summaryrefslogtreecommitdiffstats
path: root/web/server/h2o/libh2o/misc/libressl.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-03-09 13:19:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-03-09 13:20:02 +0000
commit58daab21cd043e1dc37024a7f99b396788372918 (patch)
tree96771e43bb69f7c1c2b0b4f7374cb74d7866d0cb /web/server/h2o/libh2o/misc/libressl.mk
parentReleasing debian version 1.43.2-1. (diff)
downloadnetdata-58daab21cd043e1dc37024a7f99b396788372918.tar.xz
netdata-58daab21cd043e1dc37024a7f99b396788372918.zip
Merging upstream version 1.44.3.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'web/server/h2o/libh2o/misc/libressl.mk')
-rw-r--r--web/server/h2o/libh2o/misc/libressl.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/web/server/h2o/libh2o/misc/libressl.mk b/web/server/h2o/libh2o/misc/libressl.mk
new file mode 100644
index 000000000..d20df414e
--- /dev/null
+++ b/web/server/h2o/libh2o/misc/libressl.mk
@@ -0,0 +1,12 @@
+SOURCE_DIR=.
+VERSION=2.4.5
+ARCHIVE=$(SOURCE_DIR)/libressl-$(VERSION).tar.gz
+DEST=libressl-build
+UNAME=$(shell uname -s)
+
+all: $(DEST)/lib/libssl.a
+
+$(DEST)/lib/libssl.a: $(ARCHIVE)
+ if [ ! -e "libressl-$(VERSION)" ] ; then tar xzf "$(ARCHIVE)" ; fi
+ if [ ! -e "libressl-$(VERSION)/Makefile" ] ; then (P=`pwd`/$(DEST); cd libressl-$(VERSION) && ./configure --prefix="$$P" --libdir="$$P/lib" --disable-shared `test "$(UNAME)" = "Darwin" && echo '--disable-asm'`) ; fi
+ (cd libressl-$(VERSION) && make && make install)