summaryrefslogtreecommitdiffstats
path: root/.gitignore
diff options
context:
space:
mode:
Diffstat (limited to '.gitignore')
-rw-r--r--.gitignore14
1 files changed, 14 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
index 46371060c..ecf2b648f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -7,6 +7,9 @@ gcs-credentials.json
.project
.pydevproject
+# local dev outputs
+dist/
+
*.o
*.a
config.h.in
@@ -82,6 +85,9 @@ packaging/installer/.environment.sh
# netdata makeself downloads
packaging/makeself/tmp/
+# Libbpf is always overwritten depending of kernel version
+packaging/libbpf.*
+
# coverity
cov-int/
netdata-coverity-analysis.tgz
@@ -165,6 +171,7 @@ diagrams/plantuml.jar
# cppcheck
cppcheck-build/
+# python virtual environment
venv/
# debugging / profiling
@@ -209,3 +216,10 @@ netdata.cbp
# External dependencies
externaldeps/
+
+# vim sessions
+Session.vim
+Session.*.vim
+
+# Special exceptions
+!packaging/repoconfig/Makefile