summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5088d1381..ddce9882b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -458,6 +458,11 @@ set(DISKSPACE_PLUGIN_FILES
collectors/diskspace.plugin/plugin_diskspace.c
)
+set(TIMEX_PLUGIN_FILES
+ collectors/timex.plugin/plugin_timex.h
+ collectors/timex.plugin/plugin_timex.c
+ )
+
set(FREEIPMI_PLUGIN_FILES
collectors/freeipmi.plugin/freeipmi_plugin.c
)
@@ -483,6 +488,8 @@ set(EBPF_PROCESS_PLUGIN_FILES
collectors/ebpf.plugin/ebpf.h
collectors/ebpf.plugin/ebpf_cachestat.c
collectors/ebpf.plugin/ebpf_cachestat.h
+ collectors/ebpf.plugin/ebpf_dcstat.c
+ collectors/ebpf.plugin/ebpf_dcstat.h
collectors/ebpf.plugin/ebpf_process.c
collectors/ebpf.plugin/ebpf_process.h
collectors/ebpf.plugin/ebpf_socket.c
@@ -823,6 +830,8 @@ set(DAEMON_FILES
daemon/daemon.h
daemon/global_statistics.c
daemon/global_statistics.h
+ daemon/analytics.c
+ daemon/analytics.h
daemon/main.c
daemon/main.h
daemon/signals.c
@@ -984,6 +993,7 @@ IF(LINUX)
add_executable(netdata config.h ${NETDATA_FILES}
${CGROUPS_PLUGIN_FILES}
${DISKSPACE_PLUGIN_FILES}
+ ${TIMEX_PLUGIN_FILES}
${PROC_PLUGIN_FILES}
${TC_PLUGIN_FILES}
)