summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am355
1 files changed, 336 insertions, 19 deletions
diff --git a/Makefile.am b/Makefile.am
index 2625dcc56..1846d1e1c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -60,12 +60,32 @@ dist_noinst_DATA = \
package.json \
docs \
packaging/version \
+ packaging/dashboard.version \
+ packaging/dashboard.checksums \
packaging/go.d.version \
packaging/go.d.checksums \
+ packaging/jsonc.version \
+ packaging/jsonc.checksums \
+ packaging/judy.version \
+ packaging/judy.checksums \
+ packaging/libwebsockets.version \
+ packaging/libwebsockets.checksums \
+ packaging/mosquitto.version \
+ packaging/mosquitto.checksums \
+ packaging/bundle-dashboard.sh \
+ packaging/bundle-ebpf.sh \
+ packaging/bundle-judy.sh \
+ packaging/bundle-libbpf.sh \
+ packaging/bundle-mosquitto.sh \
+ packaging/check-kernel-config.sh \
+ packaging/libbpf.checksums \
+ packaging/libbpf.version \
+ packaging/ebpf.checksums \
+ packaging/ebpf.version \
+ packaging/bundle-lws.sh \
packaging/installer/README.md \
packaging/installer/UNINSTALL.md \
packaging/installer/UPDATE.md \
- netlify.toml \
$(NULL)
# until integrated within build
@@ -77,12 +97,7 @@ dist_noinst_SCRIPTS = \
packaging/installer/kickstart.sh \
packaging/installer/kickstart-static64.sh \
packaging/installer/functions.sh \
- netdata-installer.sh \
- docs/generator/buildhtml.sh \
- docs/generator/buildyaml.sh \
- docs/generator/checklinks.sh \
- docs/generator/requirements.txt \
- docs/generator/runtime.txt \
+ netdata-installer.sh
$(NULL)
# -----------------------------------------------------------------------------
@@ -93,11 +108,16 @@ SUBDIRS += \
collectors \
daemon \
database \
+ exporting \
health \
libnetdata \
registry \
streaming \
web \
+ claim \
+ parser \
+ aclk/legacy \
+ spawn \
$(NULL)
@@ -106,17 +126,15 @@ AM_CFLAGS = \
$(OPTIONAL_NFACCT_CFLAGS) \
$(OPTIONAL_ZLIB_CFLAGS) \
$(OPTIONAL_UUID_CFLAGS) \
+ $(OPTIONAL_MQTT_CFLAGS) \
$(OPTIONAL_LIBCAP_LIBS) \
$(OPTIONAL_IPMIMONITORING_CFLAGS) \
$(OPTIONAL_CUPS_CFLAGS) \
$(OPTIONAL_XENSTAT_CFLAGS) \
+ $(OPTIONAL_BPF_CFLAGS) \
$(NULL)
sbin_PROGRAMS =
-dist_cache_DATA = packaging/installer/.keep
-dist_varlib_DATA = packaging/installer/.keep
-dist_registry_DATA = packaging/installer/.keep
-dist_log_DATA = packaging/installer/.keep
plugins_PROGRAMS =
LIBNETDATA_FILES = \
@@ -128,6 +146,8 @@ LIBNETDATA_FILES = \
libnetdata/avl/avl.h \
libnetdata/buffer/buffer.c \
libnetdata/buffer/buffer.h \
+ libnetdata/circular_buffer/circular_buffer.c \
+ libnetdata/circular_buffer/circular_buffer.h \
libnetdata/clocks/clocks.c \
libnetdata/clocks/clocks.h \
libnetdata/dictionary/dictionary.c \
@@ -171,6 +191,13 @@ LIBNETDATA_FILES = \
libnetdata/string/utf8.h \
$(NULL)
+if ENABLE_PLUGIN_EBPF
+ LIBNETDATA_FILES += \
+ libnetdata/ebpf/ebpf.c \
+ libnetdata/ebpf/ebpf.h \
+ $(NULL)
+endif
+
APPS_PLUGIN_FILES = \
collectors/apps.plugin/apps_plugin.c \
$(LIBNETDATA_FILES) \
@@ -252,6 +279,18 @@ PERF_PLUGIN_FILES = \
$(LIBNETDATA_FILES) \
$(NULL)
+EBPF_PLUGIN_FILES = \
+ collectors/ebpf.plugin/ebpf.c \
+ collectors/ebpf.plugin/ebpf_process.c \
+ collectors/ebpf.plugin/ebpf_process.h \
+ collectors/ebpf.plugin/ebpf_socket.c \
+ collectors/ebpf.plugin/ebpf_socket.h \
+ collectors/ebpf.plugin/ebpf.h \
+ collectors/ebpf.plugin/ebpf_apps.c \
+ collectors/ebpf.plugin/ebpf_apps.h \
+ $(LIBNETDATA_FILES) \
+ $(NULL)
+
PROC_PLUGIN_FILES = \
collectors/proc.plugin/ipc.c \
collectors/proc.plugin/plugin_proc.c \
@@ -263,7 +302,10 @@ PROC_PLUGIN_FILES = \
collectors/proc.plugin/proc_loadavg.c \
collectors/proc.plugin/proc_meminfo.c \
collectors/proc.plugin/proc_pagetypeinfo.c \
+ collectors/proc.plugin/proc_pressure.c \
+ collectors/proc.plugin/proc_pressure.h \
collectors/proc.plugin/proc_net_dev.c \
+ collectors/proc.plugin/proc_net_wireless.c \
collectors/proc.plugin/proc_net_ip_vs_stats.c \
collectors/proc.plugin/proc_net_netstat.c \
collectors/proc.plugin/proc_net_rpc_nfs.c \
@@ -291,6 +333,7 @@ PROC_PLUGIN_FILES = \
collectors/proc.plugin/sys_devices_system_node.c \
collectors/proc.plugin/sys_fs_btrfs.c \
collectors/proc.plugin/sys_class_power_supply.c \
+ collectors/proc.plugin/sys_class_infiniband.c \
$(NULL)
TC_PLUGIN_FILES = \
@@ -309,6 +352,8 @@ MACOS_PLUGIN_FILES = \
PLUGINSD_PLUGIN_FILES = \
collectors/plugins.d/plugins_d.c \
collectors/plugins.d/plugins_d.h \
+ collectors/plugins.d/pluginsd_parser.c \
+ collectors/plugins.d/pluginsd_parser.h \
$(NULL)
RRD_PLUGIN_FILES = \
@@ -321,6 +366,7 @@ RRD_PLUGIN_FILES = \
database/rrddimvar.h \
database/rrdfamily.c \
database/rrdhost.c \
+ database/rrdlabels.c \
database/rrd.c \
database/rrd.h \
database/rrdset.c \
@@ -332,6 +378,10 @@ RRD_PLUGIN_FILES = \
if ENABLE_DBENGINE
RRD_PLUGIN_FILES += \
+ database/sqlite/sqlite_functions.c \
+ database/sqlite/sqlite_functions.h \
+ database/sqlite/sqlite3.c \
+ database/sqlite/sqlite3.h \
database/engine/rrdengine.c \
database/engine/rrdengine.h \
database/engine/rrddiskprotocol.h \
@@ -347,6 +397,16 @@ if ENABLE_DBENGINE
database/engine/pagecache.h \
database/engine/rrdenglocking.c \
database/engine/rrdenglocking.h \
+ database/engine/metadata_log/metadatalog.h \
+ database/engine/metadata_log/metadatalogapi.c \
+ database/engine/metadata_log/metadatalogapi.h \
+ database/engine/metadata_log/logfile.h \
+ database/engine/metadata_log/logfile.c \
+ database/engine/metadata_log/metadatalogprotocol.h \
+ database/engine/metadata_log/metalogpluginsd.c \
+ database/engine/metadata_log/metalogpluginsd.h \
+ database/engine/metadata_log/compaction.c \
+ database/engine/metadata_log/compaction.h \
$(NULL)
endif
@@ -403,6 +463,8 @@ API_PLUGIN_FILES = \
STREAMING_PLUGIN_FILES = \
streaming/rrdpush.c \
+ streaming/sender.c \
+ streaming/receiver.c \
streaming/rrdpush.h \
$(NULL)
@@ -451,6 +513,97 @@ BACKENDS_PLUGIN_FILES = \
backends/prometheus/backend_prometheus.h \
$(NULL)
+CLAIM_FILES = \
+ claim/claim.c \
+ claim/claim.h \
+ $(NULL)
+
+PARSER_FILES = \
+ parser/parser.c \
+ parser/parser.h \
+ $(NULL)
+
+ACLK_FILES = \
+ aclk/legacy/aclk_rrdhost_state.h \
+ aclk/legacy/aclk_common.c \
+ aclk/legacy/aclk_common.h \
+ aclk/legacy/aclk_stats.c \
+ aclk/legacy/aclk_stats.h \
+ $(NULL)
+
+if ENABLE_ACLK
+ACLK_FILES += \
+ aclk/legacy/agent_cloud_link.c \
+ aclk/legacy/agent_cloud_link.h \
+ aclk/legacy/aclk_query.c \
+ aclk/legacy/aclk_query.h \
+ aclk/legacy/mqtt.c \
+ aclk/legacy/mqtt.h \
+ aclk/legacy/aclk_rx_msgs.c \
+ aclk/legacy/aclk_rx_msgs.h \
+ aclk/legacy/aclk_lws_wss_client.c \
+ aclk/legacy/aclk_lws_wss_client.h \
+ aclk/legacy/aclk_lws_https_client.c \
+ aclk/legacy/aclk_lws_https_client.h \
+ $(NULL)
+endif
+
+
+
+SPAWN_PLUGIN_FILES = \
+ spawn/spawn.c \
+ spawn/spawn_server.c \
+ spawn/spawn_client.c \
+ spawn/spawn.h \
+ $(NULL)
+
+EXPORTING_ENGINE_FILES = \
+ exporting/exporting_engine.c \
+ exporting/exporting_engine.h \
+ exporting/graphite/graphite.c \
+ exporting/graphite/graphite.h \
+ exporting/json/json.c \
+ exporting/json/json.h \
+ exporting/opentsdb/opentsdb.c \
+ exporting/opentsdb/opentsdb.h \
+ exporting/prometheus/prometheus.c \
+ exporting/prometheus/prometheus.h \
+ exporting/read_config.c \
+ exporting/clean_connectors.c \
+ exporting/init_connectors.c \
+ exporting/process_data.c \
+ exporting/check_filters.c \
+ exporting/send_data.c \
+ exporting/send_internal_metrics.c \
+ $(NULL)
+
+PROMETHEUS_REMOTE_WRITE_EXPORTING_FILES = \
+ exporting/prometheus/remote_write/remote_write.c \
+ exporting/prometheus/remote_write/remote_write.h \
+ exporting/prometheus/remote_write/remote_write_request.cc \
+ exporting/prometheus/remote_write/remote_write_request.h \
+ exporting/prometheus/remote_write/remote_write.proto \
+ $(NULL)
+
+KINESIS_EXPORTING_FILES = \
+ exporting/aws_kinesis/aws_kinesis.c \
+ exporting/aws_kinesis/aws_kinesis.h \
+ exporting/aws_kinesis/aws_kinesis_put_record.cc \
+ exporting/aws_kinesis/aws_kinesis_put_record.h \
+ $(NULL)
+
+PUBSUB_EXPORTING_FILES = \
+ exporting/pubsub/pubsub.c \
+ exporting/pubsub/pubsub.h \
+ exporting/pubsub/pubsub_publish.cc \
+ exporting/pubsub/pubsub_publish.h \
+ $(NULL)
+
+MONGODB_EXPORTING_FILES = \
+ exporting/mongodb/mongodb.c \
+ exporting/mongodb/mongodb.h \
+ $(NULL)
+
KINESIS_BACKEND_FILES = \
backends/aws_kinesis/aws_kinesis.c \
backends/aws_kinesis/aws_kinesis.h \
@@ -461,7 +614,6 @@ KINESIS_BACKEND_FILES = \
PROMETHEUS_REMOTE_WRITE_BACKEND_FILES = \
backends/prometheus/remote_write/remote_write.cc \
backends/prometheus/remote_write/remote_write.h \
- backends/prometheus/remote_write/remote_write.proto \
$(NULL)
MONGODB_BACKEND_FILES = \
@@ -470,6 +622,8 @@ MONGODB_BACKEND_FILES = \
$(NULL)
DAEMON_FILES = \
+ daemon/buildinfo.c \
+ daemon/buildinfo.h \
daemon/common.c \
daemon/common.h \
daemon/daemon.c \
@@ -480,6 +634,8 @@ DAEMON_FILES = \
daemon/main.h \
daemon/signals.c \
daemon/signals.h \
+ daemon/commands.c \
+ daemon/commands.h \
daemon/unit_test.c \
daemon/unit_test.h \
$(NULL)
@@ -490,6 +646,7 @@ NETDATA_FILES = \
$(LIBNETDATA_FILES) \
$(API_PLUGIN_FILES) \
$(BACKENDS_PLUGIN_FILES) \
+ $(EXPORTING_ENGINE_FILES) \
$(CHECKS_PLUGIN_FILES) \
$(HEALTH_PLUGIN_FILES) \
$(IDLEJITTER_PLUGIN_FILES) \
@@ -499,6 +656,10 @@ NETDATA_FILES = \
$(STREAMING_PLUGIN_FILES) \
$(STATSD_PLUGIN_FILES) \
$(WEB_PLUGIN_FILES) \
+ $(CLAIM_FILES) \
+ $(PARSER_FILES) \
+ $(ACLK_FILES) \
+ $(SPAWN_PLUGIN_FILES) \
$(NULL)
if FREEBSD
@@ -525,9 +686,11 @@ endif
NETDATA_COMMON_LIBS = \
$(OPTIONAL_MATH_LIBS) \
+ $(OPTIONAL_BPF_LIBS) \
$(OPTIONAL_ZLIB_LIBS) \
$(OPTIONAL_SSL_LIBS) \
$(OPTIONAL_UUID_LIBS) \
+ $(OPTIONAL_MQTT_LIBS) \
$(OPTIONAL_UV_LIBS) \
$(OPTIONAL_LZ4_LIBS) \
$(OPTIONAL_JUDY_LIBS) \
@@ -535,17 +698,50 @@ NETDATA_COMMON_LIBS = \
$(OPTIONAL_JSONC_LIBS) \
$(NULL)
+if LINK_STATIC_JSONC
+ NETDATA_COMMON_LIBS += externaldeps/jsonc/libjson-c.a
+endif
+
+NETDATACLI_FILES = \
+ daemon/commands.h \
+ $(LIBNETDATA_FILES) \
+ cli/cli.c \
+ cli/cli.h \
+ $(NULL)
+
sbin_PROGRAMS += netdata
netdata_SOURCES = $(NETDATA_FILES)
+
+if ENABLE_ACLK
+netdata_LDADD = \
+ externaldeps/mosquitto/libmosquitto.a \
+ $(OPTIONAL_LIBCAP_LIBS) \
+ $(OPTIONAL_LWS_LIBS) \
+ $(NETDATA_COMMON_LIBS) \
+ $(NULL)
+else
netdata_LDADD = \
$(NETDATA_COMMON_LIBS) \
$(NULL)
+endif
+
if ENABLE_CXX_LINKER
netdata_LINK = $(CXXLD) $(CXXFLAGS) $(LDFLAGS) -o $@
else
netdata_LINK = $(CCLD) $(CFLAGS) $(LDFLAGS) -o $@
endif
+sbin_PROGRAMS += netdatacli
+netdatacli_SOURCES = $(NETDATACLI_FILES)
+netdatacli_LDADD = \
+ $(NETDATA_COMMON_LIBS) \
+ $(NULL)
+if ENABLE_CXX_LINKER
+ netdatacli_LINK = $(CXXLD) $(CXXFLAGS) $(LDFLAGS) -o $@
+else
+ netdatacli_LINK = $(CCLD) $(CFLAGS) $(LDFLAGS) -o $@
+endif
+
if ENABLE_PLUGIN_APPS
plugins_PROGRAMS += apps.plugin
apps_plugin_SOURCES = $(APPS_PLUGIN_FILES)
@@ -572,6 +768,14 @@ if ENABLE_PLUGIN_FREEIPMI
$(NULL)
endif
+if ENABLE_PLUGIN_EBPF
+ plugins_PROGRAMS += ebpf.plugin
+ ebpf_plugin_SOURCES = $(EBPF_PLUGIN_FILES)
+ ebpf_plugin_LDADD = \
+ $(NETDATA_COMMON_LIBS) \
+ $(NULL)
+endif
+
if ENABLE_PLUGIN_CUPS
plugins_PROGRAMS += cups.plugin
cups_plugin_SOURCES = $(CUPS_PLUGIN_FILES)
@@ -616,27 +820,32 @@ if ENABLE_PLUGIN_SLABINFO
endif
if ENABLE_BACKEND_KINESIS
- netdata_SOURCES += $(KINESIS_BACKEND_FILES)
+ netdata_SOURCES += $(KINESIS_BACKEND_FILES) $(KINESIS_EXPORTING_FILES)
netdata_LDADD += $(OPTIONAL_KINESIS_LIBS)
endif
+if ENABLE_EXPORTING_PUBSUB
+ netdata_SOURCES += $(PUBSUB_EXPORTING_FILES)
+ netdata_LDADD += $(OPTIONAL_PUBSUB_LIBS)
+endif
+
if ENABLE_BACKEND_PROMETHEUS_REMOTE_WRITE
- netdata_SOURCES += $(PROMETHEUS_REMOTE_WRITE_BACKEND_FILES)
+ netdata_SOURCES += $(PROMETHEUS_REMOTE_WRITE_BACKEND_FILES) $(PROMETHEUS_REMOTE_WRITE_EXPORTING_FILES)
netdata_LDADD += $(OPTIONAL_PROMETHEUS_REMOTE_WRITE_LIBS)
BUILT_SOURCES = \
- backends/prometheus/remote_write/remote_write.pb.cc \
- backends/prometheus/remote_write/remote_write.pb.h \
+ exporting/prometheus/remote_write/remote_write.pb.cc \
+ exporting/prometheus/remote_write/remote_write.pb.h \
$(NULL)
nodist_netdata_SOURCES = $(BUILT_SOURCES)
-backends/prometheus/remote_write/remote_write.pb.cc \
-backends/prometheus/remote_write/remote_write.pb.h: backends/prometheus/remote_write/remote_write.proto
+exporting/prometheus/remote_write/remote_write.pb.cc \
+exporting/prometheus/remote_write/remote_write.pb.h: exporting/prometheus/remote_write/remote_write.proto
$(PROTOC) --proto_path=$(srcdir) --cpp_out=$(builddir) $^
endif
if ENABLE_BACKEND_MONGODB
- netdata_SOURCES += $(MONGODB_BACKEND_FILES)
+ netdata_SOURCES += $(MONGODB_BACKEND_FILES) $(MONGODB_EXPORTING_FILES)
netdata_LDADD += $(OPTIONAL_MONGOC_LIBS)
endif
@@ -644,8 +853,10 @@ if ENABLE_UNITTESTS
check_PROGRAMS = \
libnetdata/tests/str2ld_testdriver \
libnetdata/storage_number/tests/storage_number_testdriver \
+ exporting/tests/exporting_engine_testdriver \
web/api/tests/web_api_testdriver \
web/api/tests/valid_urls_testdriver \
+ collectors/cgroups_plugin/tests/cgroups_testdriver \
$(NULL)
TESTS = $(check_PROGRAMS)
@@ -707,4 +918,110 @@ if ENABLE_UNITTESTS
$(LIBNETDATA_FILES) \
$(NULL)
libnetdata_storage_number_tests_storage_number_testdriver_LDADD = $(NETDATA_COMMON_LIBS) $(TEST_LIBS)
+
+ EXPORTING_ENGINE_TEST_FILES = \
+ exporting/tests/test_exporting_engine.c \
+ exporting/tests/test_exporting_engine.h \
+ exporting/tests/exporting_fixtures.c \
+ exporting/tests/exporting_doubles.c \
+ exporting/tests/netdata_doubles.c \
+ exporting/tests/system_doubles.c \
+ $(NULL)
+ exporting_tests_exporting_engine_testdriver_SOURCES = \
+ $(EXPORTING_ENGINE_TEST_FILES) \
+ $(EXPORTING_ENGINE_FILES) \
+ $(LIBNETDATA_FILES) \
+ $(NULL)
+ exporting_tests_exporting_engine_testdriver_CFLAGS = \
+ $(AM_CFLAGS) \
+ -DUNIT_TESTING \
+ $(NULL)
+ exporting_tests_exporting_engine_testdriver_LDFLAGS = \
+ -Wl,--wrap=read_exporting_config \
+ -Wl,--wrap=init_connectors \
+ -Wl,--wrap=mark_scheduled_instances \
+ -Wl,--wrap=rrdhost_is_exportable \
+ -Wl,--wrap=rrdset_is_exportable \
+ -Wl,--wrap=exporting_calculate_value_from_stored_data \
+ -Wl,--wrap=prepare_buffers \
+ -Wl,--wrap=send_internal_metrics \
+ -Wl,--wrap=now_realtime_sec \
+ -Wl,--wrap=uv_thread_set_name_np \
+ -Wl,--wrap=uv_thread_create \
+ -Wl,--wrap=uv_mutex_lock \
+ -Wl,--wrap=uv_mutex_unlock \
+ -Wl,--wrap=uv_cond_signal \
+ -Wl,--wrap=uv_cond_wait \
+ -Wl,--wrap=strdupz \
+ -Wl,--wrap=info_int \
+ -Wl,--wrap=recv \
+ -Wl,--wrap=send \
+ -Wl,--wrap=connect_to_one_of \
+ -Wl,--wrap=create_main_rusage_chart \
+ -Wl,--wrap=send_main_rusage \
+ -Wl,--wrap=simple_connector_end_batch \
+ $(TEST_LDFLAGS) \
+ $(NULL)
+ exporting_tests_exporting_engine_testdriver_LDADD = $(NETDATA_COMMON_LIBS) $(TEST_LIBS)
+if ENABLE_BACKEND_PROMETHEUS_REMOTE_WRITE
+ exporting_tests_exporting_engine_testdriver_SOURCES += $(PROMETHEUS_REMOTE_WRITE_EXPORTING_FILES)
+ exporting_tests_exporting_engine_testdriver_LDADD += $(OPTIONAL_PROMETHEUS_REMOTE_WRITE_LIBS)
+ exporting_tests_exporting_engine_testdriver_LDFLAGS += \
+ -Wl,--wrap=init_write_request \
+ -Wl,--wrap=add_host_info \
+ -Wl,--wrap=add_label \
+ -Wl,--wrap=add_metric \
+ $(NULL)
+ nodist_exporting_tests_exporting_engine_testdriver_SOURCES = $(BUILT_SOURCES)
+endif
+if ENABLE_BACKEND_KINESIS
+ exporting_tests_exporting_engine_testdriver_SOURCES += $(KINESIS_EXPORTING_FILES)
+ exporting_tests_exporting_engine_testdriver_LDADD += $(OPTIONAL_KINESIS_LIBS)
+ exporting_tests_exporting_engine_testdriver_LDFLAGS += \
+ -Wl,--wrap=aws_sdk_init \
+ -Wl,--wrap=kinesis_init \
+ -Wl,--wrap=kinesis_put_record \
+ -Wl,--wrap=kinesis_get_result \
+ $(NULL)
+endif
+if ENABLE_EXPORTING_PUBSUB
+ exporting_tests_exporting_engine_testdriver_SOURCES += $(PUBSUB_EXPORTING_FILES)
+ exporting_tests_exporting_engine_testdriver_LDADD += $(OPTIONAL_PUBSUB_LIBS)
+ exporting_tests_exporting_engine_testdriver_LDFLAGS += \
+ -Wl,--wrap=pubsub_init \
+ -Wl,--wrap=pubsub_add_message \
+ -Wl,--wrap=pubsub_publish \
+ -Wl,--wrap=pubsub_get_result \
+ $(NULL)
+endif
+if ENABLE_BACKEND_MONGODB
+ exporting_tests_exporting_engine_testdriver_SOURCES += $(MONGODB_EXPORTING_FILES)
+ exporting_tests_exporting_engine_testdriver_LDADD += $(OPTIONAL_MONGOC_LIBS)
+ exporting_tests_exporting_engine_testdriver_LDFLAGS += \
+ -Wl,--wrap=mongoc_init \
+ -Wl,--wrap=mongoc_uri_new_with_error \
+ -Wl,--wrap=mongoc_uri_get_option_as_int32 \
+ -Wl,--wrap=mongoc_uri_set_option_as_int32 \
+ -Wl,--wrap=mongoc_client_new_from_uri \
+ -Wl,--wrap=mongoc_client_set_appname \
+ -Wl,--wrap=mongoc_client_get_collection \
+ -Wl,--wrap=mongoc_uri_destroy \
+ -Wl,--wrap=mongoc_collection_insert_many \
+ $(NULL)
+endif
+
+ collectors_cgroups_plugin_tests_cgroups_testdriver_SOURCES = \
+ collectors/cgroups.plugin/tests/test_cgroups_plugin.c \
+ collectors/cgroups.plugin/tests/test_cgroups_plugin.h \
+ collectors/cgroups.plugin/tests/test_doubles.c \
+ $(CGROUPS_PLUGIN_FILES) \
+ database/rrdlabels.c \
+ database/rrd.h \
+ $(LIBNETDATA_FILES) \
+ $(NULL)
+ collectors_cgroups_plugin_tests_cgroups_testdriver_LDADD = $(NETDATA_COMMON_LIBS) $(TEST_LIBS)
+ collectors_cgroups_plugin_tests_cgroups_testdriver_LDFLAGS = \
+ -Wl,--wrap=add_label_to_list \
+ $(NULL)
+
endif