summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 84bf4c9da..e0e85d288 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -154,6 +154,8 @@ LIBNETDATA_FILES = \
libnetdata/dictionary/dictionary.h \
libnetdata/eval/eval.c \
libnetdata/eval/eval.h \
+ libnetdata/facets/facets.c \
+ libnetdata/facets/facets.h \
libnetdata/gorilla/gorilla.h \
libnetdata/gorilla/gorilla.cc \
libnetdata/inlined.h \
@@ -200,6 +202,8 @@ LIBNETDATA_FILES = \
libnetdata/worker_utilization/worker_utilization.c \
libnetdata/worker_utilization/worker_utilization.h \
libnetdata/http/http_defs.h \
+ libnetdata/dyn_conf/dyn_conf.c \
+ libnetdata/dyn_conf/dyn_conf.h \
$(NULL)
if ENABLE_PLUGIN_EBPF
@@ -219,6 +223,7 @@ DEBUGFS_PLUGIN_FILES = \
collectors/debugfs.plugin/debugfs_plugin.h \
collectors/debugfs.plugin/debugfs_extfrag.c \
collectors/debugfs.plugin/debugfs_zswap.c \
+ collectors/debugfs.plugin/sys_devices_virtual_powercap.c \
$(LIBNETDATA_FILES) \
$(NULL)
@@ -299,6 +304,11 @@ FREEIPMI_PLUGIN_FILES = \
$(LIBNETDATA_FILES) \
$(NULL)
+SYSTEMD_JOURNAL_PLUGIN_FILES = \
+ collectors/systemd-journal.plugin/systemd-journal.c \
+ $(LIBNETDATA_FILES) \
+ $(NULL)
+
CUPS_PLUGIN_FILES = \
collectors/cups.plugin/cups_plugin.c \
$(LIBNETDATA_FILES) \
@@ -408,10 +418,12 @@ PROC_PLUGIN_FILES = \
collectors/proc.plugin/sys_kernel_mm_ksm.c \
collectors/proc.plugin/sys_block_zram.c \
collectors/proc.plugin/sys_devices_system_edac_mc.c \
+ collectors/proc.plugin/sys_devices_pci_aer.c \
collectors/proc.plugin/sys_devices_system_node.c \
collectors/proc.plugin/sys_fs_btrfs.c \
collectors/proc.plugin/sys_class_power_supply.c \
collectors/proc.plugin/sys_class_infiniband.c \
+ collectors/proc.plugin/sys_class_drm.c \
$(NULL)
PROFILE_PLUGIN_FILES = \
@@ -1228,6 +1240,15 @@ if ENABLE_PLUGIN_FREEIPMI
$(NULL)
endif
+if ENABLE_PLUGIN_SYSTEMD_JOURNAL
+ plugins_PROGRAMS += systemd-journal.plugin
+ systemd_journal_plugin_SOURCES = $(SYSTEMD_JOURNAL_PLUGIN_FILES)
+ systemd_journal_plugin_LDADD = \
+ $(NETDATA_COMMON_LIBS) \
+ $(OPTIONAL_SYSTEMD_LIBS) \
+ $(NULL)
+endif
+
if ENABLE_PLUGIN_EBPF
plugins_PROGRAMS += ebpf.plugin
ebpf_plugin_SOURCES = $(EBPF_PLUGIN_FILES)