summaryrefslogtreecommitdiffstats
path: root/collectors/node.d.plugin/README.md
diff options
context:
space:
mode:
Diffstat (limited to 'collectors/node.d.plugin/README.md')
-rw-r--r--collectors/node.d.plugin/README.md16
1 files changed, 15 insertions, 1 deletions
diff --git a/collectors/node.d.plugin/README.md b/collectors/node.d.plugin/README.md
index dd977017d..af8708c7b 100644
--- a/collectors/node.d.plugin/README.md
+++ b/collectors/node.d.plugin/README.md
@@ -9,7 +9,21 @@
5. Allows each **module** to have one or more data collection **jobs**
6. Each **job** is collecting one or more metrics from a single data source
-# Motivation
+## Pull Request Checklist for Node.js Plugins
+
+This is a generic checklist for submitting a new Node.js plugin for Netdata. It is by no means comprehensive.
+
+At minimum, to be buildable and testable, the PR needs to include:
+
+* The module itself, following proper naming conventions: `node.d/<module_dir>/<module_name>.node.js`
+* A README.md file for the plugin.
+* The configuration file for the module
+* A basic configuration for the plugin in the appropriate global config file: `conf.d/node.d.conf`, which is also in JSON format. If the module should be enabled by default, add a section for it in the `modules` dictionary.
+* A line for the plugin in the appropriate `Makefile.am` file: `node.d/Makefile.am` under `dist_node_DATA`.
+* A line for the plugin configuration file in `conf.d/Makefile.am`: under `dist_nodeconfig_DATA`
+* Optionally, chart information in `web/dashboard_info.js`. This generally involves specifying a name and icon for the section, and may include descriptions for the section or individual charts.
+
+## Motivation
Node.js is perfect for asynchronous operations. It is very fast and quite common (actually the whole web is based on it).
Since data collection is not a CPU intensive task, node.js is an ideal solution for it.