summaryrefslogtreecommitdiffstats
path: root/collectors/node.d.plugin/snmp
diff options
context:
space:
mode:
Diffstat (limited to 'collectors/node.d.plugin/snmp')
-rw-r--r--collectors/node.d.plugin/snmp/Makefile.inc13
-rw-r--r--collectors/node.d.plugin/snmp/README.md445
-rw-r--r--collectors/node.d.plugin/snmp/snmp.node.js527
3 files changed, 0 insertions, 985 deletions
diff --git a/collectors/node.d.plugin/snmp/Makefile.inc b/collectors/node.d.plugin/snmp/Makefile.inc
deleted file mode 100644
index 26448a1ce..000000000
--- a/collectors/node.d.plugin/snmp/Makefile.inc
+++ /dev/null
@@ -1,13 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# THIS IS NOT A COMPLETE Makefile
-# IT IS INCLUDED BY ITS PARENT'S Makefile.am
-# IT IS REQUIRED TO REFERENCE ALL FILES RELATIVE TO THE PARENT
-
-# install these files
-dist_node_DATA += snmp/snmp.node.js
-# dist_nodeconfig_DATA += snmp/snmp.conf
-
-# do not install these files, but include them in the distribution
-dist_noinst_DATA += snmp/README.md snmp/Makefile.inc
-
diff --git a/collectors/node.d.plugin/snmp/README.md b/collectors/node.d.plugin/snmp/README.md
deleted file mode 100644
index 2df94c7b5..000000000
--- a/collectors/node.d.plugin/snmp/README.md
+++ /dev/null
@@ -1,445 +0,0 @@
-<!--
-title: "SNMP device monitoring with Netdata"
-custom_edit_url: https://github.com/netdata/netdata/edit/master/collectors/node.d.plugin/snmp/README.md
-sidebar_label: "SNMP"
--->
-
-# SNMP device monitoring with Netdata
-
-Collects data from any SNMP device and uses the [net-snmp](https://github.com/markabrahams/node-net-snmp) module.
-
-It supports:
-
-- all SNMP versions: SNMPv1, SNMPv2c and SNMPv3
-- any number of SNMP devices
-- each SNMP device can be used to collect data for any number of charts
-- each chart may have any number of dimensions
-- each SNMP device may have a different update frequency
-- each SNMP device will accept one or more batches to report values (you can set `max_request_size` per SNMP server, to control the size of batches).
-
-## Requirements
-
-- `nodejs` minimum required version 4
-
-## Configuration
-
-You will need to create the file `/etc/netdata/node.d/snmp.conf` with data like the following.
-
-In this example:
-
-- the SNMP device is `10.11.12.8`.
-- the SNMP community is `public`.
-- we will update the values every 10 seconds (`update_every: 10` under the server `10.11.12.8`).
-- we define 2 charts `snmp_switch.bandwidth_port1` and `snmp_switch.bandwidth_port2`, each having 2 dimensions: `in` and `out`. Note that the charts and dimensions must not contain any white space or special characters, other than `.` and `_`.
-
-```json
-{
- "enable_autodetect": false,
- "update_every": 5,
- "max_request_size": 100,
- "servers": [
- {
- "hostname": "10.11.12.8",
- "community": "public",
- "update_every": 10,
- "max_request_size": 50,
- "options": {
- "timeout": 10000
- },
- "charts": {
- "snmp_switch.bandwidth_port1": {
- "title": "Switch Bandwidth for port 1",
- "units": "kilobits/s",
- "type": "area",
- "priority": 1,
- "family": "ports",
- "dimensions": {
- "in": {
- "oid": "1.3.6.1.2.1.2.2.1.10.1",
- "algorithm": "incremental",
- "multiplier": 8,
- "divisor": 1024,
- "offset": 0
- },
- "out": {
- "oid": "1.3.6.1.2.1.2.2.1.16.1",
- "algorithm": "incremental",
- "multiplier": -8,
- "divisor": 1024,
- "offset": 0
- }
- }
- },
- "snmp_switch.bandwidth_port2": {
- "title": "Switch Bandwidth for port 2",
- "units": "kilobits/s",
- "type": "area",
- "priority": 1,
- "family": "ports",
- "dimensions": {
- "in": {
- "oid": "1.3.6.1.2.1.2.2.1.10.2",
- "algorithm": "incremental",
- "multiplier": 8,
- "divisor": 1024,
- "offset": 0
- },
- "out": {
- "oid": "1.3.6.1.2.1.2.2.1.16.2",
- "algorithm": "incremental",
- "multiplier": -8,
- "divisor": 1024,
- "offset": 0
- }
- }
- }
- }
- }
- ]
-}
-```
-
-`update_every` is the update frequency for each server, in seconds.
-
-`max_request_size` limits the maximum number of OIDs that will be requested in a single call. The default is 50. Lower this number of you get `TooBig` errors in Netdata's `error.log`.
-
-`family` sets the name of the submenu of the dashboard each chart will appear under.
-
-`multiplier` and `divisor` are passed by the plugin to the Netdata daemon and are applied to the metric to convert it properly to `units`. For incremental counters with the exception of Counter64 type metrics, `offset` is added to the metric from within the SNMP plugin. This means that the value you will see in debug mode in the `DEBUG: setting current chart to... SET` line for a metric will not have been multiplied or divided, but it will have had the offset added to it.
-
-<details markdown="1"><summary><b>Caution: Counter64 metrics do not support `offset` (issue #5028).</b></summary>
-The SNMP plugin supports Counter64 metrics with the only limitation that the `offset` parameter should not be defined. Due to the way Javascript handles large numbers and the fact that the offset is applied to metrics inside the plugin, the offset will be ignored silently.
-</details>
-
-If you need to define many charts using incremental OIDs, you can use something like this:
-
-```json
-{
- "enable_autodetect": false,
- "update_every": 10,
- "servers": [
- {
- "hostname": "10.11.12.8",
- "community": "public",
- "update_every": 10,
- "options": {
- "timeout": 20000
- },
- "charts": {
- "snmp_switch.bandwidth_port": {
- "title": "Switch Bandwidth for port ",
- "units": "kilobits/s",
- "type": "area",
- "priority": 1,
- "family": "ports",
- "multiply_range": [
- 1,
- 24
- ],
- "dimensions": {
- "in": {
- "oid": "1.3.6.1.2.1.2.2.1.10.",
- "algorithm": "incremental",
- "multiplier": 8,
- "divisor": 1024,
- "offset": 0
- },
- "out": {
- "oid": "1.3.6.1.2.1.2.2.1.16.",
- "algorithm": "incremental",
- "multiplier": -8,
- "divisor": 1024,
- "offset": 0
- }
- }
- }
- }
- }
- ]
-}
-```
-
-This is like the previous, but the option `multiply_range` given, will multiply the current chart from `1` to `24` inclusive, producing 24 charts in total for the 24 ports of the switch `10.11.12.8`.
-
-Each of the 24 new charts will have its id (1-24) appended at:
-
-1. its chart unique id, i.e. `snmp_switch.bandwidth_port1` to `snmp_switch.bandwidth_port24`
-2. its `title`, i.e. `Switch Bandwidth for port 1` to `Switch Bandwidth for port 24`
-3. its `oid` (for all dimensions), i.e. dimension `in` will be `1.3.6.1.2.1.2.2.1.10.1` to `1.3.6.1.2.1.2.2.1.10.24`
-4. its priority (which will be incremented for each chart so that the charts will appear on the dashboard in this order)
-
-The `options` given for each server, are:
-
-- `port` - UDP port to send requests too. Defaults to `161`.
-- `retries` - number of times to re-send a request. Defaults to `1`.
-- `sourceAddress` - IP address from which SNMP requests should originate, there is no default for this option, the operating system will select an appropriate source address when the SNMP request is sent.
-- `sourcePort` - UDP port from which SNMP requests should originate, defaults to an ephemeral port selected by the operation system.
-- `timeout` - number of milliseconds to wait for a response before re-trying or failing. Defaults to `5000`.
-- `transport` - specify the transport to use, can be either `udp4` or `udp6`. Defaults to `udp4`.
-- `version` - either `0` (v1) or `1` (v2) or `3` (v3). Defaults to `0`.
-- `idBitsSize` - either `16` or `32`. Defaults to `32`. Used to reduce the size of the generated id for compatibility with some older devices.
-
-## SNMPv3
-
-To use SNMPv3:
-
-- use `user` instead of `community`
-- set `version` to 3
-
-User syntax:
-
-```json
-{
- "enable_autodetect": false,
- "update_every": 10,
- "servers": [
- {
- "hostname": "10.11.12.8",
- "user": {
- "name": "userName",
- "level": 3,
- "authProtocol": "3",
- "authKey": "authKey",
- "privProtocol": "2",
- "privKey": "privKey"
- },
- "update_every": 10,
- "options": {
- "version": 3
- },
- "charts": {
- }
- }
- ]
-}
-```
-
-Security levels (`level`):
-
-- 1 is `noAuthNoPriv`
-- 2 is `authNoPriv`
-- 3 is `authPriv`
-
-Authentication protocols (`authProtocol`):
-
-- "1" is `none`
-- "2" is `md5`
-- "3" is `sha`
-
-Privacy protocols (`privProtocol`):
-
-- "1" is `none`
-- "2" is `des`
-
-For additional details please see [net-snmp module readme](https://github.com/markabrahams/node-net-snmp#snmpcreatev3session-target-user-options).
-
-## Retrieving names from snmp
-
-You can append a value retrieved from SNMP to the title, by adding `titleoid` to the chart.
-
-You can set a dimension name to a value retrieved from SNMP, by adding `oidname` to the dimension.
-
-Both of the above will participate in `multiply_range`.
-
-## Testing the configuration
-
-To test it, you can run:
-
-```sh
-/usr/libexec/netdata/plugins.d/node.d.plugin 1 snmp
-```
-
-The above will run it on your console and you will be able to see what Netdata sees, but also errors. You can get a very detailed output by appending `debug` to the command line.
-
-If it works, restart Netdata to activate the snmp collector and refresh the dashboard (if your SNMP device responds with a delay, you may need to refresh the dashboard in a few seconds).
-
-## Data collection speed
-
-Keep in mind that many SNMP switches and routers are very slow. They may not be able to report values per second. If you run `node.d.plugin` in `debug` mode, it will report the time it took for the SNMP device to respond. My switch, for example, needs 7-8 seconds to respond for the traffic on 24 ports (48 OIDs, in/out).
-
-Also, if you use many SNMP clients on the same SNMP device at the same time, values may be skipped. This is a problem of the SNMP device, not this collector.
-
-## Finding OIDs
-
-Use `snmpwalk`, like this:
-
-```sh
-snmpwalk -t 20 -v 1 -O fn -c public 10.11.12.8
-```
-
-- `-t 20` is the timeout in seconds
-- `-v 1` is the SNMP version
-- `-O fn` will display full OIDs in numeric format (you may want to run it also without this option to see human readable output of OIDs)
-- `-c public` is the SNMP community
-- `10.11.12.8` is the SNMP device
-
-Keep in mind that `snmpwalk` outputs the OIDs with a dot in front them. You should remove this dot when adding OIDs to the configuration file of this collector.
-
-## Example: Linksys SRW2024P
-
-This is what I use for my Linksys SRW2024P. It creates:
-
-1. A chart for power consumption (it is a PoE switch)
-2. Two charts for packets received (total packets received and packets received with errors)
-3. One chart for packets output
-4. 24 charts, one for each port of the switch. It also appends the port names, as defined at the switch, to the chart titles.
-
-This switch also reports various other metrics, like snmp, packets per port, etc. Unfortunately it does not report CPU utilization or backplane utilization.
-
-This switch has a very slow SNMP processors. To respond, it needs about 8 seconds, so I have set the refresh frequency (`update_every`) to 15 seconds.
-
-```json
-{
- "enable_autodetect": false,
- "update_every": 5,
- "servers": [
- {
- "hostname": "10.11.12.8",
- "community": "public",
- "update_every": 15,
- "options": {
- "timeout": 20000,
- "version": 1
- },
- "charts": {
- "snmp_switch.power": {
- "title": "Switch Power Supply",
- "units": "watts",
- "type": "line",
- "priority": 10,
- "family": "power",
- "dimensions": {
- "supply": {
- "oid": ".1.3.6.1.2.1.105.1.3.1.1.2.1",
- "algorithm": "absolute",
- "multiplier": 1,
- "divisor": 1,
- "offset": 0
- },
- "used": {
- "oid": ".1.3.6.1.2.1.105.1.3.1.1.4.1",
- "algorithm": "absolute",
- "multiplier": 1,
- "divisor": 1,
- "offset": 0
- }
- }
- },
- "snmp_switch.input": {
- "title": "Switch Packets Input",
- "units": "packets/s",
- "type": "area",
- "priority": 20,
- "family": "IP",
- "dimensions": {
- "receives": {
- "oid": ".1.3.6.1.2.1.4.3.0",
- "algorithm": "incremental",
- "multiplier": 1,
- "divisor": 1,
- "offset": 0
- },
- "discards": {
- "oid": ".1.3.6.1.2.1.4.8.0",
- "algorithm": "incremental",
- "multiplier": 1,
- "divisor": 1,
- "offset": 0
- }
- }
- },
- "snmp_switch.input_errors": {
- "title": "Switch Received Packets with Errors",
- "units": "packets/s",
- "type": "line",
- "priority": 30,
- "family": "IP",
- "dimensions": {
- "bad_header": {
- "oid": ".1.3.6.1.2.1.4.4.0",
- "algorithm": "incremental",
- "multiplier": 1,
- "divisor": 1,
- "offset": 0
- },
- "bad_address": {
- "oid": ".1.3.6.1.2.1.4.5.0",
- "algorithm": "incremental",
- "multiplier": 1,
- "divisor": 1,
- "offset": 0
- },
- "unknown_protocol": {
- "oid": ".1.3.6.1.2.1.4.7.0",
- "algorithm": "incremental",
- "multiplier": 1,
- "divisor": 1,
- "offset": 0
- }
- }
- },
- "snmp_switch.output": {
- "title": "Switch Output Packets",
- "units": "packets/s",
- "type": "line",
- "priority": 40,
- "family": "IP",
- "dimensions": {
- "requests": {
- "oid": ".1.3.6.1.2.1.4.10.0",
- "algorithm": "incremental",
- "multiplier": 1,
- "divisor": 1,
- "offset": 0
- },
- "discards": {
- "oid": ".1.3.6.1.2.1.4.11.0",
- "algorithm": "incremental",
- "multiplier": -1,
- "divisor": 1,
- "offset": 0
- },
- "no_route": {
- "oid": ".1.3.6.1.2.1.4.12.0",
- "algorithm": "incremental",
- "multiplier": -1,
- "divisor": 1,
- "offset": 0
- }
- }
- },
- "snmp_switch.bandwidth_port": {
- "title": "Switch Bandwidth for port ",
- "titleoid": ".1.3.6.1.2.1.31.1.1.1.18.",
- "units": "kilobits/s",
- "type": "area",
- "priority": 100,
- "family": "ports",
- "multiply_range": [
- 1,
- 24
- ],
- "dimensions": {
- "in": {
- "oid": ".1.3.6.1.2.1.2.2.1.10.",
- "algorithm": "incremental",
- "multiplier": 8,
- "divisor": 1024,
- "offset": 0
- },
- "out": {
- "oid": ".1.3.6.1.2.1.2.2.1.16.",
- "algorithm": "incremental",
- "multiplier": -8,
- "divisor": 1024,
- "offset": 0
- }
- }
- }
- }
- }
- ]
-}
-```
-
-
diff --git a/collectors/node.d.plugin/snmp/snmp.node.js b/collectors/node.d.plugin/snmp/snmp.node.js
deleted file mode 100644
index 9e874586e..000000000
--- a/collectors/node.d.plugin/snmp/snmp.node.js
+++ /dev/null
@@ -1,527 +0,0 @@
-'use strict';
-// SPDX-License-Identifier: GPL-3.0-or-later
-// netdata snmp module
-// This program will connect to one or more SNMP Agents
-//
-
-// example configuration in /etc/netdata/node.d/snmp.conf
-/*
-{
- "enable_autodetect": false,
- "update_every": 5,
- "max_request_size": 50,
- "servers": [
- {
- "hostname": "10.11.12.8",
- "community": "public",
- "update_every": 10,
- "max_request_size": 50,
- "options": { "timeout": 10000 },
- "charts": {
- "snmp_switch.bandwidth_port1": {
- "title": "Switch Bandwidth for port 1",
- "units": "kilobits/s",
- "type": "area",
- "priority": 1,
- "dimensions": {
- "in": {
- "oid": ".1.3.6.1.2.1.2.2.1.10.1",
- "algorithm": "incremental",
- "multiplier": 8,
- "divisor": 1024,
- "offset": 0
- },
- "out": {
- "oid": ".1.3.6.1.2.1.2.2.1.16.1",
- "algorithm": "incremental",
- "multiplier": -8,
- "divisor": 1024,
- "offset": 0
- }
- }
- },
- "snmp_switch.bandwidth_port2": {
- "title": "Switch Bandwidth for port 2",
- "units": "kilobits/s",
- "type": "area",
- "priority": 1,
- "dimensions": {
- "in": {
- "oid": ".1.3.6.1.2.1.2.2.1.10.2",
- "algorithm": "incremental",
- "multiplier": 8,
- "divisor": 1024,
- "offset": 0
- },
- "out": {
- "oid": ".1.3.6.1.2.1.2.2.1.16.2",
- "algorithm": "incremental",
- "multiplier": -8,
- "divisor": 1024,
- "offset": 0
- }
- }
- }
- }
- }
- ]
-}
-*/
-
-// You can also give ranges of charts like the following.
-// This will append 1-24 to id, title, oid (on each dimension)
-// so that 24 charts will be created.
-/*
-{
- "enable_autodetect": false,
- "update_every": 10,
- "max_request_size": 50,
- "servers": [
- {
- "hostname": "10.11.12.8",
- "community": "public",
- "update_every": 10,
- "max_request_size": 50,
- "options": { "timeout": 20000 },
- "charts": {
- "snmp_switch.bandwidth_port": {
- "title": "Switch Bandwidth for port ",
- "units": "kilobits/s",
- "type": "area",
- "priority": 1,
- "multiply_range": [ 1, 24 ],
- "dimensions": {
- "in": {
- "oid": ".1.3.6.1.2.1.2.2.1.10.",
- "algorithm": "incremental",
- "multiplier": 8,
- "divisor": 1024,
- "offset": 0
- },
- "out": {
- "oid": ".1.3.6.1.2.1.2.2.1.16.",
- "algorithm": "incremental",
- "multiplier": -8,
- "divisor": 1024,
- "offset": 0
- }
- }
- }
- }
- }
- ]
-}
-*/
-
-var net_snmp = require('net-snmp');
-var extend = require('extend');
-var netdata = require('netdata');
-
-if (netdata.options.DEBUG === true) netdata.debug('loaded', __filename, ' plugin');
-
-netdata.processors.snmp = {
- name: 'snmp',
-
- fixoid: function (oid) {
- if (typeof oid !== 'string')
- return oid;
-
- if (oid.charAt(0) === '.')
- return oid.substring(1, oid.length);
-
- return oid;
- },
-
- prepare: function (service) {
- var __DEBUG = netdata.options.DEBUG;
-
- if (typeof service.snmp_oids === 'undefined' || service.snmp_oids === null || service.snmp_oids.length === 0) {
- // this is the first time we see this service
-
- if (__DEBUG === true)
- netdata.debug(service.module.name + ': ' + service.name + ': preparing ' + this.name + ' OIDs');
-
- // build an index of all OIDs
- service.snmp_oids_index = {};
- var chart_keys = Object.keys(service.request.charts);
- var chart_keys_len = chart_keys.length;
- while (chart_keys_len--) {
- var c = chart_keys[chart_keys_len];
- var chart = service.request.charts[c];
-
- // for each chart
-
- if (__DEBUG === true)
- netdata.debug(service.module.name + ': ' + service.name + ': indexing ' + this.name + ' chart: ' + c);
-
- if (typeof chart.titleoid !== 'undefined') {
- service.snmp_oids_index[this.fixoid(chart.titleoid)] = {
- type: 'title',
- link: chart
- };
- }
-
- var dim_keys = Object.keys(chart.dimensions);
- var dim_keys_len = dim_keys.length;
- while (dim_keys_len--) {
- var d = dim_keys[dim_keys_len];
- var dim = chart.dimensions[d];
-
- // for each dimension in the chart
-
- var oid = this.fixoid(dim.oid);
- var oidname = this.fixoid(dim.oidname);
-
- if (__DEBUG === true)
- netdata.debug(service.module.name + ': ' + service.name + ': indexing ' + this.name + ' chart: ' + c + ', dimension: ' + d + ', OID: ' + oid + ", OID name: " + oidname);
-
- // link it to the point we need to set the value to
- service.snmp_oids_index[oid] = {
- type: 'value',
- link: dim
- };
-
- if (typeof oidname !== 'undefined')
- service.snmp_oids_index[oidname] = {
- type: 'name',
- link: dim
- };
-
- // and set the value to null
- dim.value = null;
- }
- }
-
- if (__DEBUG === true)
- netdata.debug(service.module.name + ': ' + service.name + ': indexed ' + this.name + ' OIDs: ' + netdata.stringify(service.snmp_oids_index));
-
- // now create the array of OIDs needed by net-snmp
- service.snmp_oids = Object.keys(service.snmp_oids_index);
-
- if (__DEBUG === true)
- netdata.debug(service.module.name + ': ' + service.name + ': final list of ' + this.name + ' OIDs: ' + netdata.stringify(service.snmp_oids));
-
- service.snmp_oids_cleaned = 0;
- } else if (service.snmp_oids_cleaned === 0) {
- service.snmp_oids_cleaned = 1;
-
- // the second time, keep only values
-
- service.snmp_oids = new Array();
- var oid_keys = Object.keys(service.snmp_oids_index);
- var oid_keys_len = oid_keys.length;
- while (oid_keys_len--) {
- if (service.snmp_oids_index[oid_keys[oid_keys_len]].type === 'value')
- service.snmp_oids.push(oid_keys[oid_keys_len]);
- }
- }
- },
-
- getdata: function (service, index, ok, failed, callback) {
- var __DEBUG = netdata.options.DEBUG;
- var that = this;
-
- if (index >= service.snmp_oids.length) {
- callback((ok > 0) ? {ok: ok, failed: failed} : null);
- return;
- }
-
- var slice;
- if (service.snmp_oids.length <= service.request.max_request_size) {
- slice = service.snmp_oids;
- index = service.snmp_oids.length;
- } else if (service.snmp_oids.length - index <= service.request.max_request_size) {
- slice = service.snmp_oids.slice(index, service.snmp_oids.length);
- index = service.snmp_oids.length;
- } else {
- slice = service.snmp_oids.slice(index, index + service.request.max_request_size);
- index += service.request.max_request_size;
- }
-
- if (__DEBUG === true)
- netdata.debug(service.module.name + ': ' + service.name + ': making ' + slice.length + ' entries request, max is: ' + service.request.max_request_size);
-
- service.snmp_session.get(slice, function (error, varbinds) {
- if (error) {
- service.error('Received error = ' + netdata.stringify(error) + ' varbinds = ' + netdata.stringify(varbinds));
-
- // make all values null
- var len = slice.length;
- while (len--)
- service.snmp_oids_index[slice[len]].value = null;
- } else {
- if (__DEBUG === true)
- netdata.debug(service.module.name + ': ' + service.name + ': got valid ' + service.module.name + ' response: ' + netdata.stringify(varbinds));
-
- var varbinds_len = varbinds.length;
- for (var i = 0; i < varbinds_len; i++) {
- var value = null;
-
- if (net_snmp.isVarbindError(varbinds[i])) {
- if (__DEBUG === true)
- netdata.debug(service.module.name + ': ' + service.name + ': failed ' + service.module.name + ' get for OIDs ' + varbinds[i].oid);
-
- service.error('OID ' + varbinds[i].oid + ' gave error: ' + net_snmp.varbindError(varbinds[i]));
- value = null;
- failed++;
- } else {
- // test fom Counter64
- // varbinds[i].type = net_snmp.ObjectType.Counter64;
- // varbinds[i].value = new Buffer([0x34, 0x49, 0x2e, 0xdc, 0xd1]);
-
- switch (varbinds[i].type) {
- case net_snmp.ObjectType.OctetString:
- if (service.snmp_oids_index[varbinds[i].oid].type !== 'title' && service.snmp_oids_index[varbinds[i].oid].type !== 'name') {
- // parse floating point values, exposed as strings
- value = parseFloat(varbinds[i].value) * 1000;
- if (__DEBUG === true) netdata.debug(service.module.name + ': ' + service.name + ': found ' + service.module.name + ' value of OIDs ' + varbinds[i].oid + ", ObjectType " + net_snmp.ObjectType[varbinds[i].type] + " (" + netdata.stringify(varbinds[i].type) + "), typeof(" + typeof (varbinds[i].value) + "), in JSON: " + netdata.stringify(varbinds[i].value) + ", value = " + value.toString() + " (parsed as float in string)");
- } else {
- // just use the string
- value = varbinds[i].value;
- if (__DEBUG === true) netdata.debug(service.module.name + ': ' + service.name + ': found ' + service.module.name + ' value of OIDs ' + varbinds[i].oid + ", ObjectType " + net_snmp.ObjectType[varbinds[i].type] + " (" + netdata.stringify(varbinds[i].type) + "), typeof(" + typeof (varbinds[i].value) + "), in JSON: " + netdata.stringify(varbinds[i].value) + ", value = " + value.toString() + " (parsed as string)");
- }
- break;
-
- case net_snmp.ObjectType.Counter64:
- // copy the buffer
- value = '0x' + varbinds[i].value.toString('hex');
- if (__DEBUG === true) netdata.debug(service.module.name + ': ' + service.name + ': found ' + service.module.name + ' value of OIDs ' + varbinds[i].oid + ", ObjectType " + net_snmp.ObjectType[varbinds[i].type] + " (" + netdata.stringify(varbinds[i].type) + "), typeof(" + typeof (varbinds[i].value) + "), in JSON: " + netdata.stringify(varbinds[i].value) + ", value = " + value.toString() + " (parsed as buffer)");
- break;
-
- case net_snmp.ObjectType.Integer:
- case net_snmp.ObjectType.Counter:
- case net_snmp.ObjectType.Gauge:
- default:
- value = varbinds[i].value;
- if (__DEBUG === true) netdata.debug(service.module.name + ': ' + service.name + ': found ' + service.module.name + ' value of OIDs ' + varbinds[i].oid + ", ObjectType " + net_snmp.ObjectType[varbinds[i].type] + " (" + netdata.stringify(varbinds[i].type) + "), typeof(" + typeof (varbinds[i].value) + "), in JSON: " + netdata.stringify(varbinds[i].value) + ", value = " + value.toString() + " (parsed as number)");
- break;
- }
-
- ok++;
- }
-
- if (value !== null) {
- switch (service.snmp_oids_index[varbinds[i].oid].type) {
- case 'title':
- service.snmp_oids_index[varbinds[i].oid].link.title += ' ' + value;
- break;
- case 'name' :
- service.snmp_oids_index[varbinds[i].oid].link.name = value.toString().replace(/\W/g, '_');
- break;
- case 'value':
- service.snmp_oids_index[varbinds[i].oid].link.value = value;
- break;
- }
- }
- }
-
- if (__DEBUG === true)
- netdata.debug(service.module.name + ': ' + service.name + ': finished ' + service.module.name + ' with ' + ok + ' successful and ' + failed + ' failed values');
- }
- that.getdata(service, index, ok, failed, callback);
- });
- },
-
- process: function (service, callback) {
- var __DEBUG = netdata.options.DEBUG;
-
- this.prepare(service);
-
- if (service.snmp_oids.length === 0) {
- // no OIDs found for this service
-
- if (__DEBUG === true)
- service.error('no OIDs to process.');
-
- callback(null);
- return;
- }
-
- if (typeof service.snmp_session === 'undefined' || service.snmp_session === null) {
- // no SNMP session has been created for this service
- // the SNMP session is just the initialization of NET-SNMP
-
- var snmp_version = (service.request.options && service.request.options.version)
- ? service.request.options.version
- : net_snmp.Version1;
-
- if (snmp_version === net_snmp.Version3) {
- if (__DEBUG === true)
- netdata.debug(service.module.name + ': ' + service.name + ': opening ' + this.name + ' session on ' + service.request.hostname + ' user ' + service.request.user + ' options ' + netdata.stringify(service.request.options));
-
- // create the SNMP session
- service.snmp_session = net_snmp.createV3Session(service.request.hostname, service.request.user, service.request.options);
- } else {
- if (__DEBUG === true)
- netdata.debug(service.module.name + ': ' + service.name + ': opening ' + this.name + ' session on ' + service.request.hostname + ' community ' + service.request.community + ' options ' + netdata.stringify(service.request.options));
-
- // create the SNMP session
- service.snmp_session = net_snmp.createSession(service.request.hostname, service.request.community, service.request.options);
- }
-
- if (__DEBUG === true)
- netdata.debug(service.module.name + ': ' + service.name + ': got ' + this.name + ' session: ' + netdata.stringify(service.snmp_session));
-
- // if we later need traps, this is how to do it:
- //service.snmp_session.trap(net_snmp.TrapType.LinkDown, function(error) {
- // if(error) console.error('trap error: ' + netdata.stringify(error));
- //});
- }
-
- // do it, get the SNMP values for the sessions we need
- this.getdata(service, 0, 0, 0, callback);
- }
-};
-
-var snmp = {
- name: __filename,
- enable_autodetect: true,
- update_every: 1,
- base_priority: 50000,
-
- charts: {},
-
- processResponse: function (service, data) {
- if (data !== null) {
- if (service.added !== true)
- service.commit();
-
- var chart_keys = Object.keys(service.request.charts);
- var chart_keys_len = chart_keys.length;
- for (var i = 0; i < chart_keys_len; i++) {
- var c = chart_keys[i];
-
- var chart = snmp.charts[c];
- if (typeof chart === 'undefined') {
- chart = service.chart(c, service.request.charts[c]);
- snmp.charts[c] = chart;
- }
-
- service.begin(chart);
-
- var dimensions = service.request.charts[c].dimensions;
- var dim_keys = Object.keys(dimensions);
- var dim_keys_len = dim_keys.length;
- for (var j = 0; j < dim_keys_len; j++) {
- var d = dim_keys[j];
-
- if (dimensions[d].value !== null) {
- if (typeof dimensions[d].offset === 'number' && typeof dimensions[d].value === 'number')
- service.set(d, dimensions[d].value + dimensions[d].offset);
- else
- service.set(d, dimensions[d].value);
- }
- }
-
- service.end();
- }
- }
- },
-
- // module.serviceExecute()
- // this function is called only from this module
- // its purpose is to prepare the request and call
- // netdata.serviceExecute()
- serviceExecute: function (conf) {
- var __DEBUG = netdata.options.DEBUG;
-
- if (__DEBUG === true)
- netdata.debug(this.name + ': snmp hostname: ' + conf.hostname + ', update_every: ' + conf.update_every);
-
- var service = netdata.service({
- name: conf.hostname,
- request: conf,
- update_every: conf.update_every,
- module: this,
- processor: netdata.processors.snmp
- });
-
- // multiply the charts, if required
- var chart_keys = Object.keys(service.request.charts);
- var chart_keys_len = chart_keys.length;
- for (var i = 0; i < chart_keys_len; i++) {
- var c = chart_keys[i];
- var service_request_chart = service.request.charts[c];
-
- if (__DEBUG === true)
- netdata.debug(this.name + ': snmp hostname: ' + conf.hostname + ', examining chart: ' + c);
-
- if (typeof service_request_chart.update_every === 'undefined')
- service_request_chart.update_every = service.update_every;
-
- if (typeof service_request_chart.multiply_range !== 'undefined') {
- var from = service_request_chart.multiply_range[0];
- var to = service_request_chart.multiply_range[1];
- var prio = service_request_chart.priority || 1;
-
- if (prio < snmp.base_priority) prio += snmp.base_priority;
-
- while (from <= to) {
- var id = c + from.toString();
- var chart = extend(true, {}, service_request_chart);
- chart.title += from.toString();
-
- if (typeof chart.titleoid !== 'undefined')
- chart.titleoid += from.toString();
-
- chart.priority = prio++;
-
- var dim_keys = Object.keys(chart.dimensions);
- var dim_keys_len = dim_keys.length;
- for (var j = 0; j < dim_keys_len; j++) {
- var d = dim_keys[j];
-
- chart.dimensions[d].oid += from.toString();
-
- if (typeof chart.dimensions[d].oidname !== 'undefined')
- chart.dimensions[d].oidname += from.toString();
- }
- service.request.charts[id] = chart;
- from++;
- }
-
- delete service.request.charts[c];
- } else {
- if (service.request.charts[c].priority < snmp.base_priority)
- service.request.charts[c].priority += snmp.base_priority;
- }
- }
-
- service.execute(this.processResponse);
- },
-
- configure: function (config) {
- var added = 0;
-
- if (typeof config.max_request_size === 'undefined')
- config.max_request_size = 50;
-
- if (typeof (config.servers) !== 'undefined') {
- var len = config.servers.length;
- while (len--) {
- if (typeof config.servers[len].update_every === 'undefined')
- config.servers[len].update_every = this.update_every;
-
- if (typeof config.servers[len].max_request_size === 'undefined')
- config.servers[len].max_request_size = config.max_request_size;
-
- this.serviceExecute(config.servers[len]);
- added++;
- }
- }
-
- return added;
- },
-
- // module.update()
- // this is called repeatedly to collect data, by calling
- // service.execute()
- update: function (service, callback) {
- service.execute(function (serv, data) {
- service.module.processResponse(serv, data);
- callback();
- });
- }
-};
-
-module.exports = snmp;