summaryrefslogtreecommitdiffstats
path: root/collectors/python.d.plugin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'collectors/python.d.plugin/Makefile.am')
-rw-r--r--collectors/python.d.plugin/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/collectors/python.d.plugin/Makefile.am b/collectors/python.d.plugin/Makefile.am
index 7d087fbfd..cb14e3500 100644
--- a/collectors/python.d.plugin/Makefile.am
+++ b/collectors/python.d.plugin/Makefile.am
@@ -32,11 +32,16 @@ dist_userpythonconfig_DATA = \
.keep \
$(NULL)
+# Explicitly install directories to avoid permission issues due to umask
+install-exec-local:
+ $(INSTALL) -d $(DESTDIR)$(userpythonconfigdir)
+
pythonconfigdir=$(libconfigdir)/python.d
dist_pythonconfig_DATA = \
$(NULL)
include adaptec_raid/Makefile.inc
+include am2320/Makefile.inc
include apache/Makefile.inc
include beanstalk/Makefile.inc
include bind_rndc/Makefile.inc