summaryrefslogtreecommitdiffstats
path: root/collectors/python.d.plugin/adaptec_raid
diff options
context:
space:
mode:
Diffstat (limited to 'collectors/python.d.plugin/adaptec_raid')
-rw-r--r--collectors/python.d.plugin/adaptec_raid/Makefile.inc13
l---------collectors/python.d.plugin/adaptec_raid/README.md1
-rw-r--r--collectors/python.d.plugin/adaptec_raid/adaptec_raid.chart.py247
-rw-r--r--collectors/python.d.plugin/adaptec_raid/adaptec_raid.conf53
-rw-r--r--collectors/python.d.plugin/adaptec_raid/integrations/adaptecraid.md204
-rw-r--r--collectors/python.d.plugin/adaptec_raid/metadata.yaml167
6 files changed, 0 insertions, 685 deletions
diff --git a/collectors/python.d.plugin/adaptec_raid/Makefile.inc b/collectors/python.d.plugin/adaptec_raid/Makefile.inc
deleted file mode 100644
index 716cdb235..000000000
--- a/collectors/python.d.plugin/adaptec_raid/Makefile.inc
+++ /dev/null
@@ -1,13 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# THIS IS NOT A COMPLETE Makefile
-# IT IS INCLUDED BY ITS PARENT'S Makefile.am
-# IT IS REQUIRED TO REFERENCE ALL FILES RELATIVE TO THE PARENT
-
-# install these files
-dist_python_DATA += adaptec_raid/adaptec_raid.chart.py
-dist_pythonconfig_DATA += adaptec_raid/adaptec_raid.conf
-
-# do not install these files, but include them in the distribution
-dist_noinst_DATA += adaptec_raid/README.md adaptec_raid/Makefile.inc
-
diff --git a/collectors/python.d.plugin/adaptec_raid/README.md b/collectors/python.d.plugin/adaptec_raid/README.md
deleted file mode 120000
index 97a103eb9..000000000
--- a/collectors/python.d.plugin/adaptec_raid/README.md
+++ /dev/null
@@ -1 +0,0 @@
-integrations/adaptecraid.md \ No newline at end of file
diff --git a/collectors/python.d.plugin/adaptec_raid/adaptec_raid.chart.py b/collectors/python.d.plugin/adaptec_raid/adaptec_raid.chart.py
deleted file mode 100644
index 1995ad681..000000000
--- a/collectors/python.d.plugin/adaptec_raid/adaptec_raid.chart.py
+++ /dev/null
@@ -1,247 +0,0 @@
-# -*- coding: utf-8 -*-
-# Description: adaptec_raid netdata python.d module
-# Author: Ilya Mashchenko (ilyam8)
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-
-import re
-from copy import deepcopy
-
-from bases.FrameworkServices.ExecutableService import ExecutableService
-from bases.collection import find_binary
-
-disabled_by_default = True
-
-update_every = 5
-
-ORDER = [
- 'ld_status',
- 'pd_state',
- 'pd_smart_warnings',
- 'pd_temperature',
-]
-
-CHARTS = {
- 'ld_status': {
- 'options': [None, 'Status of logical devices (1: Failed or Degraded)', 'bool', 'logical devices',
- 'adaptec_raid.ld_status', 'line'],
- 'lines': []
- },
- 'pd_state': {
- 'options': [None, 'State of physical devices (1: not Online)', 'bool', 'physical devices',
- 'adaptec_raid.pd_state', 'line'],
- 'lines': []
- },
- 'pd_smart_warnings': {
- 'options': [None, 'S.M.A.R.T warnings', 'count', 'physical devices',
- 'adaptec_raid.smart_warnings', 'line'],
- 'lines': []
- },
- 'pd_temperature': {
- 'options': [None, 'Temperature', 'celsius', 'physical devices', 'adaptec_raid.temperature', 'line'],
- 'lines': []
- },
-}
-
-SUDO = 'sudo'
-ARCCONF = 'arcconf'
-
-BAD_LD_STATUS = (
- 'Degraded',
- 'Failed',
-)
-
-GOOD_PD_STATUS = (
- 'Online',
-)
-
-RE_LD = re.compile(
- r'Logical [dD]evice number\s+([0-9]+).*?'
- r'Status of [lL]ogical [dD]evice\s+: ([a-zA-Z]+)'
-)
-
-
-def find_lds(d):
- d = ' '.join(v.strip() for v in d)
- return [LD(*v) for v in RE_LD.findall(d)]
-
-
-def find_pds(d):
- pds = list()
- pd = PD()
-
- for row in d:
- row = row.strip()
- if row.startswith('Device #'):
- pd = PD()
- pd.id = row.split('#')[-1]
- elif not pd.id:
- continue
-
- if row.startswith('State'):
- v = row.split()[-1]
- pd.state = v
- elif row.startswith('S.M.A.R.T. warnings'):
- v = row.split()[-1]
- pd.smart_warnings = v
- elif row.startswith('Temperature'):
- v = row.split(':')[-1].split()[0]
- pd.temperature = v
- elif row.startswith(('NCQ status', 'Device Phy')) or not row:
- if pd.id and pd.state and pd.smart_warnings:
- pds.append(pd)
- pd = PD()
-
- return pds
-
-
-class LD:
- def __init__(self, ld_id, status):
- self.id = ld_id
- self.status = status
-
- def data(self):
- return {
- 'ld_{0}_status'.format(self.id): int(self.status in BAD_LD_STATUS)
- }
-
-
-class PD:
- def __init__(self):
- self.id = None
- self.state = None
- self.smart_warnings = None
- self.temperature = None
-
- def data(self):
- data = {
- 'pd_{0}_state'.format(self.id): int(self.state not in GOOD_PD_STATUS),
- 'pd_{0}_smart_warnings'.format(self.id): self.smart_warnings,
- }
- if self.temperature and self.temperature.isdigit():
- data['pd_{0}_temperature'.format(self.id)] = self.temperature
-
- return data
-
-
-class Arcconf:
- def __init__(self, arcconf):
- self.arcconf = arcconf
-
- def ld_info(self):
- return [self.arcconf, 'GETCONFIG', '1', 'LD']
-
- def pd_info(self):
- return [self.arcconf, 'GETCONFIG', '1', 'PD']
-
-
-# TODO: hardcoded sudo...
-class SudoArcconf:
- def __init__(self, arcconf, sudo):
- self.arcconf = Arcconf(arcconf)
- self.sudo = sudo
-
- def ld_info(self):
- return [self.sudo, '-n'] + self.arcconf.ld_info()
-
- def pd_info(self):
- return [self.sudo, '-n'] + self.arcconf.pd_info()
-
-
-class Service(ExecutableService):
- def __init__(self, configuration=None, name=None):
- ExecutableService.__init__(self, configuration=configuration, name=name)
- self.order = ORDER
- self.definitions = deepcopy(CHARTS)
- self.use_sudo = self.configuration.get('use_sudo', True)
- self.arcconf = None
-
- def execute(self, command, stderr=False):
- return self._get_raw_data(command=command, stderr=stderr)
-
- def check(self):
- arcconf = find_binary(ARCCONF)
- if not arcconf:
- self.error('can\'t locate "{0}" binary'.format(ARCCONF))
- return False
-
- sudo = find_binary(SUDO)
- if self.use_sudo:
- if not sudo:
- self.error('can\'t locate "{0}" binary'.format(SUDO))
- return False
- err = self.execute([sudo, '-n', '-v'], True)
- if err:
- self.error(' '.join(err))
- return False
-
- if self.use_sudo:
- self.arcconf = SudoArcconf(arcconf, sudo)
- else:
- self.arcconf = Arcconf(arcconf)
-
- lds = self.get_lds()
- if not lds:
- return False
-
- self.debug('discovered logical devices ids: {0}'.format([ld.id for ld in lds]))
-
- pds = self.get_pds()
- if not pds:
- return False
-
- self.debug('discovered physical devices ids: {0}'.format([pd.id for pd in pds]))
-
- self.update_charts(lds, pds)
- return True
-
- def get_data(self):
- data = dict()
-
- for ld in self.get_lds():
- data.update(ld.data())
-
- for pd in self.get_pds():
- data.update(pd.data())
-
- return data
-
- def get_lds(self):
- raw_lds = self.execute(self.arcconf.ld_info())
- if not raw_lds:
- return None
-
- lds = find_lds(raw_lds)
- if not lds:
- self.error('failed to parse "{0}" output'.format(' '.join(self.arcconf.ld_info())))
- self.debug('output: {0}'.format(raw_lds))
- return None
- return lds
-
- def get_pds(self):
- raw_pds = self.execute(self.arcconf.pd_info())
- if not raw_pds:
- return None
-
- pds = find_pds(raw_pds)
- if not pds:
- self.error('failed to parse "{0}" output'.format(' '.join(self.arcconf.pd_info())))
- self.debug('output: {0}'.format(raw_pds))
- return None
- return pds
-
- def update_charts(self, lds, pds):
- charts = self.definitions
- for ld in lds:
- dim = ['ld_{0}_status'.format(ld.id), 'ld {0}'.format(ld.id)]
- charts['ld_status']['lines'].append(dim)
-
- for pd in pds:
- dim = ['pd_{0}_state'.format(pd.id), 'pd {0}'.format(pd.id)]
- charts['pd_state']['lines'].append(dim)
-
- dim = ['pd_{0}_smart_warnings'.format(pd.id), 'pd {0}'.format(pd.id)]
- charts['pd_smart_warnings']['lines'].append(dim)
-
- dim = ['pd_{0}_temperature'.format(pd.id), 'pd {0}'.format(pd.id)]
- charts['pd_temperature']['lines'].append(dim)
diff --git a/collectors/python.d.plugin/adaptec_raid/adaptec_raid.conf b/collectors/python.d.plugin/adaptec_raid/adaptec_raid.conf
deleted file mode 100644
index fa462ec83..000000000
--- a/collectors/python.d.plugin/adaptec_raid/adaptec_raid.conf
+++ /dev/null
@@ -1,53 +0,0 @@
-# netdata python.d.plugin configuration for adaptec raid
-#
-# This file is in YaML format. Generally the format is:
-#
-# name: value
-#
-
-# ----------------------------------------------------------------------
-# Global Variables
-# These variables set the defaults for all JOBs, however each JOB
-# may define its own, overriding the defaults.
-
-# update_every sets the default data collection frequency.
-# If unset, the python.d.plugin default is used.
-# update_every: 1
-
-# priority controls the order of charts at the netdata dashboard.
-# Lower numbers move the charts towards the top of the page.
-# If unset, the default for python.d.plugin is used.
-# priority: 60000
-
-# penalty indicates whether to apply penalty to update_every in case of failures.
-# Penalty will increase every 5 failed updates in a row. Maximum penalty is 10 minutes.
-# penalty: yes
-
-# autodetection_retry sets the job re-check interval in seconds.
-# The job is not deleted if check fails.
-# Attempts to start the job are made once every autodetection_retry.
-# This feature is disabled by default.
-# autodetection_retry: 0
-
-# ----------------------------------------------------------------------
-# JOBS (data collection sources)
-#
-# The default JOBS share the same *name*. JOBS with the same name
-# are mutually exclusive. Only one of them will be allowed running at
-# any time. This allows autodetection to try several alternatives and
-# pick the one that works.
-#
-# Any number of jobs is supported.
-#
-# All python.d.plugin JOBS (for all its modules) support a set of
-# predefined parameters. These are:
-#
-# job_name:
-# name: myname # the JOB's name as it will appear at the
-# # dashboard (by default is the job_name)
-# # JOBs sharing a name are mutually exclusive
-# update_every: 1 # the JOB's data collection frequency
-# priority: 60000 # the JOB's order on the dashboard
-# penalty: yes # the JOB's penalty
-# autodetection_retry: 0 # the JOB's re-check interval in seconds
-# ----------------------------------------------------------------------
diff --git a/collectors/python.d.plugin/adaptec_raid/integrations/adaptecraid.md b/collectors/python.d.plugin/adaptec_raid/integrations/adaptecraid.md
deleted file mode 100644
index 13d22ba54..000000000
--- a/collectors/python.d.plugin/adaptec_raid/integrations/adaptecraid.md
+++ /dev/null
@@ -1,204 +0,0 @@
-<!--startmeta
-custom_edit_url: "https://github.com/netdata/netdata/edit/master/collectors/python.d.plugin/adaptec_raid/README.md"
-meta_yaml: "https://github.com/netdata/netdata/edit/master/collectors/python.d.plugin/adaptec_raid/metadata.yaml"
-sidebar_label: "AdaptecRAID"
-learn_status: "Published"
-learn_rel_path: "Data Collection/Storage, Mount Points and Filesystems"
-most_popular: False
-message: "DO NOT EDIT THIS FILE DIRECTLY, IT IS GENERATED BY THE COLLECTOR'S metadata.yaml FILE"
-endmeta-->
-
-# AdaptecRAID
-
-
-<img src="https://netdata.cloud/img/adaptec.svg" width="150"/>
-
-
-Plugin: python.d.plugin
-Module: adaptec_raid
-
-<img src="https://img.shields.io/badge/maintained%20by-Netdata-%2300ab44" />
-
-## Overview
-
-This collector monitors Adaptec RAID hardware storage controller metrics about both physical and logical drives.
-
-
-It uses the arcconf command line utility (from adaptec) to monitor your raid controller.
-
-Executed commands:
- - `sudo -n arcconf GETCONFIG 1 LD`
- - `sudo -n arcconf GETCONFIG 1 PD`
-
-
-This collector is supported on all platforms.
-
-This collector only supports collecting metrics from a single instance of this integration.
-
-The module uses arcconf, which can only be executed by root. It uses sudo and assumes that it is configured such that the netdata user can execute arcconf as root without a password.
-
-### Default Behavior
-
-#### Auto-Detection
-
-After all the permissions are satisfied, netdata should be to execute commands via the arcconf command line utility
-
-#### Limits
-
-The default configuration for this integration does not impose any limits on data collection.
-
-#### Performance Impact
-
-The default configuration for this integration is not expected to impose a significant performance impact on the system.
-
-
-## Metrics
-
-Metrics grouped by *scope*.
-
-The scope defines the instance that the metric belongs to. An instance is uniquely identified by a set of labels.
-
-
-
-### Per AdaptecRAID instance
-
-These metrics refer to the entire monitored application.
-
-This scope has no labels.
-
-Metrics:
-
-| Metric | Dimensions | Unit |
-|:------|:----------|:----|
-| adaptec_raid.ld_status | a dimension per logical device | bool |
-| adaptec_raid.pd_state | a dimension per physical device | bool |
-| adaptec_raid.smart_warnings | a dimension per physical device | count |
-| adaptec_raid.temperature | a dimension per physical device | celsius |
-
-
-
-## Alerts
-
-
-The following alerts are available:
-
-| Alert name | On metric | Description |
-|:------------|:----------|:------------|
-| [ adaptec_raid_ld_status ](https://github.com/netdata/netdata/blob/master/health/health.d/adaptec_raid.conf) | adaptec_raid.ld_status | logical device status is failed or degraded |
-| [ adaptec_raid_pd_state ](https://github.com/netdata/netdata/blob/master/health/health.d/adaptec_raid.conf) | adaptec_raid.pd_state | physical device state is not online |
-
-
-## Setup
-
-### Prerequisites
-
-#### Grant permissions for netdata, to run arcconf as sudoer
-
-The module uses arcconf, which can only be executed by root. It uses sudo and assumes that it is configured such that the netdata user can execute arcconf as root without a password.
-
-Add to your /etc/sudoers file:
-which arcconf shows the full path to the binary.
-
-```bash
-netdata ALL=(root) NOPASSWD: /path/to/arcconf
-```
-
-
-#### Reset Netdata's systemd unit CapabilityBoundingSet (Linux distributions with systemd)
-
-The default CapabilityBoundingSet doesn't allow using sudo, and is quite strict in general. Resetting is not optimal, but a next-best solution given the inability to execute arcconf using sudo.
-
-As root user, do the following:
-
-```bash
-mkdir /etc/systemd/system/netdata.service.d
-echo -e '[Service]\nCapabilityBoundingSet=~' | tee /etc/systemd/system/netdata.service.d/unset-capability-bounding-set.conf
-systemctl daemon-reload
-systemctl restart netdata.service
-```
-
-
-
-### Configuration
-
-#### File
-
-The configuration file name for this integration is `python.d/adaptec_raid.conf`.
-
-
-You can edit the configuration file using the `edit-config` script from the
-Netdata [config directory](https://github.com/netdata/netdata/blob/master/docs/configure/nodes.md#the-netdata-config-directory).
-
-```bash
-cd /etc/netdata 2>/dev/null || cd /opt/netdata/etc/netdata
-sudo ./edit-config python.d/adaptec_raid.conf
-```
-#### Options
-
-There are 2 sections:
-
-* Global variables
-* One or more JOBS that can define multiple different instances to monitor.
-
-The following options can be defined globally: priority, penalty, autodetection_retry, update_every, but can also be defined per JOB to override the global values.
-
-Additionally, the following collapsed table contains all the options that can be configured inside a JOB definition.
-
-Every configuration JOB starts with a `job_name` value which will appear in the dashboard, unless a `name` parameter is specified.
-
-
-<details><summary>Config options</summary>
-
-| Name | Description | Default | Required |
-|:----|:-----------|:-------|:--------:|
-| update_every | Sets the default data collection frequency. | 5 | no |
-| priority | Controls the order of charts at the netdata dashboard. | 60000 | no |
-| autodetection_retry | Sets the job re-check interval in seconds. | 0 | no |
-| penalty | Indicates whether to apply penalty to update_every in case of failures. | yes | no |
-
-</details>
-
-#### Examples
-
-##### Basic
-
-A basic example configuration per job
-
-```yaml
-job_name:
- name: my_job_name
- update_every: 1 # the JOB's data collection frequency
- priority: 60000 # the JOB's order on the dashboard
- penalty: yes # the JOB's penalty
- autodetection_retry: 0 # the JOB's re-check interval in seconds
-
-```
-
-
-## Troubleshooting
-
-### Debug Mode
-
-To troubleshoot issues with the `adaptec_raid` collector, run the `python.d.plugin` with the debug option enabled. The output
-should give you clues as to why the collector isn't working.
-
-- Navigate to the `plugins.d` directory, usually at `/usr/libexec/netdata/plugins.d/`. If that's not the case on
- your system, open `netdata.conf` and look for the `plugins` setting under `[directories]`.
-
- ```bash
- cd /usr/libexec/netdata/plugins.d/
- ```
-
-- Switch to the `netdata` user.
-
- ```bash
- sudo -u netdata -s
- ```
-
-- Run the `python.d.plugin` to debug the collector:
-
- ```bash
- ./python.d.plugin adaptec_raid debug trace
- ```
-
-
diff --git a/collectors/python.d.plugin/adaptec_raid/metadata.yaml b/collectors/python.d.plugin/adaptec_raid/metadata.yaml
deleted file mode 100644
index c69baff4a..000000000
--- a/collectors/python.d.plugin/adaptec_raid/metadata.yaml
+++ /dev/null
@@ -1,167 +0,0 @@
-plugin_name: python.d.plugin
-modules:
- - meta:
- plugin_name: python.d.plugin
- module_name: adaptec_raid
- monitored_instance:
- name: AdaptecRAID
- link: "https://www.microchip.com/en-us/products/storage"
- categories:
- - data-collection.storage-mount-points-and-filesystems
- icon_filename: "adaptec.svg"
- related_resources:
- integrations:
- list: []
- info_provided_to_referring_integrations:
- description: ""
- keywords:
- - storage
- - raid-controller
- - manage-disks
- most_popular: false
- overview:
- data_collection:
- metrics_description: |
- This collector monitors Adaptec RAID hardware storage controller metrics about both physical and logical drives.
- method_description: |
- It uses the arcconf command line utility (from adaptec) to monitor your raid controller.
-
- Executed commands:
- - `sudo -n arcconf GETCONFIG 1 LD`
- - `sudo -n arcconf GETCONFIG 1 PD`
- supported_platforms:
- include: []
- exclude: []
- multi_instance: false
- additional_permissions:
- description: "The module uses arcconf, which can only be executed by root. It uses sudo and assumes that it is configured such that the netdata user can execute arcconf as root without a password."
- default_behavior:
- auto_detection:
- description: "After all the permissions are satisfied, netdata should be to execute commands via the arcconf command line utility"
- limits:
- description: ""
- performance_impact:
- description: ""
- setup:
- prerequisites:
- list:
- - title: Grant permissions for netdata, to run arcconf as sudoer
- description: |
- The module uses arcconf, which can only be executed by root. It uses sudo and assumes that it is configured such that the netdata user can execute arcconf as root without a password.
-
- Add to your /etc/sudoers file:
- which arcconf shows the full path to the binary.
-
- ```bash
- netdata ALL=(root) NOPASSWD: /path/to/arcconf
- ```
- - title: Reset Netdata's systemd unit CapabilityBoundingSet (Linux distributions with systemd)
- description: |
- The default CapabilityBoundingSet doesn't allow using sudo, and is quite strict in general. Resetting is not optimal, but a next-best solution given the inability to execute arcconf using sudo.
-
- As root user, do the following:
-
- ```bash
- mkdir /etc/systemd/system/netdata.service.d
- echo -e '[Service]\nCapabilityBoundingSet=~' | tee /etc/systemd/system/netdata.service.d/unset-capability-bounding-set.conf
- systemctl daemon-reload
- systemctl restart netdata.service
- ```
- configuration:
- file:
- name: "python.d/adaptec_raid.conf"
- options:
- description: |
- There are 2 sections:
-
- * Global variables
- * One or more JOBS that can define multiple different instances to monitor.
-
- The following options can be defined globally: priority, penalty, autodetection_retry, update_every, but can also be defined per JOB to override the global values.
-
- Additionally, the following collapsed table contains all the options that can be configured inside a JOB definition.
-
- Every configuration JOB starts with a `job_name` value which will appear in the dashboard, unless a `name` parameter is specified.
- folding:
- title: "Config options"
- enabled: true
- list:
- - name: update_every
- description: Sets the default data collection frequency.
- default_value: 5
- required: false
- - name: priority
- description: Controls the order of charts at the netdata dashboard.
- default_value: 60000
- required: false
- - name: autodetection_retry
- description: Sets the job re-check interval in seconds.
- default_value: 0
- required: false
- - name: penalty
- description: Indicates whether to apply penalty to update_every in case of failures.
- default_value: yes
- required: false
- examples:
- folding:
- enabled: true
- title: "Config"
- list:
- - name: Basic
- folding:
- enabled: false
- description: A basic example configuration per job
- config: |
- job_name:
- name: my_job_name
- update_every: 1 # the JOB's data collection frequency
- priority: 60000 # the JOB's order on the dashboard
- penalty: yes # the JOB's penalty
- autodetection_retry: 0 # the JOB's re-check interval in seconds
- troubleshooting:
- problems:
- list: []
- alerts:
- - name: adaptec_raid_ld_status
- link: https://github.com/netdata/netdata/blob/master/health/health.d/adaptec_raid.conf
- metric: adaptec_raid.ld_status
- info: logical device status is failed or degraded
- - name: adaptec_raid_pd_state
- link: https://github.com/netdata/netdata/blob/master/health/health.d/adaptec_raid.conf
- metric: adaptec_raid.pd_state
- info: physical device state is not online
- metrics:
- folding:
- title: Metrics
- enabled: false
- description: ""
- availability: []
- scopes:
- - name: global
- description: "These metrics refer to the entire monitored application."
- labels: []
- metrics:
- - name: adaptec_raid.ld_status
- description: "Status of logical devices (1: Failed or Degraded)"
- unit: "bool"
- chart_type: line
- dimensions:
- - name: a dimension per logical device
- - name: adaptec_raid.pd_state
- description: "State of physical devices (1: not Online)"
- unit: "bool"
- chart_type: line
- dimensions:
- - name: a dimension per physical device
- - name: adaptec_raid.smart_warnings
- description: S.M.A.R.T warnings
- unit: "count"
- chart_type: line
- dimensions:
- - name: a dimension per physical device
- - name: adaptec_raid.temperature
- description: Temperature
- unit: "celsius"
- chart_type: line
- dimensions:
- - name: a dimension per physical device