summaryrefslogtreecommitdiffstats
path: root/collectors/python.d.plugin/go_expvar
diff options
context:
space:
mode:
Diffstat (limited to 'collectors/python.d.plugin/go_expvar')
-rw-r--r--collectors/python.d.plugin/go_expvar/Makefile.inc13
l---------collectors/python.d.plugin/go_expvar/README.md1
-rw-r--r--collectors/python.d.plugin/go_expvar/go_expvar.chart.py253
-rw-r--r--collectors/python.d.plugin/go_expvar/go_expvar.conf108
-rw-r--r--collectors/python.d.plugin/go_expvar/integrations/go_applications_expvar.md335
-rw-r--r--collectors/python.d.plugin/go_expvar/metadata.yaml329
6 files changed, 0 insertions, 1039 deletions
diff --git a/collectors/python.d.plugin/go_expvar/Makefile.inc b/collectors/python.d.plugin/go_expvar/Makefile.inc
deleted file mode 100644
index 74f50d765..000000000
--- a/collectors/python.d.plugin/go_expvar/Makefile.inc
+++ /dev/null
@@ -1,13 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# THIS IS NOT A COMPLETE Makefile
-# IT IS INCLUDED BY ITS PARENT'S Makefile.am
-# IT IS REQUIRED TO REFERENCE ALL FILES RELATIVE TO THE PARENT
-
-# install these files
-dist_python_DATA += go_expvar/go_expvar.chart.py
-dist_pythonconfig_DATA += go_expvar/go_expvar.conf
-
-# do not install these files, but include them in the distribution
-dist_noinst_DATA += go_expvar/README.md go_expvar/Makefile.inc
-
diff --git a/collectors/python.d.plugin/go_expvar/README.md b/collectors/python.d.plugin/go_expvar/README.md
deleted file mode 120000
index f28a82f34..000000000
--- a/collectors/python.d.plugin/go_expvar/README.md
+++ /dev/null
@@ -1 +0,0 @@
-integrations/go_applications_expvar.md \ No newline at end of file
diff --git a/collectors/python.d.plugin/go_expvar/go_expvar.chart.py b/collectors/python.d.plugin/go_expvar/go_expvar.chart.py
deleted file mode 100644
index dca010817..000000000
--- a/collectors/python.d.plugin/go_expvar/go_expvar.chart.py
+++ /dev/null
@@ -1,253 +0,0 @@
-# -*- coding: utf-8 -*-
-# Description: go_expvar netdata python.d module
-# Author: Jan Kral (kralewitz)
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-from __future__ import division
-
-import json
-from collections import namedtuple
-
-from bases.FrameworkServices.UrlService import UrlService
-
-MEMSTATS_ORDER = [
- 'memstats_heap',
- 'memstats_stack',
- 'memstats_mspan',
- 'memstats_mcache',
- 'memstats_sys',
- 'memstats_live_objects',
- 'memstats_gc_pauses',
-]
-
-MEMSTATS_CHARTS = {
- 'memstats_heap': {
- 'options': ['heap', 'memory: size of heap memory structures', 'KiB', 'memstats',
- 'expvar.memstats.heap', 'line'],
- 'lines': [
- ['memstats_heap_alloc', 'alloc', 'absolute', 1, 1024],
- ['memstats_heap_inuse', 'inuse', 'absolute', 1, 1024]
- ]
- },
- 'memstats_stack': {
- 'options': ['stack', 'memory: size of stack memory structures', 'KiB', 'memstats',
- 'expvar.memstats.stack', 'line'],
- 'lines': [
- ['memstats_stack_inuse', 'inuse', 'absolute', 1, 1024]
- ]
- },
- 'memstats_mspan': {
- 'options': ['mspan', 'memory: size of mspan memory structures', 'KiB', 'memstats',
- 'expvar.memstats.mspan', 'line'],
- 'lines': [
- ['memstats_mspan_inuse', 'inuse', 'absolute', 1, 1024]
- ]
- },
- 'memstats_mcache': {
- 'options': ['mcache', 'memory: size of mcache memory structures', 'KiB', 'memstats',
- 'expvar.memstats.mcache', 'line'],
- 'lines': [
- ['memstats_mcache_inuse', 'inuse', 'absolute', 1, 1024]
- ]
- },
- 'memstats_live_objects': {
- 'options': ['live_objects', 'memory: number of live objects', 'objects', 'memstats',
- 'expvar.memstats.live_objects', 'line'],
- 'lines': [
- ['memstats_live_objects', 'live']
- ]
- },
- 'memstats_sys': {
- 'options': ['sys', 'memory: size of reserved virtual address space', 'KiB', 'memstats',
- 'expvar.memstats.sys', 'line'],
- 'lines': [
- ['memstats_sys', 'sys', 'absolute', 1, 1024]
- ]
- },
- 'memstats_gc_pauses': {
- 'options': ['gc_pauses', 'memory: average duration of GC pauses', 'ns', 'memstats',
- 'expvar.memstats.gc_pauses', 'line'],
- 'lines': [
- ['memstats_gc_pauses', 'avg']
- ]
- }
-}
-
-EXPVAR = namedtuple(
- "EXPVAR",
- [
- "key",
- "type",
- "id",
- ]
-)
-
-
-def flatten(d, top='', sep='.'):
- items = []
- for key, val in d.items():
- nkey = top + sep + key if top else key
- if isinstance(val, dict):
- items.extend(flatten(val, nkey, sep=sep).items())
- else:
- items.append((nkey, val))
- return dict(items)
-
-
-class Service(UrlService):
- def __init__(self, configuration=None, name=None):
- UrlService.__init__(self, configuration=configuration, name=name)
- # if memstats collection is enabled, add the charts and their order
- if self.configuration.get('collect_memstats'):
- self.definitions = dict(MEMSTATS_CHARTS)
- self.order = list(MEMSTATS_ORDER)
- else:
- self.definitions = dict()
- self.order = list()
-
- # if extra charts are defined, parse their config
- extra_charts = self.configuration.get('extra_charts')
- if extra_charts:
- self._parse_extra_charts_config(extra_charts)
-
- def check(self):
- """
- Check if the module can collect data:
- 1) At least one JOB configuration has to be specified
- 2) The JOB configuration needs to define the URL and either collect_memstats must be enabled or at least one
- extra_chart must be defined.
-
- The configuration and URL check is provided by the UrlService class.
- """
-
- if not (self.configuration.get('extra_charts') or self.configuration.get('collect_memstats')):
- self.error('Memstats collection is disabled and no extra_charts are defined, disabling module.')
- return False
-
- return UrlService.check(self)
-
- def _parse_extra_charts_config(self, extra_charts_config):
-
- # a place to store the expvar keys and their types
- self.expvars = list()
-
- for chart in extra_charts_config:
-
- chart_dict = dict()
- chart_id = chart.get('id')
- chart_lines = chart.get('lines')
- chart_opts = chart.get('options', dict())
-
- if not all([chart_id, chart_lines]):
- self.info('Chart {0} has no ID or no lines defined, skipping'.format(chart))
- continue
-
- chart_dict['options'] = [
- chart_opts.get('name', ''),
- chart_opts.get('title', ''),
- chart_opts.get('units', ''),
- chart_opts.get('family', ''),
- chart_opts.get('context', ''),
- chart_opts.get('chart_type', 'line')
- ]
- chart_dict['lines'] = list()
-
- # add the lines to the chart
- for line in chart_lines:
-
- ev_key = line.get('expvar_key')
- ev_type = line.get('expvar_type')
- line_id = line.get('id')
-
- if not all([ev_key, ev_type, line_id]):
- self.info('Line missing expvar_key, expvar_type, or line_id, skipping: {0}'.format(line))
- continue
-
- if ev_type not in ['int', 'float']:
- self.info('Unsupported expvar_type "{0}". Must be "int" or "float"'.format(ev_type))
- continue
-
- # self.expvars[ev_key] = (ev_type, line_id)
- self.expvars.append(EXPVAR(ev_key, ev_type, line_id))
-
- chart_dict['lines'].append(
- [
- line.get('id', ''),
- line.get('name', ''),
- line.get('algorithm', ''),
- line.get('multiplier', 1),
- line.get('divisor', 100 if ev_type == 'float' else 1),
- line.get('hidden', False)
- ]
- )
-
- self.order.append(chart_id)
- self.definitions[chart_id] = chart_dict
-
- def _get_data(self):
- """
- Format data received from http request
- :return: dict
- """
-
- raw_data = self._get_raw_data()
- if not raw_data:
- return None
-
- data = json.loads(raw_data)
-
- expvars = dict()
- if self.configuration.get('collect_memstats'):
- expvars.update(self._parse_memstats(data))
-
- if self.configuration.get('extra_charts'):
- # the memstats part of the data has been already parsed, so we remove it before flattening and checking
- # the rest of the data, thus avoiding needless iterating over the multiply nested memstats dict.
- del (data['memstats'])
- flattened = flatten(data)
-
- for ev in self.expvars:
- v = flattened.get(ev.key)
-
- if v is None:
- continue
-
- try:
- if ev.type == 'int':
- expvars[ev.id] = int(v)
- elif ev.type == 'float':
- expvars[ev.id] = float(v) * 100
- except ValueError:
- self.info('Failed to parse value for key {0} as {1}, ignoring key.'.format(ev.key, ev.type))
- return None
-
- return expvars
-
- @staticmethod
- def _parse_memstats(data):
-
- memstats = data['memstats']
-
- # calculate the number of live objects in memory
- live_objs = int(memstats['Mallocs']) - int(memstats['Frees'])
-
- # calculate GC pause times average
- # the Go runtime keeps the last 256 GC pause durations in a circular buffer,
- # so we need to filter out the 0 values before the buffer is filled
- gc_pauses = memstats['PauseNs']
- try:
- gc_pause_avg = sum(gc_pauses) / len([x for x in gc_pauses if x > 0])
- # no GC cycles have occurred yet
- except ZeroDivisionError:
- gc_pause_avg = 0
-
- return {
- 'memstats_heap_alloc': memstats['HeapAlloc'],
- 'memstats_heap_inuse': memstats['HeapInuse'],
- 'memstats_stack_inuse': memstats['StackInuse'],
- 'memstats_mspan_inuse': memstats['MSpanInuse'],
- 'memstats_mcache_inuse': memstats['MCacheInuse'],
- 'memstats_sys': memstats['Sys'],
- 'memstats_live_objects': live_objs,
- 'memstats_gc_pauses': gc_pause_avg,
- }
diff --git a/collectors/python.d.plugin/go_expvar/go_expvar.conf b/collectors/python.d.plugin/go_expvar/go_expvar.conf
deleted file mode 100644
index 4b821cde9..000000000
--- a/collectors/python.d.plugin/go_expvar/go_expvar.conf
+++ /dev/null
@@ -1,108 +0,0 @@
-# netdata python.d.plugin configuration for go_expvar
-#
-# This file is in YaML format. Generally the format is:
-#
-# name: value
-#
-# There are 2 sections:
-# - global variables
-# - one or more JOBS
-#
-# JOBS allow you to collect values from multiple sources.
-# Each source will have its own set of charts.
-#
-# JOB parameters have to be indented (using spaces only, example below).
-
-# ----------------------------------------------------------------------
-# Global Variables
-# These variables set the defaults for all JOBs, however each JOB
-# may define its own, overriding the defaults.
-
-# update_every sets the default data collection frequency.
-# If unset, the python.d.plugin default is used.
-# update_every: 1
-
-# priority controls the order of charts at the netdata dashboard.
-# Lower numbers move the charts towards the top of the page.
-# If unset, the default for python.d.plugin is used.
-# priority: 60000
-
-# penalty indicates whether to apply penalty to update_every in case of failures.
-# Penalty will increase every 5 failed updates in a row. Maximum penalty is 10 minutes.
-# penalty: yes
-
-# autodetection_retry sets the job re-check interval in seconds.
-# The job is not deleted if check fails.
-# Attempts to start the job are made once every autodetection_retry.
-# This feature is disabled by default.
-# autodetection_retry: 0
-
-# ----------------------------------------------------------------------
-# JOBS (data collection sources)
-#
-# Any number of jobs is supported.
-#
-# All python.d.plugin JOBS (for all its modules) support a set of
-# predefined parameters. These are:
-#
-# job_name:
-# name: myname # the JOB's name as it will appear at the
-# # dashboard (by default is the job_name)
-# # JOBs sharing a name are mutually exclusive
-# update_every: 1 # the JOB's data collection frequency
-# priority: 60000 # the JOB's order on the dashboard
-# penalty: yes # the JOB's penalty
-# autodetection_retry: 0 # the JOB's re-check interval in seconds
-#
-# Additionally to the above, this plugin also supports the following:
-#
-# url: 'http://127.0.0.1/debug/vars' # the URL of the expvar endpoint
-#
-# As the plugin cannot possibly know the port your application listens on, there is no default value. Please include
-# the whole path of the endpoint, as the expvar handler can be installed in a non-standard location.
-#
-# if the URL is password protected, the following are supported:
-#
-# user: 'username'
-# pass: 'password'
-#
-# collect_memstats: true # enables charts for Go runtime's memory statistics
-# extra_charts: {} # defines extra data/charts to monitor, please see the example below
-#
-# If collect_memstats is disabled and no extra charts are defined, this module will disable itself, as it has no data to
-# collect.
-#
-# Please visit the module wiki page for more information on how to use the extra_charts variable:
-#
-# https://github.com/netdata/netdata/tree/master/collectors/python.d.plugin/go_expvar
-#
-# Configuration example
-# ---------------------
-
-#app1:
-# name : 'app1'
-# url : 'http://127.0.0.1:8080/debug/vars'
-# collect_memstats: true
-# extra_charts:
-# - id: "runtime_goroutines"
-# options:
-# name: num_goroutines
-# title: "runtime: number of goroutines"
-# units: goroutines
-# family: runtime
-# context: expvar.runtime.goroutines
-# chart_type: line
-# lines:
-# - {expvar_key: 'runtime.goroutines', expvar_type: int, id: runtime_goroutines}
-# - id: "foo_counters"
-# options:
-# name: counters
-# title: "some random counters"
-# units: awesomeness
-# family: counters
-# context: expvar.foo.counters
-# chart_type: line
-# lines:
-# - {expvar_key: 'counters.cnt1', expvar_type: int, id: counters_cnt1}
-# - {expvar_key: 'counters.cnt2', expvar_type: float, id: counters_cnt2}
-
diff --git a/collectors/python.d.plugin/go_expvar/integrations/go_applications_expvar.md b/collectors/python.d.plugin/go_expvar/integrations/go_applications_expvar.md
deleted file mode 100644
index 8d61fa2ae..000000000
--- a/collectors/python.d.plugin/go_expvar/integrations/go_applications_expvar.md
+++ /dev/null
@@ -1,335 +0,0 @@
-<!--startmeta
-custom_edit_url: "https://github.com/netdata/netdata/edit/master/collectors/python.d.plugin/go_expvar/README.md"
-meta_yaml: "https://github.com/netdata/netdata/edit/master/collectors/python.d.plugin/go_expvar/metadata.yaml"
-sidebar_label: "Go applications (EXPVAR)"
-learn_status: "Published"
-learn_rel_path: "Data Collection/APM"
-most_popular: False
-message: "DO NOT EDIT THIS FILE DIRECTLY, IT IS GENERATED BY THE COLLECTOR'S metadata.yaml FILE"
-endmeta-->
-
-# Go applications (EXPVAR)
-
-
-<img src="https://netdata.cloud/img/go.png" width="150"/>
-
-
-Plugin: python.d.plugin
-Module: go_expvar
-
-<img src="https://img.shields.io/badge/maintained%20by-Netdata-%2300ab44" />
-
-## Overview
-
-This collector monitors Go applications that expose their metrics with the use of the `expvar` package from the Go standard library. It produces charts for Go runtime memory statistics and optionally any number of custom charts.
-
-It connects via http to gather the metrics exposed via the `expvar` package.
-
-This collector is supported on all platforms.
-
-This collector supports collecting metrics from multiple instances of this integration, including remote instances.
-
-
-### Default Behavior
-
-#### Auto-Detection
-
-This integration doesn't support auto-detection.
-
-#### Limits
-
-The default configuration for this integration does not impose any limits on data collection.
-
-#### Performance Impact
-
-The default configuration for this integration is not expected to impose a significant performance impact on the system.
-
-
-## Metrics
-
-Metrics grouped by *scope*.
-
-The scope defines the instance that the metric belongs to. An instance is uniquely identified by a set of labels.
-
-
-
-### Per Go applications (EXPVAR) instance
-
-These metrics refer to the entire monitored application.
-
-This scope has no labels.
-
-Metrics:
-
-| Metric | Dimensions | Unit |
-|:------|:----------|:----|
-| expvar.memstats.heap | alloc, inuse | KiB |
-| expvar.memstats.stack | inuse | KiB |
-| expvar.memstats.mspan | inuse | KiB |
-| expvar.memstats.mcache | inuse | KiB |
-| expvar.memstats.live_objects | live | objects |
-| expvar.memstats.sys | sys | KiB |
-| expvar.memstats.gc_pauses | avg | ns |
-
-
-
-## Alerts
-
-There are no alerts configured by default for this integration.
-
-
-## Setup
-
-### Prerequisites
-
-#### Enable the go_expvar collector
-
-The `go_expvar` collector is disabled by default. To enable it, use `edit-config` from the Netdata [config directory](https://github.com/netdata/netdata/blob/master/docs/configure/nodes.md), which is typically at `/etc/netdata`, to edit the `python.d.conf` file.
-
-```bash
-cd /etc/netdata # Replace this path with your Netdata config directory, if different
-sudo ./edit-config python.d.conf
-```
-
-Change the value of the `go_expvar` setting to `yes`. Save the file and restart the Netdata Agent with `sudo systemctl restart netdata`, or the [appropriate method](https://github.com/netdata/netdata/blob/master/docs/configure/start-stop-restart.md) for your system.
-
-
-#### Sample `expvar` usage in a Go application
-
-The `expvar` package exposes metrics over HTTP and is very easy to use.
-Consider this minimal sample below:
-
-```go
-package main
-
-import (
- _ "expvar"
- "net/http"
-)
-
-func main() {
- http.ListenAndServe("127.0.0.1:8080", nil)
-}
-```
-
-When imported this way, the `expvar` package registers a HTTP handler at `/debug/vars` that
-exposes Go runtime's memory statistics in JSON format. You can inspect the output by opening
-the URL in your browser (or by using `wget` or `curl`).
-
-Sample output:
-
-```json
-{
-"cmdline": ["./expvar-demo-binary"],
-"memstats": {"Alloc":630856,"TotalAlloc":630856,"Sys":3346432,"Lookups":27, <omitted for brevity>}
-}
-```
-
-You can of course expose and monitor your own variables as well.
-Here is a sample Go application that exposes a few custom variables:
-
-```go
-package main
-
-import (
- "expvar"
- "net/http"
- "runtime"
- "time"
-)
-
-func main() {
-
- tick := time.NewTicker(1 * time.Second)
- num_go := expvar.NewInt("runtime.goroutines")
- counters := expvar.NewMap("counters")
- counters.Set("cnt1", new(expvar.Int))
- counters.Set("cnt2", new(expvar.Float))
-
- go http.ListenAndServe(":8080", nil)
-
- for {
- select {
- case <- tick.C:
- num_go.Set(int64(runtime.NumGoroutine()))
- counters.Add("cnt1", 1)
- counters.AddFloat("cnt2", 1.452)
- }
- }
-}
-```
-
-Apart from the runtime memory stats, this application publishes two counters and the
-number of currently running Goroutines and updates these stats every second.
-
-
-
-### Configuration
-
-#### File
-
-The configuration file name for this integration is `python.d/go_expvar.conf`.
-
-
-You can edit the configuration file using the `edit-config` script from the
-Netdata [config directory](https://github.com/netdata/netdata/blob/master/docs/configure/nodes.md#the-netdata-config-directory).
-
-```bash
-cd /etc/netdata 2>/dev/null || cd /opt/netdata/etc/netdata
-sudo ./edit-config python.d/go_expvar.conf
-```
-#### Options
-
-There are 2 sections:
-
-* Global variables
-* One or more JOBS that can define multiple different instances to monitor.
-
-The following options can be defined globally: priority, penalty, autodetection_retry, update_every, but can also be defined per JOB to override the global values.
-
-Additionally, the following collapsed table contains all the options that can be configured inside a JOB definition.
-
-Every configuration JOB starts with a `job_name` value which will appear in the dashboard, unless a `name` parameter is specified. Each JOB can be used to monitor a different Go application.
-
-
-<details><summary>Config options</summary>
-
-| Name | Description | Default | Required |
-|:----|:-----------|:-------|:--------:|
-| update_every | Sets the default data collection frequency. | 5 | no |
-| priority | Controls the order of charts at the netdata dashboard. | 60000 | no |
-| autodetection_retry | Sets the job re-check interval in seconds. | 0 | no |
-| penalty | Indicates whether to apply penalty to update_every in case of failures. | yes | no |
-| name | Job name. This value will overwrite the `job_name` value. JOBS with the same name are mutually exclusive. Only one of them will be allowed running at any time. This allows autodetection to try several alternatives and pick the one that works. | | no |
-| url | the URL and port of the expvar endpoint. Please include the whole path of the endpoint, as the expvar handler can be installed in a non-standard location. | | yes |
-| user | If the URL is password protected, this is the username to use. | | no |
-| pass | If the URL is password protected, this is the password to use. | | no |
-| collect_memstats | Enables charts for Go runtime's memory statistics. | | no |
-| extra_charts | Defines extra data/charts to monitor, please see the example below. | | no |
-
-</details>
-
-#### Examples
-
-##### Monitor a Go app1 application
-
-The example below sets a configuration for a Go application, called `app1`. Besides the `memstats`, the application also exposes two counters and the number of currently running Goroutines and updates these stats every second.
-
-The `go_expvar` collector can monitor these as well with the use of the `extra_charts` configuration variable.
-
-The `extra_charts` variable is a YaML list of Netdata chart definitions.
-Each chart definition has the following keys:
-
-```
-id: Netdata chart ID
-options: a key-value mapping of chart options
-lines: a list of line definitions
-```
-
-**Note: please do not use dots in the chart or line ID field.
-See [this issue](https://github.com/netdata/netdata/pull/1902#issuecomment-284494195) for explanation.**
-
-Please see these two links to the official Netdata documentation for more information about the values:
-
-- [External plugins - charts](https://github.com/netdata/netdata/blob/master/collectors/plugins.d/README.md#chart)
-- [Chart variables](https://github.com/netdata/netdata/blob/master/collectors/python.d.plugin/README.md#global-variables-order-and-chart)
-
-**Line definitions**
-
-Each chart can define multiple lines (dimensions).
-A line definition is a key-value mapping of line options.
-Each line can have the following options:
-
-```
-# mandatory
-expvar_key: the name of the expvar as present in the JSON output of /debug/vars endpoint
-expvar_type: value type; supported are "float" or "int"
-id: the id of this line/dimension in Netdata
-
-# optional - Netdata defaults are used if these options are not defined
-name: ''
-algorithm: absolute
-multiplier: 1
-divisor: 100 if expvar_type == float, 1 if expvar_type == int
-hidden: False
-```
-
-Please see the following link for more information about the options and their default values:
-[External plugins - dimensions](https://github.com/netdata/netdata/blob/master/collectors/plugins.d/README.md#dimension)
-
-Apart from top-level expvars, this plugin can also parse expvars stored in a multi-level map;
-All dicts in the resulting JSON document are then flattened to one level.
-Expvar names are joined together with '.' when flattening.
-
-Example:
-
-```
-{
- "counters": {"cnt1": 1042, "cnt2": 1512.9839999999983},
- "runtime.goroutines": 5
-}
-```
-
-In the above case, the exported variables will be available under `runtime.goroutines`,
-`counters.cnt1` and `counters.cnt2` expvar_keys. If the flattening results in a key collision,
-the first defined key wins and all subsequent keys with the same name are ignored.
-
-
-```yaml
-app1:
- name : 'app1'
- url : 'http://127.0.0.1:8080/debug/vars'
- collect_memstats: true
- extra_charts:
- - id: "runtime_goroutines"
- options:
- name: num_goroutines
- title: "runtime: number of goroutines"
- units: goroutines
- family: runtime
- context: expvar.runtime.goroutines
- chart_type: line
- lines:
- - {expvar_key: 'runtime.goroutines', expvar_type: int, id: runtime_goroutines}
- - id: "foo_counters"
- options:
- name: counters
- title: "some random counters"
- units: awesomeness
- family: counters
- context: expvar.foo.counters
- chart_type: line
- lines:
- - {expvar_key: 'counters.cnt1', expvar_type: int, id: counters_cnt1}
- - {expvar_key: 'counters.cnt2', expvar_type: float, id: counters_cnt2}
-
-```
-
-
-## Troubleshooting
-
-### Debug Mode
-
-To troubleshoot issues with the `go_expvar` collector, run the `python.d.plugin` with the debug option enabled. The output
-should give you clues as to why the collector isn't working.
-
-- Navigate to the `plugins.d` directory, usually at `/usr/libexec/netdata/plugins.d/`. If that's not the case on
- your system, open `netdata.conf` and look for the `plugins` setting under `[directories]`.
-
- ```bash
- cd /usr/libexec/netdata/plugins.d/
- ```
-
-- Switch to the `netdata` user.
-
- ```bash
- sudo -u netdata -s
- ```
-
-- Run the `python.d.plugin` to debug the collector:
-
- ```bash
- ./python.d.plugin go_expvar debug trace
- ```
-
-
diff --git a/collectors/python.d.plugin/go_expvar/metadata.yaml b/collectors/python.d.plugin/go_expvar/metadata.yaml
deleted file mode 100644
index 9419b024a..000000000
--- a/collectors/python.d.plugin/go_expvar/metadata.yaml
+++ /dev/null
@@ -1,329 +0,0 @@
-plugin_name: python.d.plugin
-modules:
- - meta:
- plugin_name: python.d.plugin
- module_name: go_expvar
- monitored_instance:
- name: Go applications (EXPVAR)
- link: "https://pkg.go.dev/expvar"
- categories:
- - data-collection.apm
- icon_filename: "go.png"
- related_resources:
- integrations:
- list: []
- info_provided_to_referring_integrations:
- description: ""
- keywords:
- - go
- - expvar
- - application
- most_popular: false
- overview:
- data_collection:
- metrics_description: "This collector monitors Go applications that expose their metrics with the use of the `expvar` package from the Go standard library. It produces charts for Go runtime memory statistics and optionally any number of custom charts."
- method_description: "It connects via http to gather the metrics exposed via the `expvar` package."
- supported_platforms:
- include: []
- exclude: []
- multi_instance: true
- additional_permissions:
- description: ""
- default_behavior:
- auto_detection:
- description: ""
- limits:
- description: ""
- performance_impact:
- description: ""
- setup:
- prerequisites:
- list:
- - title: "Enable the go_expvar collector"
- description: |
- The `go_expvar` collector is disabled by default. To enable it, use `edit-config` from the Netdata [config directory](https://github.com/netdata/netdata/blob/master/docs/configure/nodes.md), which is typically at `/etc/netdata`, to edit the `python.d.conf` file.
-
- ```bash
- cd /etc/netdata # Replace this path with your Netdata config directory, if different
- sudo ./edit-config python.d.conf
- ```
-
- Change the value of the `go_expvar` setting to `yes`. Save the file and restart the Netdata Agent with `sudo systemctl restart netdata`, or the [appropriate method](https://github.com/netdata/netdata/blob/master/docs/configure/start-stop-restart.md) for your system.
- - title: "Sample `expvar` usage in a Go application"
- description: |
- The `expvar` package exposes metrics over HTTP and is very easy to use.
- Consider this minimal sample below:
-
- ```go
- package main
-
- import (
- _ "expvar"
- "net/http"
- )
-
- func main() {
- http.ListenAndServe("127.0.0.1:8080", nil)
- }
- ```
-
- When imported this way, the `expvar` package registers a HTTP handler at `/debug/vars` that
- exposes Go runtime's memory statistics in JSON format. You can inspect the output by opening
- the URL in your browser (or by using `wget` or `curl`).
-
- Sample output:
-
- ```json
- {
- "cmdline": ["./expvar-demo-binary"],
- "memstats": {"Alloc":630856,"TotalAlloc":630856,"Sys":3346432,"Lookups":27, <omitted for brevity>}
- }
- ```
-
- You can of course expose and monitor your own variables as well.
- Here is a sample Go application that exposes a few custom variables:
-
- ```go
- package main
-
- import (
- "expvar"
- "net/http"
- "runtime"
- "time"
- )
-
- func main() {
-
- tick := time.NewTicker(1 * time.Second)
- num_go := expvar.NewInt("runtime.goroutines")
- counters := expvar.NewMap("counters")
- counters.Set("cnt1", new(expvar.Int))
- counters.Set("cnt2", new(expvar.Float))
-
- go http.ListenAndServe(":8080", nil)
-
- for {
- select {
- case <- tick.C:
- num_go.Set(int64(runtime.NumGoroutine()))
- counters.Add("cnt1", 1)
- counters.AddFloat("cnt2", 1.452)
- }
- }
- }
- ```
-
- Apart from the runtime memory stats, this application publishes two counters and the
- number of currently running Goroutines and updates these stats every second.
- configuration:
- file:
- name: python.d/go_expvar.conf
- options:
- description: |
- There are 2 sections:
-
- * Global variables
- * One or more JOBS that can define multiple different instances to monitor.
-
- The following options can be defined globally: priority, penalty, autodetection_retry, update_every, but can also be defined per JOB to override the global values.
-
- Additionally, the following collapsed table contains all the options that can be configured inside a JOB definition.
-
- Every configuration JOB starts with a `job_name` value which will appear in the dashboard, unless a `name` parameter is specified. Each JOB can be used to monitor a different Go application.
- folding:
- title: "Config options"
- enabled: true
- list:
- - name: update_every
- description: Sets the default data collection frequency.
- default_value: 5
- required: false
- - name: priority
- description: Controls the order of charts at the netdata dashboard.
- default_value: 60000
- required: false
- - name: autodetection_retry
- description: Sets the job re-check interval in seconds.
- default_value: 0
- required: false
- - name: penalty
- description: Indicates whether to apply penalty to update_every in case of failures.
- default_value: yes
- required: false
- - name: name
- description: Job name. This value will overwrite the `job_name` value. JOBS with the same name are mutually exclusive. Only one of them will be allowed running at any time. This allows autodetection to try several alternatives and pick the one that works.
- default_value: ""
- required: false
- - name: url
- description: the URL and port of the expvar endpoint. Please include the whole path of the endpoint, as the expvar handler can be installed in a non-standard location.
- default_value: ""
- required: true
- - name: user
- description: If the URL is password protected, this is the username to use.
- default_value: ""
- required: false
- - name: pass
- description: If the URL is password protected, this is the password to use.
- default_value: ""
- required: false
- - name: collect_memstats
- description: Enables charts for Go runtime's memory statistics.
- default_value: ""
- required: false
- - name: extra_charts
- description: Defines extra data/charts to monitor, please see the example below.
- default_value: ""
- required: false
- examples:
- folding:
- enabled: false
- title: "Config"
- list:
- - name: Monitor a Go app1 application
- description: |
- The example below sets a configuration for a Go application, called `app1`. Besides the `memstats`, the application also exposes two counters and the number of currently running Goroutines and updates these stats every second.
-
- The `go_expvar` collector can monitor these as well with the use of the `extra_charts` configuration variable.
-
- The `extra_charts` variable is a YaML list of Netdata chart definitions.
- Each chart definition has the following keys:
-
- ```
- id: Netdata chart ID
- options: a key-value mapping of chart options
- lines: a list of line definitions
- ```
-
- **Note: please do not use dots in the chart or line ID field.
- See [this issue](https://github.com/netdata/netdata/pull/1902#issuecomment-284494195) for explanation.**
-
- Please see these two links to the official Netdata documentation for more information about the values:
-
- - [External plugins - charts](https://github.com/netdata/netdata/blob/master/collectors/plugins.d/README.md#chart)
- - [Chart variables](https://github.com/netdata/netdata/blob/master/collectors/python.d.plugin/README.md#global-variables-order-and-chart)
-
- **Line definitions**
-
- Each chart can define multiple lines (dimensions).
- A line definition is a key-value mapping of line options.
- Each line can have the following options:
-
- ```
- # mandatory
- expvar_key: the name of the expvar as present in the JSON output of /debug/vars endpoint
- expvar_type: value type; supported are "float" or "int"
- id: the id of this line/dimension in Netdata
-
- # optional - Netdata defaults are used if these options are not defined
- name: ''
- algorithm: absolute
- multiplier: 1
- divisor: 100 if expvar_type == float, 1 if expvar_type == int
- hidden: False
- ```
-
- Please see the following link for more information about the options and their default values:
- [External plugins - dimensions](https://github.com/netdata/netdata/blob/master/collectors/plugins.d/README.md#dimension)
-
- Apart from top-level expvars, this plugin can also parse expvars stored in a multi-level map;
- All dicts in the resulting JSON document are then flattened to one level.
- Expvar names are joined together with '.' when flattening.
-
- Example:
-
- ```
- {
- "counters": {"cnt1": 1042, "cnt2": 1512.9839999999983},
- "runtime.goroutines": 5
- }
- ```
-
- In the above case, the exported variables will be available under `runtime.goroutines`,
- `counters.cnt1` and `counters.cnt2` expvar_keys. If the flattening results in a key collision,
- the first defined key wins and all subsequent keys with the same name are ignored.
- config: |
- app1:
- name : 'app1'
- url : 'http://127.0.0.1:8080/debug/vars'
- collect_memstats: true
- extra_charts:
- - id: "runtime_goroutines"
- options:
- name: num_goroutines
- title: "runtime: number of goroutines"
- units: goroutines
- family: runtime
- context: expvar.runtime.goroutines
- chart_type: line
- lines:
- - {expvar_key: 'runtime.goroutines', expvar_type: int, id: runtime_goroutines}
- - id: "foo_counters"
- options:
- name: counters
- title: "some random counters"
- units: awesomeness
- family: counters
- context: expvar.foo.counters
- chart_type: line
- lines:
- - {expvar_key: 'counters.cnt1', expvar_type: int, id: counters_cnt1}
- - {expvar_key: 'counters.cnt2', expvar_type: float, id: counters_cnt2}
- troubleshooting:
- problems:
- list: []
- alerts: []
- metrics:
- folding:
- title: Metrics
- enabled: false
- description: ""
- availability: []
- scopes:
- - name: global
- description: "These metrics refer to the entire monitored application."
- labels: []
- metrics:
- - name: expvar.memstats.heap
- description: "memory: size of heap memory structures"
- unit: "KiB"
- chart_type: line
- dimensions:
- - name: alloc
- - name: inuse
- - name: expvar.memstats.stack
- description: "memory: size of stack memory structures"
- unit: "KiB"
- chart_type: line
- dimensions:
- - name: inuse
- - name: expvar.memstats.mspan
- description: "memory: size of mspan memory structures"
- unit: "KiB"
- chart_type: line
- dimensions:
- - name: inuse
- - name: expvar.memstats.mcache
- description: "memory: size of mcache memory structures"
- unit: "KiB"
- chart_type: line
- dimensions:
- - name: inuse
- - name: expvar.memstats.live_objects
- description: "memory: number of live objects"
- unit: "objects"
- chart_type: line
- dimensions:
- - name: live
- - name: expvar.memstats.sys
- description: "memory: size of reserved virtual address space"
- unit: "KiB"
- chart_type: line
- dimensions:
- - name: sys
- - name: expvar.memstats.gc_pauses
- description: "memory: average duration of GC pauses"
- unit: "ns"
- chart_type: line
- dimensions:
- - name: avg