summaryrefslogtreecommitdiffstats
path: root/collectors/python.d.plugin/puppet
diff options
context:
space:
mode:
Diffstat (limited to 'collectors/python.d.plugin/puppet')
-rw-r--r--collectors/python.d.plugin/puppet/Makefile.inc13
l---------collectors/python.d.plugin/puppet/README.md1
-rw-r--r--collectors/python.d.plugin/puppet/integrations/puppet.md215
-rw-r--r--collectors/python.d.plugin/puppet/metadata.yaml185
-rw-r--r--collectors/python.d.plugin/puppet/puppet.chart.py121
-rw-r--r--collectors/python.d.plugin/puppet/puppet.conf94
6 files changed, 0 insertions, 629 deletions
diff --git a/collectors/python.d.plugin/puppet/Makefile.inc b/collectors/python.d.plugin/puppet/Makefile.inc
deleted file mode 100644
index fe94b9254..000000000
--- a/collectors/python.d.plugin/puppet/Makefile.inc
+++ /dev/null
@@ -1,13 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# THIS IS NOT A COMPLETE Makefile
-# IT IS INCLUDED BY ITS PARENT'S Makefile.am
-# IT IS REQUIRED TO REFERENCE ALL FILES RELATIVE TO THE PARENT
-
-# install these files
-dist_python_DATA += puppet/puppet.chart.py
-dist_pythonconfig_DATA += puppet/puppet.conf
-
-# do not install these files, but include them in the distribution
-dist_noinst_DATA += puppet/README.md puppet/Makefile.inc
-
diff --git a/collectors/python.d.plugin/puppet/README.md b/collectors/python.d.plugin/puppet/README.md
deleted file mode 120000
index b6c4c83f9..000000000
--- a/collectors/python.d.plugin/puppet/README.md
+++ /dev/null
@@ -1 +0,0 @@
-integrations/puppet.md \ No newline at end of file
diff --git a/collectors/python.d.plugin/puppet/integrations/puppet.md b/collectors/python.d.plugin/puppet/integrations/puppet.md
deleted file mode 100644
index ca190b576..000000000
--- a/collectors/python.d.plugin/puppet/integrations/puppet.md
+++ /dev/null
@@ -1,215 +0,0 @@
-<!--startmeta
-custom_edit_url: "https://github.com/netdata/netdata/edit/master/collectors/python.d.plugin/puppet/README.md"
-meta_yaml: "https://github.com/netdata/netdata/edit/master/collectors/python.d.plugin/puppet/metadata.yaml"
-sidebar_label: "Puppet"
-learn_status: "Published"
-learn_rel_path: "Data Collection/CICD Platforms"
-most_popular: False
-message: "DO NOT EDIT THIS FILE DIRECTLY, IT IS GENERATED BY THE COLLECTOR'S metadata.yaml FILE"
-endmeta-->
-
-# Puppet
-
-
-<img src="https://netdata.cloud/img/puppet.svg" width="150"/>
-
-
-Plugin: python.d.plugin
-Module: puppet
-
-<img src="https://img.shields.io/badge/maintained%20by-Netdata-%2300ab44" />
-
-## Overview
-
-This collector monitors Puppet metrics about JVM Heap, Non-Heap, CPU usage and file descriptors.'
-
-
-It uses Puppet's metrics API endpoint to gather the metrics.
-
-
-This collector is supported on all platforms.
-
-This collector supports collecting metrics from multiple instances of this integration, including remote instances.
-
-
-### Default Behavior
-
-#### Auto-Detection
-
-By default, this collector will use `https://fqdn.example.com:8140` as the URL to look for metrics.
-
-#### Limits
-
-The default configuration for this integration does not impose any limits on data collection.
-
-#### Performance Impact
-
-The default configuration for this integration is not expected to impose a significant performance impact on the system.
-
-
-## Metrics
-
-Metrics grouped by *scope*.
-
-The scope defines the instance that the metric belongs to. An instance is uniquely identified by a set of labels.
-
-
-
-### Per Puppet instance
-
-These metrics refer to the entire monitored application.
-
-This scope has no labels.
-
-Metrics:
-
-| Metric | Dimensions | Unit |
-|:------|:----------|:----|
-| puppet.jvm | committed, used | MiB |
-| puppet.jvm | committed, used | MiB |
-| puppet.cpu | execution, GC | percentage |
-| puppet.fdopen | used | descriptors |
-
-
-
-## Alerts
-
-There are no alerts configured by default for this integration.
-
-
-## Setup
-
-### Prerequisites
-
-No action required.
-
-### Configuration
-
-#### File
-
-The configuration file name for this integration is `python.d/puppet.conf`.
-
-
-You can edit the configuration file using the `edit-config` script from the
-Netdata [config directory](https://github.com/netdata/netdata/blob/master/docs/configure/nodes.md#the-netdata-config-directory).
-
-```bash
-cd /etc/netdata 2>/dev/null || cd /opt/netdata/etc/netdata
-sudo ./edit-config python.d/puppet.conf
-```
-#### Options
-
-This particular collector does not need further configuration to work if permissions are satisfied, but you can always customize it's data collection behavior.
-
-There are 2 sections:
-
-* Global variables
-* One or more JOBS that can define multiple different instances to monitor.
-
-The following options can be defined globally: priority, penalty, autodetection_retry, update_every, but can also be defined per JOB to override the global values.
-
-Additionally, the following collapsed table contains all the options that can be configured inside a JOB definition.
-
-Every configuration JOB starts with a `job_name` value which will appear in the dashboard, unless a `name` parameter is specified.
-
-> Notes:
-> - Exact Fully Qualified Domain Name of the node should be used.
-> - Usually Puppet Server/DB startup time is VERY long. So, there should be quite reasonable retry count.
-> - A secured PuppetDB config may require a client certificate. This does not apply to the default PuppetDB configuration though.
-
-
-<details><summary>Config options</summary>
-
-| Name | Description | Default | Required |
-|:----|:-----------|:-------|:--------:|
-| url | HTTP or HTTPS URL, exact Fully Qualified Domain Name of the node should be used. | https://fqdn.example.com:8081 | yes |
-| tls_verify | Control HTTPS server certificate verification. | False | no |
-| tls_ca_file | Optional CA (bundle) file to use | | no |
-| tls_cert_file | Optional client certificate file | | no |
-| tls_key_file | Optional client key file | | no |
-| update_every | Sets the default data collection frequency. | 30 | no |
-| priority | Controls the order of charts at the netdata dashboard. | 60000 | no |
-| autodetection_retry | Sets the job re-check interval in seconds. | 0 | no |
-| penalty | Indicates whether to apply penalty to update_every in case of failures. | yes | no |
-| name | Job name. This value will overwrite the `job_name` value. JOBS with the same name are mutually exclusive. Only one of them will be allowed running at any time. This allows autodetection to try several alternatives and pick the one that works. | | no |
-
-</details>
-
-#### Examples
-
-##### Basic
-
-A basic example configuration
-
-```yaml
-puppetserver:
- url: 'https://fqdn.example.com:8140'
- autodetection_retry: 1
-
-```
-##### TLS Certificate
-
-An example using a TLS certificate
-
-<details><summary>Config</summary>
-
-```yaml
-puppetdb:
- url: 'https://fqdn.example.com:8081'
- tls_cert_file: /path/to/client.crt
- tls_key_file: /path/to/client.key
- autodetection_retry: 1
-
-```
-</details>
-
-##### Multi-instance
-
-> **Note**: When you define multiple jobs, their names must be unique.
-
-Collecting metrics from local and remote instances.
-
-
-<details><summary>Config</summary>
-
-```yaml
-puppetserver1:
- url: 'https://fqdn.example.com:8140'
- autodetection_retry: 1
-
-puppetserver2:
- url: 'https://fqdn.example2.com:8140'
- autodetection_retry: 1
-
-```
-</details>
-
-
-
-## Troubleshooting
-
-### Debug Mode
-
-To troubleshoot issues with the `puppet` collector, run the `python.d.plugin` with the debug option enabled. The output
-should give you clues as to why the collector isn't working.
-
-- Navigate to the `plugins.d` directory, usually at `/usr/libexec/netdata/plugins.d/`. If that's not the case on
- your system, open `netdata.conf` and look for the `plugins` setting under `[directories]`.
-
- ```bash
- cd /usr/libexec/netdata/plugins.d/
- ```
-
-- Switch to the `netdata` user.
-
- ```bash
- sudo -u netdata -s
- ```
-
-- Run the `python.d.plugin` to debug the collector:
-
- ```bash
- ./python.d.plugin puppet debug trace
- ```
-
-
diff --git a/collectors/python.d.plugin/puppet/metadata.yaml b/collectors/python.d.plugin/puppet/metadata.yaml
deleted file mode 100644
index 781519b6a..000000000
--- a/collectors/python.d.plugin/puppet/metadata.yaml
+++ /dev/null
@@ -1,185 +0,0 @@
-plugin_name: python.d.plugin
-modules:
- - meta:
- plugin_name: python.d.plugin
- module_name: puppet
- monitored_instance:
- name: Puppet
- link: "https://www.puppet.com/"
- categories:
- - data-collection.ci-cd-systems
- icon_filename: "puppet.svg"
- related_resources:
- integrations:
- list: []
- info_provided_to_referring_integrations:
- description: ""
- keywords:
- - puppet
- - jvm heap
- most_popular: false
- overview:
- data_collection:
- metrics_description: |
- This collector monitors Puppet metrics about JVM Heap, Non-Heap, CPU usage and file descriptors.'
- method_description: |
- It uses Puppet's metrics API endpoint to gather the metrics.
- supported_platforms:
- include: []
- exclude: []
- multi_instance: true
- additional_permissions:
- description: ""
- default_behavior:
- auto_detection:
- description: By default, this collector will use `https://fqdn.example.com:8140` as the URL to look for metrics.
- limits:
- description: ""
- performance_impact:
- description: ""
- setup:
- prerequisites:
- list: []
- configuration:
- file:
- name: "python.d/puppet.conf"
- options:
- description: |
- This particular collector does not need further configuration to work if permissions are satisfied, but you can always customize it's data collection behavior.
-
- There are 2 sections:
-
- * Global variables
- * One or more JOBS that can define multiple different instances to monitor.
-
- The following options can be defined globally: priority, penalty, autodetection_retry, update_every, but can also be defined per JOB to override the global values.
-
- Additionally, the following collapsed table contains all the options that can be configured inside a JOB definition.
-
- Every configuration JOB starts with a `job_name` value which will appear in the dashboard, unless a `name` parameter is specified.
-
- > Notes:
- > - Exact Fully Qualified Domain Name of the node should be used.
- > - Usually Puppet Server/DB startup time is VERY long. So, there should be quite reasonable retry count.
- > - A secured PuppetDB config may require a client certificate. This does not apply to the default PuppetDB configuration though.
- folding:
- title: "Config options"
- enabled: true
- list:
- - name: url
- description: HTTP or HTTPS URL, exact Fully Qualified Domain Name of the node should be used.
- default_value: https://fqdn.example.com:8081
- required: true
- - name: tls_verify
- description: Control HTTPS server certificate verification.
- default_value: "False"
- required: false
- - name: tls_ca_file
- description: Optional CA (bundle) file to use
- default_value: ""
- required: false
- - name: tls_cert_file
- description: Optional client certificate file
- default_value: ""
- required: false
- - name: tls_key_file
- description: Optional client key file
- default_value: ""
- required: false
- - name: update_every
- description: Sets the default data collection frequency.
- default_value: 30
- required: false
- - name: priority
- description: Controls the order of charts at the netdata dashboard.
- default_value: 60000
- required: false
- - name: autodetection_retry
- description: Sets the job re-check interval in seconds.
- default_value: 0
- required: false
- - name: penalty
- description: Indicates whether to apply penalty to update_every in case of failures.
- default_value: yes
- required: false
- - name: name
- description: >
- Job name. This value will overwrite the `job_name` value. JOBS with the same name are mutually exclusive. Only one of them will be allowed running at any time. This allows autodetection to try several alternatives and pick the one that works.
- default_value: ""
- required: false
- examples:
- folding:
- enabled: true
- title: "Config"
- list:
- - name: Basic
- description: A basic example configuration
- folding:
- enabled: false
- config: |
- puppetserver:
- url: 'https://fqdn.example.com:8140'
- autodetection_retry: 1
- - name: TLS Certificate
- description: An example using a TLS certificate
- config: |
- puppetdb:
- url: 'https://fqdn.example.com:8081'
- tls_cert_file: /path/to/client.crt
- tls_key_file: /path/to/client.key
- autodetection_retry: 1
- - name: Multi-instance
- description: |
- > **Note**: When you define multiple jobs, their names must be unique.
-
- Collecting metrics from local and remote instances.
- config: |
- puppetserver1:
- url: 'https://fqdn.example.com:8140'
- autodetection_retry: 1
-
- puppetserver2:
- url: 'https://fqdn.example2.com:8140'
- autodetection_retry: 1
- troubleshooting:
- problems:
- list: []
- alerts: []
- metrics:
- folding:
- title: Metrics
- enabled: false
- description: ""
- availability: []
- scopes:
- - name: global
- description: "These metrics refer to the entire monitored application."
- labels: []
- metrics:
- - name: puppet.jvm
- description: JVM Heap
- unit: "MiB"
- chart_type: area
- dimensions:
- - name: committed
- - name: used
- - name: puppet.jvm
- description: JVM Non-Heap
- unit: "MiB"
- chart_type: area
- dimensions:
- - name: committed
- - name: used
- - name: puppet.cpu
- description: CPU usage
- unit: "percentage"
- chart_type: stacked
- dimensions:
- - name: execution
- - name: GC
- - name: puppet.fdopen
- description: File Descriptors
- unit: "descriptors"
- chart_type: line
- dimensions:
- - name: used
diff --git a/collectors/python.d.plugin/puppet/puppet.chart.py b/collectors/python.d.plugin/puppet/puppet.chart.py
deleted file mode 100644
index f8adf6006..000000000
--- a/collectors/python.d.plugin/puppet/puppet.chart.py
+++ /dev/null
@@ -1,121 +0,0 @@
-# -*- coding: utf-8 -*-
-# Description: puppet netdata python.d module
-# Author: Andrey Galkin <andrey@futoin.org> (andvgal)
-# SPDX-License-Identifier: GPL-3.0-or-later
-#
-# This module should work both with OpenSource and PE versions
-# of PuppetServer and PuppetDB.
-#
-# NOTE: PuppetDB may be configured to require proper TLS
-# client certificate for security reasons. Use tls_key_file
-# and tls_cert_file options then.
-#
-
-import socket
-from json import loads
-
-from bases.FrameworkServices.UrlService import UrlService
-
-update_every = 5
-
-MiB = 1 << 20
-CPU_SCALE = 1000
-
-ORDER = [
- 'jvm_heap',
- 'jvm_nonheap',
- 'cpu',
- 'fd_open',
-]
-
-CHARTS = {
- 'jvm_heap': {
- 'options': [None, 'JVM Heap', 'MiB', 'resources', 'puppet.jvm', 'area'],
- 'lines': [
- ['jvm_heap_committed', 'committed', 'absolute', 1, MiB],
- ['jvm_heap_used', 'used', 'absolute', 1, MiB],
- ],
- 'variables': [
- ['jvm_heap_max'],
- ['jvm_heap_init'],
- ],
- },
- 'jvm_nonheap': {
- 'options': [None, 'JVM Non-Heap', 'MiB', 'resources', 'puppet.jvm', 'area'],
- 'lines': [
- ['jvm_nonheap_committed', 'committed', 'absolute', 1, MiB],
- ['jvm_nonheap_used', 'used', 'absolute', 1, MiB],
- ],
- 'variables': [
- ['jvm_nonheap_max'],
- ['jvm_nonheap_init'],
- ],
- },
- 'cpu': {
- 'options': [None, 'CPU usage', 'percentage', 'resources', 'puppet.cpu', 'stacked'],
- 'lines': [
- ['cpu_time', 'execution', 'absolute', 1, CPU_SCALE],
- ['gc_time', 'GC', 'absolute', 1, CPU_SCALE],
- ]
- },
- 'fd_open': {
- 'options': [None, 'File Descriptors', 'descriptors', 'resources', 'puppet.fdopen', 'line'],
- 'lines': [
- ['fd_used', 'used', 'absolute'],
- ],
- 'variables': [
- ['fd_max'],
- ],
- },
-}
-
-
-class Service(UrlService):
- def __init__(self, configuration=None, name=None):
- UrlService.__init__(self, configuration=configuration, name=name)
- self.order = ORDER
- self.definitions = CHARTS
- self.url = 'https://{0}:8140'.format(socket.getfqdn())
-
- def _get_data(self):
- # NOTE: there are several ways to retrieve data
- # 1. Only PE versions:
- # https://puppet.com/docs/pe/2018.1/api_status/status_api_metrics_endpoints.html
- # 2. Individual Metrics API (JMX):
- # https://puppet.com/docs/pe/2018.1/api_status/metrics_api.html
- # 3. Extended status at debug level:
- # https://puppet.com/docs/pe/2018.1/api_status/status_api_json_endpoints.html
- #
- # For sake of simplicity and efficiency the status one is used..
-
- raw_data = self._get_raw_data(self.url + '/status/v1/services?level=debug')
-
- if raw_data is None:
- return None
-
- raw_data = loads(raw_data)
- data = {}
-
- try:
- try:
- jvm_metrics = raw_data['status-service']['status']['experimental']['jvm-metrics']
- except KeyError:
- jvm_metrics = raw_data['status-service']['status']['jvm-metrics']
-
- heap_mem = jvm_metrics['heap-memory']
- non_heap_mem = jvm_metrics['non-heap-memory']
-
- for k in ['max', 'committed', 'used', 'init']:
- data['jvm_heap_' + k] = heap_mem[k]
- data['jvm_nonheap_' + k] = non_heap_mem[k]
-
- fd_open = jvm_metrics['file-descriptors']
- data['fd_max'] = fd_open['max']
- data['fd_used'] = fd_open['used']
-
- data['cpu_time'] = int(jvm_metrics['cpu-usage'] * CPU_SCALE)
- data['gc_time'] = int(jvm_metrics['gc-cpu-usage'] * CPU_SCALE)
- except KeyError:
- pass
-
- return data or None
diff --git a/collectors/python.d.plugin/puppet/puppet.conf b/collectors/python.d.plugin/puppet/puppet.conf
deleted file mode 100644
index ff5c3d020..000000000
--- a/collectors/python.d.plugin/puppet/puppet.conf
+++ /dev/null
@@ -1,94 +0,0 @@
-# netdata python.d.plugin configuration for Puppet Server and Puppet DB
-#
-# This file is in YaML format. Generally the format is:
-#
-# name: value
-#
-# There are 2 sections:
-# - global variables
-# - one or more JOBS
-#
-# JOBS allow you to collect values from multiple sources.
-# Each source will have its own set of charts.
-#
-# JOB parameters have to be indented (using spaces only, example below).
-
-# ----------------------------------------------------------------------
-# Global Variables
-# These variables set the defaults for all JOBs, however each JOB
-# may define its own, overriding the defaults.
-
-# update_every sets the default data collection frequency.
-# If unset, the python.d.plugin default is used.
-# update_every: 1
-
-# priority controls the order of charts at the netdata dashboard.
-# Lower numbers move the charts towards the top of the page.
-# If unset, the default for python.d.plugin is used.
-# priority: 60000
-
-# penalty indicates whether to apply penalty to update_every in case of failures.
-# Penalty will increase every 5 failed updates in a row. Maximum penalty is 10 minutes.
-# penalty: yes
-
-# autodetection_retry sets the job re-check interval in seconds.
-# The job is not deleted if check fails.
-# Attempts to start the job are made once every autodetection_retry.
-# This feature is disabled by default.
-# autodetection_retry: 0
-
-# ----------------------------------------------------------------------
-# JOBS (data collection sources)
-#
-# The default JOBS share the same *name*. JOBS with the same name
-# are mutually exclusive. Only one of them will be allowed running at
-# any time. This allows autodetection to try several alternatives and
-# pick the one that works.
-#
-# Any number of jobs is supported.
-#
-# All python.d.plugin JOBS (for all its modules) support a set of
-# predefined parameters. These are:
-#
-# job_name:
-# name: myname # the JOB's name as it will appear at the
-# # dashboard (by default is the job_name)
-# # JOBs sharing a name are mutually exclusive
-# update_every: 1 # the JOB's data collection frequency
-# priority: 60000 # the JOB's order on the dashboard
-# penalty: yes # the JOB's penalty
-# autodetection_retry: 0 # the JOB's re-check interval in seconds
-#
-# These configuration comes from UrlService base:
-# url: # HTTP or HTTPS URL
-# tls_verify: False # Control HTTPS server certificate verification
-# tls_ca_file: # Optional CA (bundle) file to use
-# tls_cert_file: # Optional client certificate file
-# tls_key_file: # Optional client key file
-#
-# ----------------------------------------------------------------------
-# AUTO-DETECTION JOBS
-# only one of them will run (they have the same name)
-# puppet:
-# url: 'https://<FQDN>:8140'
-#
-
-#
-# Production configuration should look like below.
-#
-# NOTE: usually Puppet Server/DB startup time is VERY long. So, there should
-# be quite reasonable retry count.
-#
-# NOTE: secure PuppetDB config may require client certificate.
-# Not applies to default PuppetDB configuration though.
-#
-# puppetdb:
-# url: 'https://fqdn.example.com:8081'
-# tls_cert_file: /path/to/client.crt
-# tls_key_file: /path/to/client.key
-# autodetection_retry: 1
-#
-# puppetserver:
-# url: 'https://fqdn.example.com:8140'
-# autodetection_retry: 1
-#