summaryrefslogtreecommitdiffstats
path: root/collectors/python.d.plugin/redis
diff options
context:
space:
mode:
Diffstat (limited to 'collectors/python.d.plugin/redis')
-rw-r--r--collectors/python.d.plugin/redis/Makefile.inc13
-rw-r--r--collectors/python.d.plugin/redis/README.md64
-rw-r--r--collectors/python.d.plugin/redis/redis.chart.py268
-rw-r--r--collectors/python.d.plugin/redis/redis.conf110
4 files changed, 0 insertions, 455 deletions
diff --git a/collectors/python.d.plugin/redis/Makefile.inc b/collectors/python.d.plugin/redis/Makefile.inc
deleted file mode 100644
index 6aab08977..000000000
--- a/collectors/python.d.plugin/redis/Makefile.inc
+++ /dev/null
@@ -1,13 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# THIS IS NOT A COMPLETE Makefile
-# IT IS INCLUDED BY ITS PARENT'S Makefile.am
-# IT IS REQUIRED TO REFERENCE ALL FILES RELATIVE TO THE PARENT
-
-# install these files
-dist_python_DATA += redis/redis.chart.py
-dist_pythonconfig_DATA += redis/redis.conf
-
-# do not install these files, but include them in the distribution
-dist_noinst_DATA += redis/README.md redis/Makefile.inc
-
diff --git a/collectors/python.d.plugin/redis/README.md b/collectors/python.d.plugin/redis/README.md
deleted file mode 100644
index 319827100..000000000
--- a/collectors/python.d.plugin/redis/README.md
+++ /dev/null
@@ -1,64 +0,0 @@
-<!--
-title: "Redis monitoring with Netdata"
-custom_edit_url: https://github.com/netdata/netdata/edit/master/collectors/python.d.plugin/redis/README.md
-sidebar_label: "Redis"
--->
-
-# Redis monitoring with Netdata
-
-Monitors database status. It reads server response to `INFO` command.
-
-Following charts are drawn:
-
-1. **Operations** per second
-
- - operations
-
-2. **Hit rate** in percent
-
- - rate
-
-3. **Memory utilization** in kilobytes
-
- - total
- - lua
-
-4. **Database keys**
-
- - lines are creates dynamically based on how many databases are there
-
-5. **Clients**
-
- - connected
- - blocked
-
-6. **Slaves**
-
- - connected
-
-## Configuration
-
-Edit the `python.d/redis.conf` configuration file using `edit-config` from the Netdata [config
-directory](/docs/configure/nodes.md), which is typically at `/etc/netdata`.
-
-```bash
-cd /etc/netdata # Replace this path with your Netdata config directory, if different
-sudo ./edit-config python.d/redis.conf
-```
-
-```yaml
-socket:
- name : 'local'
- socket : '/var/lib/redis/redis.sock'
-
-localhost:
- name : 'local'
- host : 'localhost'
- port : 6379
-```
-
-When no configuration file is found, module tries to connect to TCP/IP socket: `localhost:6379`.
-
----
-
-
diff --git a/collectors/python.d.plugin/redis/redis.chart.py b/collectors/python.d.plugin/redis/redis.chart.py
deleted file mode 100644
index e09916d86..000000000
--- a/collectors/python.d.plugin/redis/redis.chart.py
+++ /dev/null
@@ -1,268 +0,0 @@
-# -*- coding: utf-8 -*-
-# Description: redis netdata python.d module
-# Author: Pawel Krupa (paulfantom)
-# Author: Ilya Mashchenko (ilyam8)
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-import re
-from copy import deepcopy
-
-from bases.FrameworkServices.SocketService import SocketService
-
-REDIS_ORDER = [
- 'operations',
- 'hit_rate',
- 'memory',
- 'keys_redis',
- 'eviction',
- 'net',
- 'connections',
- 'clients',
- 'slaves',
- 'persistence',
- 'bgsave_now',
- 'bgsave_health',
- 'uptime',
-]
-
-PIKA_ORDER = [
- 'operations',
- 'hit_rate',
- 'memory',
- 'keys_pika',
- 'connections',
- 'clients',
- 'slaves',
- 'uptime',
-]
-
-CHARTS = {
- 'operations': {
- 'options': [None, 'Operations', 'operations/s', 'operations', 'redis.operations', 'line'],
- 'lines': [
- ['total_commands_processed', 'commands', 'incremental'],
- ['instantaneous_ops_per_sec', 'operations', 'absolute']
- ]
- },
- 'hit_rate': {
- 'options': [None, 'Hit rate', 'percentage', 'hits', 'redis.hit_rate', 'line'],
- 'lines': [
- ['hit_rate', 'rate', 'absolute']
- ]
- },
- 'memory': {
- 'options': [None, 'Memory utilization', 'KiB', 'memory', 'redis.memory', 'area'],
- 'lines': [
- ['maxmemory', 'max', 'absolute', 1, 1024],
- ['used_memory', 'total', 'absolute', 1, 1024],
- ['used_memory_lua', 'lua', 'absolute', 1, 1024]
- ]
- },
- 'net': {
- 'options': [None, 'Bandwidth', 'kilobits/s', 'network', 'redis.net', 'area'],
- 'lines': [
- ['total_net_input_bytes', 'in', 'incremental', 8, 1000],
- ['total_net_output_bytes', 'out', 'incremental', -8, 1000]
- ]
- },
- 'keys_redis': {
- 'options': [None, 'Keys per Database', 'keys', 'keys', 'redis.keys', 'line'],
- 'lines': []
- },
- 'keys_pika': {
- 'options': [None, 'Keys', 'keys', 'keys', 'redis.keys', 'line'],
- 'lines': [
- ['kv_keys', 'kv', 'absolute'],
- ['hash_keys', 'hash', 'absolute'],
- ['list_keys', 'list', 'absolute'],
- ['zset_keys', 'zset', 'absolute'],
- ['set_keys', 'set', 'absolute']
- ]
- },
- 'eviction': {
- 'options': [None, 'Evicted Keys', 'keys', 'keys', 'redis.eviction', 'line'],
- 'lines': [
- ['evicted_keys', 'evicted', 'absolute']
- ]
- },
- 'connections': {
- 'options': [None, 'Connections', 'connections/s', 'connections', 'redis.connections', 'line'],
- 'lines': [
- ['total_connections_received', 'received', 'incremental', 1],
- ['rejected_connections', 'rejected', 'incremental', -1]
- ]
- },
- 'clients': {
- 'options': [None, 'Clients', 'clients', 'connections', 'redis.clients', 'line'],
- 'lines': [
- ['connected_clients', 'connected', 'absolute', 1],
- ['blocked_clients', 'blocked', 'absolute', -1]
- ]
- },
- 'slaves': {
- 'options': [None, 'Slaves', 'slaves', 'replication', 'redis.slaves', 'line'],
- 'lines': [
- ['connected_slaves', 'connected', 'absolute']
- ]
- },
- 'persistence': {
- 'options': [None, 'Persistence Changes Since Last Save', 'changes', 'persistence',
- 'redis.rdb_changes', 'line'],
- 'lines': [
- ['rdb_changes_since_last_save', 'changes', 'absolute']
- ]
- },
- 'bgsave_now': {
- 'options': [None, 'Duration of the RDB Save Operation', 'seconds', 'persistence',
- 'redis.bgsave_now', 'absolute'],
- 'lines': [
- ['rdb_bgsave_in_progress', 'rdb save', 'absolute']
- ]
- },
- 'bgsave_health': {
- 'options': [None, 'Status of the Last RDB Save Operation', 'status', 'persistence',
- 'redis.bgsave_health', 'line'],
- 'lines': [
- ['rdb_last_bgsave_status', 'rdb save', 'absolute']
- ]
- },
- 'uptime': {
- 'options': [None, 'Uptime', 'seconds', 'uptime', 'redis.uptime', 'line'],
- 'lines': [
- ['uptime_in_seconds', 'uptime', 'absolute']
- ]
- }
-}
-
-
-def copy_chart(name):
- return {name: deepcopy(CHARTS[name])}
-
-
-RE = re.compile(r'\n([a-z_0-9 ]+):(?:keys=)?([^,\r]+)')
-
-
-class Service(SocketService):
- def __init__(self, configuration=None, name=None):
- SocketService.__init__(self, configuration=configuration, name=name)
- self.order = list()
- self.definitions = dict()
- self._keep_alive = True
- self.host = self.configuration.get('host', 'localhost')
- self.port = self.configuration.get('port', 6379)
- self.unix_socket = self.configuration.get('socket')
- p = self.configuration.get('pass')
- self.auth_request = 'AUTH {0} \r\n'.format(p).encode() if p else None
- self.request = 'INFO\r\n'.encode()
- self.bgsave_time = 0
- self.keyspace_dbs = set()
-
- def do_auth(self):
- resp = self._get_raw_data(request=self.auth_request)
- if not resp:
- return False
- if resp.strip() != '+OK':
- self.error('invalid password')
- return False
- return True
-
- def get_raw_and_parse(self):
- if self.auth_request and not self.do_auth():
- return None
-
- resp = self._get_raw_data()
-
- if not resp:
- return None
-
- parsed = RE.findall(resp)
-
- if not parsed:
- self.error('response is invalid/empty')
- return None
-
- return dict((k.replace(' ', '_'), v) for k, v in parsed)
-
- def get_data(self):
- """
- Get data from socket
- :return: dict
- """
- data = self.get_raw_and_parse()
- if not data:
- return None
-
- self.calc_hit_rate(data)
- self.calc_redis_keys(data)
- self.calc_redis_rdb_save_operations(data)
- return data
-
- @staticmethod
- def calc_hit_rate(data):
- try:
- hits = int(data['keyspace_hits'])
- misses = int(data['keyspace_misses'])
- data['hit_rate'] = hits * 100 / (hits + misses)
- except (KeyError, ZeroDivisionError):
- data['hit_rate'] = 0
-
- def calc_redis_keys(self, data):
- if not data.get('redis_version'):
- return
- # db0:keys=2,expires=0,avg_ttl=0
- new_keyspace_dbs = [k for k in data if k.startswith('db') and k not in self.keyspace_dbs]
- for db in new_keyspace_dbs:
- self.keyspace_dbs.add(db)
- self.charts['keys_redis'].add_dimension([db, None, 'absolute'])
- for db in self.keyspace_dbs:
- if db not in data:
- data[db] = 0
-
- def calc_redis_rdb_save_operations(self, data):
- if not (data.get('redis_version') and data.get('rdb_bgsave_in_progress')):
- return
- if data['rdb_bgsave_in_progress'] != '0':
- self.bgsave_time += self.update_every
- else:
- self.bgsave_time = 0
-
- data['rdb_last_bgsave_status'] = 0 if data['rdb_last_bgsave_status'] == 'ok' else 1
- data['rdb_bgsave_in_progress'] = self.bgsave_time
-
- def check(self):
- """
- Parse configuration, check if redis is available, and dynamically create chart lines data
- :return: boolean
- """
- data = self.get_raw_and_parse()
-
- if not data:
- return False
-
- self.order = PIKA_ORDER if data.get('pika_version') else REDIS_ORDER
-
- for n in self.order:
- self.definitions.update(copy_chart(n))
-
- return True
-
- def _check_raw_data(self, data):
- """
- Check if all data has been gathered from socket.
- Parse first line containing message length and check against received message
- :param data: str
- :return: boolean
- """
- length = len(data)
- supposed = data.split('\n')[0][1:-1]
- offset = len(supposed) + 4 # 1 dollar sing, 1 new line character + 1 ending sequence '\r\n'
- if not supposed.isdigit():
- return True
- supposed = int(supposed)
-
- if length - offset >= supposed:
- self.debug('received full response from redis')
- return True
-
- self.debug('waiting more data from redis')
- return False
diff --git a/collectors/python.d.plugin/redis/redis.conf b/collectors/python.d.plugin/redis/redis.conf
deleted file mode 100644
index b456d75d3..000000000
--- a/collectors/python.d.plugin/redis/redis.conf
+++ /dev/null
@@ -1,110 +0,0 @@
-# netdata python.d.plugin configuration for redis
-#
-# This file is in YaML format. Generally the format is:
-#
-# name: value
-#
-# There are 2 sections:
-# - global variables
-# - one or more JOBS
-#
-# JOBS allow you to collect values from multiple sources.
-# Each source will have its own set of charts.
-#
-# JOB parameters have to be indented (using spaces only, example below).
-
-# ----------------------------------------------------------------------
-# Global Variables
-# These variables set the defaults for all JOBs, however each JOB
-# may define its own, overriding the defaults.
-
-# update_every sets the default data collection frequency.
-# If unset, the python.d.plugin default is used.
-# update_every: 1
-
-# priority controls the order of charts at the netdata dashboard.
-# Lower numbers move the charts towards the top of the page.
-# If unset, the default for python.d.plugin is used.
-# priority: 60000
-
-# penalty indicates whether to apply penalty to update_every in case of failures.
-# Penalty will increase every 5 failed updates in a row. Maximum penalty is 10 minutes.
-# penalty: yes
-
-# autodetection_retry sets the job re-check interval in seconds.
-# The job is not deleted if check fails.
-# Attempts to start the job are made once every autodetection_retry.
-# This feature is disabled by default.
-# autodetection_retry: 0
-
-# ----------------------------------------------------------------------
-# JOBS (data collection sources)
-#
-# The default JOBS share the same *name*. JOBS with the same name
-# are mutually exclusive. Only one of them will be allowed running at
-# any time. This allows autodetection to try several alternatives and
-# pick the one that works.
-#
-# Any number of jobs is supported.
-#
-# All python.d.plugin JOBS (for all its modules) support a set of
-# predefined parameters. These are:
-#
-# job_name:
-# name: myname # the JOB's name as it will appear at the
-# # dashboard (by default is the job_name)
-# # JOBs sharing a name are mutually exclusive
-# update_every: 1 # the JOB's data collection frequency
-# priority: 60000 # the JOB's order on the dashboard
-# penalty: yes # the JOB's penalty
-# autodetection_retry: 0 # the JOB's re-check interval in seconds
-#
-# Additionally to the above, redis also supports the following:
-#
-# socket: 'path/to/redis.sock'
-#
-# or
-# host: 'IP or HOSTNAME' # the host to connect to
-# port: PORT # the port to connect to
-#
-# and
-# pass: 'password' # the redis password to use for AUTH command
-#
-
-# ----------------------------------------------------------------------
-# AUTO-DETECTION JOBS
-# only one of them will run (they have the same name)
-
-socket1:
- name : 'local'
- socket : '/tmp/redis.sock'
- # pass : ''
-
-socket2:
- name : 'local'
- socket : '/var/run/redis/redis.sock'
- # pass : ''
-
-socket3:
- name : 'local'
- socket : '/var/lib/redis/redis.sock'
- # pass : ''
-
-localhost:
- name : 'local'
- host : 'localhost'
- port : 6379
- # pass : ''
-
-localipv4:
- name : 'local'
- host : '127.0.0.1'
- port : 6379
- # pass : ''
-
-localipv6:
- name : 'local'
- host : '::1'
- port : 6379
- # pass : ''
-