summaryrefslogtreecommitdiffstats
path: root/collectors/python.d.plugin/rethinkdbs
diff options
context:
space:
mode:
Diffstat (limited to 'collectors/python.d.plugin/rethinkdbs')
-rw-r--r--collectors/python.d.plugin/rethinkdbs/Makefile.inc13
l---------collectors/python.d.plugin/rethinkdbs/README.md1
-rw-r--r--collectors/python.d.plugin/rethinkdbs/integrations/rethinkdb.md190
-rw-r--r--collectors/python.d.plugin/rethinkdbs/metadata.yaml188
-rw-r--r--collectors/python.d.plugin/rethinkdbs/rethinkdbs.chart.py247
-rw-r--r--collectors/python.d.plugin/rethinkdbs/rethinkdbs.conf76
6 files changed, 0 insertions, 715 deletions
diff --git a/collectors/python.d.plugin/rethinkdbs/Makefile.inc b/collectors/python.d.plugin/rethinkdbs/Makefile.inc
deleted file mode 100644
index dec604464..000000000
--- a/collectors/python.d.plugin/rethinkdbs/Makefile.inc
+++ /dev/null
@@ -1,13 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# THIS IS NOT A COMPLETE Makefile
-# IT IS INCLUDED BY ITS PARENT'S Makefile.am
-# IT IS REQUIRED TO REFERENCE ALL FILES RELATIVE TO THE PARENT
-
-# install these files
-dist_python_DATA += rethinkdbs/rethinkdbs.chart.py
-dist_pythonconfig_DATA += rethinkdbs/rethinkdbs.conf
-
-# do not install these files, but include them in the distribution
-dist_noinst_DATA += rethinkdbs/README.md rethinkdbs/Makefile.inc
-
diff --git a/collectors/python.d.plugin/rethinkdbs/README.md b/collectors/python.d.plugin/rethinkdbs/README.md
deleted file mode 120000
index 78ddcfa18..000000000
--- a/collectors/python.d.plugin/rethinkdbs/README.md
+++ /dev/null
@@ -1 +0,0 @@
-integrations/rethinkdb.md \ No newline at end of file
diff --git a/collectors/python.d.plugin/rethinkdbs/integrations/rethinkdb.md b/collectors/python.d.plugin/rethinkdbs/integrations/rethinkdb.md
deleted file mode 100644
index ab51c0514..000000000
--- a/collectors/python.d.plugin/rethinkdbs/integrations/rethinkdb.md
+++ /dev/null
@@ -1,190 +0,0 @@
-<!--startmeta
-custom_edit_url: "https://github.com/netdata/netdata/edit/master/collectors/python.d.plugin/rethinkdbs/README.md"
-meta_yaml: "https://github.com/netdata/netdata/edit/master/collectors/python.d.plugin/rethinkdbs/metadata.yaml"
-sidebar_label: "RethinkDB"
-learn_status: "Published"
-learn_rel_path: "Data Collection/Databases"
-most_popular: False
-message: "DO NOT EDIT THIS FILE DIRECTLY, IT IS GENERATED BY THE COLLECTOR'S metadata.yaml FILE"
-endmeta-->
-
-# RethinkDB
-
-
-<img src="https://netdata.cloud/img/rethinkdb.png" width="150"/>
-
-
-Plugin: python.d.plugin
-Module: rethinkdbs
-
-<img src="https://img.shields.io/badge/maintained%20by-Netdata-%2300ab44" />
-
-## Overview
-
-This collector monitors metrics about RethinkDB clusters and database servers.
-
-It uses the `rethinkdb` python module to connect to a RethinkDB server instance and gather statistics.
-
-This collector is supported on all platforms.
-
-This collector supports collecting metrics from multiple instances of this integration, including remote instances.
-
-
-### Default Behavior
-
-#### Auto-Detection
-
-When no configuration file is found, the collector tries to connect to 127.0.0.1:28015.
-
-#### Limits
-
-The default configuration for this integration does not impose any limits on data collection.
-
-#### Performance Impact
-
-The default configuration for this integration is not expected to impose a significant performance impact on the system.
-
-
-## Metrics
-
-Metrics grouped by *scope*.
-
-The scope defines the instance that the metric belongs to. An instance is uniquely identified by a set of labels.
-
-
-
-### Per RethinkDB instance
-
-These metrics refer to the entire monitored application.
-
-This scope has no labels.
-
-Metrics:
-
-| Metric | Dimensions | Unit |
-|:------|:----------|:----|
-| rethinkdb.cluster_connected_servers | connected, missing | servers |
-| rethinkdb.cluster_clients_active | active | clients |
-| rethinkdb.cluster_queries | queries | queries/s |
-| rethinkdb.cluster_documents | reads, writes | documents/s |
-
-### Per database server
-
-
-
-This scope has no labels.
-
-Metrics:
-
-| Metric | Dimensions | Unit |
-|:------|:----------|:----|
-| rethinkdb.client_connections | connections | connections |
-| rethinkdb.clients_active | active | clients |
-| rethinkdb.queries | queries | queries/s |
-| rethinkdb.documents | reads, writes | documents/s |
-
-
-
-## Alerts
-
-There are no alerts configured by default for this integration.
-
-
-## Setup
-
-### Prerequisites
-
-#### Required python module
-
-The collector requires the `rethinkdb` python module to be installed.
-
-
-### Configuration
-
-#### File
-
-The configuration file name for this integration is `python.d/rethinkdbs.conf`.
-
-
-You can edit the configuration file using the `edit-config` script from the
-Netdata [config directory](https://github.com/netdata/netdata/blob/master/docs/configure/nodes.md#the-netdata-config-directory).
-
-```bash
-cd /etc/netdata 2>/dev/null || cd /opt/netdata/etc/netdata
-sudo ./edit-config python.d/rethinkdbs.conf
-```
-#### Options
-
-There are 2 sections:
-
-* Global variables
-* One or more JOBS that can define multiple different instances to monitor.
-
-The following options can be defined globally: priority, penalty, autodetection_retry, update_every, but can also be defined per JOB to override the global values.
-
-Additionally, the following collapsed table contains all the options that can be configured inside a JOB definition.
-
-Every configuration JOB starts with a `job_name` value which will appear in the dashboard, unless a `name` parameter is specified.
-
-
-<details><summary>Config options</summary>
-
-| Name | Description | Default | Required |
-|:----|:-----------|:-------|:--------:|
-| update_every | Sets the default data collection frequency. | 5 | no |
-| priority | Controls the order of charts at the netdata dashboard. | 60000 | no |
-| autodetection_retry | Sets the job re-check interval in seconds. | 0 | no |
-| penalty | Indicates whether to apply penalty to update_every in case of failures. | yes | no |
-| name | Job name. This value will overwrite the `job_name` value. JOBS with the same name are mutually exclusive. Only one of them will be allowed running at any time. This allows autodetection to try several alternatives and pick the one that works. | | no |
-| host | Hostname or ip of the RethinkDB server. | localhost | no |
-| port | Port to connect to the RethinkDB server. | 28015 | no |
-| user | The username to use to connect to the RethinkDB server. | admin | no |
-| password | The password to use to connect to the RethinkDB server. | | no |
-| timeout | Set a connect timeout to the RethinkDB server. | 2 | no |
-
-</details>
-
-#### Examples
-
-##### Local RethinkDB server
-
-An example of a configuration for a local RethinkDB server
-
-```yaml
-localhost:
- name: 'local'
- host: '127.0.0.1'
- port: 28015
- user: "user"
- password: "pass"
-
-```
-
-
-## Troubleshooting
-
-### Debug Mode
-
-To troubleshoot issues with the `rethinkdbs` collector, run the `python.d.plugin` with the debug option enabled. The output
-should give you clues as to why the collector isn't working.
-
-- Navigate to the `plugins.d` directory, usually at `/usr/libexec/netdata/plugins.d/`. If that's not the case on
- your system, open `netdata.conf` and look for the `plugins` setting under `[directories]`.
-
- ```bash
- cd /usr/libexec/netdata/plugins.d/
- ```
-
-- Switch to the `netdata` user.
-
- ```bash
- sudo -u netdata -s
- ```
-
-- Run the `python.d.plugin` to debug the collector:
-
- ```bash
- ./python.d.plugin rethinkdbs debug trace
- ```
-
-
diff --git a/collectors/python.d.plugin/rethinkdbs/metadata.yaml b/collectors/python.d.plugin/rethinkdbs/metadata.yaml
deleted file mode 100644
index bbc50eac6..000000000
--- a/collectors/python.d.plugin/rethinkdbs/metadata.yaml
+++ /dev/null
@@ -1,188 +0,0 @@
-plugin_name: python.d.plugin
-modules:
- - meta:
- plugin_name: python.d.plugin
- module_name: rethinkdbs
- monitored_instance:
- name: RethinkDB
- link: 'https://rethinkdb.com/'
- categories:
- - data-collection.database-servers
- icon_filename: 'rethinkdb.png'
- related_resources:
- integrations:
- list: []
- info_provided_to_referring_integrations:
- description: ''
- keywords:
- - rethinkdb
- - database
- - db
- most_popular: false
- overview:
- data_collection:
- metrics_description: 'This collector monitors metrics about RethinkDB clusters and database servers.'
- method_description: 'It uses the `rethinkdb` python module to connect to a RethinkDB server instance and gather statistics.'
- supported_platforms:
- include: []
- exclude: []
- multi_instance: true
- additional_permissions:
- description: ''
- default_behavior:
- auto_detection:
- description: 'When no configuration file is found, the collector tries to connect to 127.0.0.1:28015.'
- limits:
- description: ''
- performance_impact:
- description: ''
- setup:
- prerequisites:
- list:
- - title: 'Required python module'
- description: 'The collector requires the `rethinkdb` python module to be installed.'
- configuration:
- file:
- name: python.d/rethinkdbs.conf
- options:
- description: |
- There are 2 sections:
-
- * Global variables
- * One or more JOBS that can define multiple different instances to monitor.
-
- The following options can be defined globally: priority, penalty, autodetection_retry, update_every, but can also be defined per JOB to override the global values.
-
- Additionally, the following collapsed table contains all the options that can be configured inside a JOB definition.
-
- Every configuration JOB starts with a `job_name` value which will appear in the dashboard, unless a `name` parameter is specified.
- folding:
- title: "Config options"
- enabled: true
- list:
- - name: update_every
- description: Sets the default data collection frequency.
- default_value: 5
- required: false
- - name: priority
- description: Controls the order of charts at the netdata dashboard.
- default_value: 60000
- required: false
- - name: autodetection_retry
- description: Sets the job re-check interval in seconds.
- default_value: 0
- required: false
- - name: penalty
- description: Indicates whether to apply penalty to update_every in case of failures.
- default_value: yes
- required: false
- - name: name
- description: Job name. This value will overwrite the `job_name` value. JOBS with the same name are mutually exclusive. Only one of them will be allowed running at any time. This allows autodetection to try several alternatives and pick the one that works.
- default_value: ''
- required: false
- - name: host
- description: Hostname or ip of the RethinkDB server.
- default_value: 'localhost'
- required: false
- - name: port
- description: Port to connect to the RethinkDB server.
- default_value: '28015'
- required: false
- - name: user
- description: The username to use to connect to the RethinkDB server.
- default_value: 'admin'
- required: false
- - name: password
- description: The password to use to connect to the RethinkDB server.
- default_value: ''
- required: false
- - name: timeout
- description: Set a connect timeout to the RethinkDB server.
- default_value: '2'
- required: false
- examples:
- folding:
- enabled: false
- title: "Config"
- list:
- - name: Local RethinkDB server
- description: An example of a configuration for a local RethinkDB server
- folding:
- enabled: false
- config: |
- localhost:
- name: 'local'
- host: '127.0.0.1'
- port: 28015
- user: "user"
- password: "pass"
- troubleshooting:
- problems:
- list: []
- alerts: []
- metrics:
- folding:
- title: Metrics
- enabled: false
- description: ""
- availability: []
- scopes:
- - name: global
- description: "These metrics refer to the entire monitored application."
- labels: []
- metrics:
- - name: rethinkdb.cluster_connected_servers
- description: Connected Servers
- unit: "servers"
- chart_type: stacked
- dimensions:
- - name: connected
- - name: missing
- - name: rethinkdb.cluster_clients_active
- description: Active Clients
- unit: "clients"
- chart_type: line
- dimensions:
- - name: active
- - name: rethinkdb.cluster_queries
- description: Queries
- unit: "queries/s"
- chart_type: line
- dimensions:
- - name: queries
- - name: rethinkdb.cluster_documents
- description: Documents
- unit: "documents/s"
- chart_type: line
- dimensions:
- - name: reads
- - name: writes
- - name: database server
- description: ""
- labels: []
- metrics:
- - name: rethinkdb.client_connections
- description: Client Connections
- unit: "connections"
- chart_type: line
- dimensions:
- - name: connections
- - name: rethinkdb.clients_active
- description: Active Clients
- unit: "clients"
- chart_type: line
- dimensions:
- - name: active
- - name: rethinkdb.queries
- description: Queries
- unit: "queries/s"
- chart_type: line
- dimensions:
- - name: queries
- - name: rethinkdb.documents
- description: Documents
- unit: "documents/s"
- chart_type: line
- dimensions:
- - name: reads
- - name: writes
diff --git a/collectors/python.d.plugin/rethinkdbs/rethinkdbs.chart.py b/collectors/python.d.plugin/rethinkdbs/rethinkdbs.chart.py
deleted file mode 100644
index e3fbc3632..000000000
--- a/collectors/python.d.plugin/rethinkdbs/rethinkdbs.chart.py
+++ /dev/null
@@ -1,247 +0,0 @@
-# -*- coding: utf-8 -*-
-# Description: rethinkdb netdata python.d module
-# Author: Ilya Mashchenko (ilyam8)
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-try:
- import rethinkdb as rdb
-
- HAS_RETHINKDB = True
-except ImportError:
- HAS_RETHINKDB = False
-
-from bases.FrameworkServices.SimpleService import SimpleService
-
-ORDER = [
- 'cluster_connected_servers',
- 'cluster_clients_active',
- 'cluster_queries',
- 'cluster_documents',
-]
-
-
-def cluster_charts():
- return {
- 'cluster_connected_servers': {
- 'options': [None, 'Connected Servers', 'servers', 'cluster', 'rethinkdb.cluster_connected_servers',
- 'stacked'],
- 'lines': [
- ['cluster_servers_connected', 'connected'],
- ['cluster_servers_missing', 'missing'],
- ]
- },
- 'cluster_clients_active': {
- 'options': [None, 'Active Clients', 'clients', 'cluster', 'rethinkdb.cluster_clients_active',
- 'line'],
- 'lines': [
- ['cluster_clients_active', 'active'],
- ]
- },
- 'cluster_queries': {
- 'options': [None, 'Queries', 'queries/s', 'cluster', 'rethinkdb.cluster_queries', 'line'],
- 'lines': [
- ['cluster_queries_per_sec', 'queries'],
- ]
- },
- 'cluster_documents': {
- 'options': [None, 'Documents', 'documents/s', 'cluster', 'rethinkdb.cluster_documents', 'line'],
- 'lines': [
- ['cluster_read_docs_per_sec', 'reads'],
- ['cluster_written_docs_per_sec', 'writes'],
- ]
- },
- }
-
-
-def server_charts(n):
- o = [
- '{0}_client_connections'.format(n),
- '{0}_clients_active'.format(n),
- '{0}_queries'.format(n),
- '{0}_documents'.format(n),
- ]
- f = 'server {0}'.format(n)
-
- c = {
- o[0]: {
- 'options': [None, 'Client Connections', 'connections', f, 'rethinkdb.client_connections', 'line'],
- 'lines': [
- ['{0}_client_connections'.format(n), 'connections'],
- ]
- },
- o[1]: {
- 'options': [None, 'Active Clients', 'clients', f, 'rethinkdb.clients_active', 'line'],
- 'lines': [
- ['{0}_clients_active'.format(n), 'active'],
- ]
- },
- o[2]: {
- 'options': [None, 'Queries', 'queries/s', f, 'rethinkdb.queries', 'line'],
- 'lines': [
- ['{0}_queries_total'.format(n), 'queries', 'incremental'],
- ]
- },
- o[3]: {
- 'options': [None, 'Documents', 'documents/s', f, 'rethinkdb.documents', 'line'],
- 'lines': [
- ['{0}_read_docs_total'.format(n), 'reads', 'incremental'],
- ['{0}_written_docs_total'.format(n), 'writes', 'incremental'],
- ]
- },
- }
-
- return o, c
-
-
-class Cluster:
- def __init__(self, raw):
- self.raw = raw
-
- def data(self):
- qe = self.raw['query_engine']
-
- return {
- 'cluster_clients_active': qe['clients_active'],
- 'cluster_queries_per_sec': qe['queries_per_sec'],
- 'cluster_read_docs_per_sec': qe['read_docs_per_sec'],
- 'cluster_written_docs_per_sec': qe['written_docs_per_sec'],
- 'cluster_servers_connected': 0,
- 'cluster_servers_missing': 0,
- }
-
-
-class Server:
- def __init__(self, raw):
- self.name = raw['server']
- self.raw = raw
-
- def error(self):
- return self.raw.get('error')
-
- def data(self):
- qe = self.raw['query_engine']
-
- d = {
- 'client_connections': qe['client_connections'],
- 'clients_active': qe['clients_active'],
- 'queries_total': qe['queries_total'],
- 'read_docs_total': qe['read_docs_total'],
- 'written_docs_total': qe['written_docs_total'],
- }
-
- return dict(('{0}_{1}'.format(self.name, k), d[k]) for k in d)
-
-
-# https://pypi.org/project/rethinkdb/2.4.0/
-# rdb.RethinkDB() can be used as rdb drop in replacement.
-# https://github.com/rethinkdb/rethinkdb-python#quickstart
-def get_rethinkdb():
- if hasattr(rdb, 'RethinkDB'):
- return rdb.RethinkDB()
- return rdb
-
-
-class Service(SimpleService):
- def __init__(self, configuration=None, name=None):
- SimpleService.__init__(self, configuration=configuration, name=name)
- self.order = list(ORDER)
- self.definitions = cluster_charts()
- self.host = self.configuration.get('host', '127.0.0.1')
- self.port = self.configuration.get('port', 28015)
- self.user = self.configuration.get('user', 'admin')
- self.password = self.configuration.get('password')
- self.timeout = self.configuration.get('timeout', 2)
- self.rdb = None
- self.conn = None
- self.alive = True
-
- def check(self):
- if not HAS_RETHINKDB:
- self.error('"rethinkdb" module is needed to use rethinkdbs.py')
- return False
-
- self.debug("rethinkdb driver version {0}".format(rdb.__version__))
- self.rdb = get_rethinkdb()
-
- if not self.connect():
- return None
-
- stats = self.get_stats()
-
- if not stats:
- return None
-
- for v in stats[1:]:
- if get_id(v) == 'server':
- o, c = server_charts(v['server'])
- self.order.extend(o)
- self.definitions.update(c)
-
- return True
-
- def get_data(self):
- if not self.is_alive():
- return None
-
- stats = self.get_stats()
-
- if not stats:
- return None
-
- data = dict()
-
- # cluster
- data.update(Cluster(stats[0]).data())
-
- # servers
- for v in stats[1:]:
- if get_id(v) != 'server':
- continue
-
- s = Server(v)
-
- if s.error():
- data['cluster_servers_missing'] += 1
- else:
- data['cluster_servers_connected'] += 1
- data.update(s.data())
-
- return data
-
- def get_stats(self):
- try:
- return list(self.rdb.db('rethinkdb').table('stats').run(self.conn).items)
- except rdb.errors.ReqlError:
- self.alive = False
- return None
-
- def connect(self):
- try:
- self.conn = self.rdb.connect(
- host=self.host,
- port=self.port,
- user=self.user,
- password=self.password,
- timeout=self.timeout,
- )
- self.alive = True
- return True
- except rdb.errors.ReqlError as error:
- self.error('Connection to {0}:{1} failed: {2}'.format(self.host, self.port, error))
- return False
-
- def reconnect(self):
- # The connection is already closed after rdb.errors.ReqlError,
- # so we do not need to call conn.close()
- if self.connect():
- return True
- return False
-
- def is_alive(self):
- if not self.alive:
- return self.reconnect()
- return True
-
-
-def get_id(v):
- return v['id'][0]
diff --git a/collectors/python.d.plugin/rethinkdbs/rethinkdbs.conf b/collectors/python.d.plugin/rethinkdbs/rethinkdbs.conf
deleted file mode 100644
index d671acbb0..000000000
--- a/collectors/python.d.plugin/rethinkdbs/rethinkdbs.conf
+++ /dev/null
@@ -1,76 +0,0 @@
-# netdata python.d.plugin configuration for rethinkdb
-#
-# This file is in YaML format. Generally the format is:
-#
-# name: value
-#
-# There are 2 sections:
-# - global variables
-# - one or more JOBS
-#
-# JOBS allow you to collect values from multiple sources.
-# Each source will have its own set of charts.
-#
-# JOB parameters have to be indented (using spaces only, example below).
-
-# ----------------------------------------------------------------------
-# Global Variables
-# These variables set the defaults for all JOBs, however each JOB
-# may define its own, overriding the defaults.
-
-# update_every sets the default data collection frequency.
-# If unset, the python.d.plugin default is used.
-# update_every: 1
-
-# priority controls the order of charts at the netdata dashboard.
-# Lower numbers move the charts towards the top of the page.
-# If unset, the default for python.d.plugin is used.
-# priority: 60000
-
-# penalty indicates whether to apply penalty to update_every in case of failures.
-# Penalty will increase every 5 failed updates in a row. Maximum penalty is 10 minutes.
-# penalty: yes
-
-# autodetection_retry sets the job re-check interval in seconds.
-# The job is not deleted if check fails.
-# Attempts to start the job are made once every autodetection_retry.
-# This feature is disabled by default.
-# autodetection_retry: 0
-
-# ----------------------------------------------------------------------
-# JOBS (data collection sources)
-#
-# The default JOBS share the same *name*. JOBS with the same name
-# are mutually exclusive. Only one of them will be allowed running at
-# any time. This allows autodetection to try several alternatives and
-# pick the one that works.
-#
-# Any number of jobs is supported.
-#
-# All python.d.plugin JOBS (for all its modules) support a set of
-# predefined parameters. These are:
-#
-# job_name:
-# name: myname # the JOB's name as it will appear at the
-# # dashboard (by default is the job_name)
-# # JOBs sharing a name are mutually exclusive
-# update_every: 1 # the JOB's data collection frequency
-# priority: 60000 # the JOB's order on the dashboard
-# penalty: yes # the JOB's penalty
-# autodetection_retry: 0 # the JOB's re-check interval in seconds
-#
-# Additionally to the above, rethinkdb also supports the following:
-#
-# host: IP or HOSTNAME # default is 'localhost'
-# port: PORT # default is 28015
-# user: USERNAME # default is 'admin'
-# password: PASSWORD # not set by default
-# timeout: TIMEOUT # default is 2
-
-# ----------------------------------------------------------------------
-# AUTO-DETECTION JOBS
-# only one of them will run (they have the same name)
-
-local:
- name: 'local'
- host: 'localhost'