summaryrefslogtreecommitdiffstats
path: root/collectors/python.d.plugin/squid
diff options
context:
space:
mode:
Diffstat (limited to 'collectors/python.d.plugin/squid')
-rw-r--r--collectors/python.d.plugin/squid/Makefile.inc13
l---------collectors/python.d.plugin/squid/README.md1
-rw-r--r--collectors/python.d.plugin/squid/integrations/squid.md199
-rw-r--r--collectors/python.d.plugin/squid/metadata.yaml174
-rw-r--r--collectors/python.d.plugin/squid/squid.chart.py123
-rw-r--r--collectors/python.d.plugin/squid/squid.conf167
6 files changed, 0 insertions, 677 deletions
diff --git a/collectors/python.d.plugin/squid/Makefile.inc b/collectors/python.d.plugin/squid/Makefile.inc
deleted file mode 100644
index 76ecff81e..000000000
--- a/collectors/python.d.plugin/squid/Makefile.inc
+++ /dev/null
@@ -1,13 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# THIS IS NOT A COMPLETE Makefile
-# IT IS INCLUDED BY ITS PARENT'S Makefile.am
-# IT IS REQUIRED TO REFERENCE ALL FILES RELATIVE TO THE PARENT
-
-# install these files
-dist_python_DATA += squid/squid.chart.py
-dist_pythonconfig_DATA += squid/squid.conf
-
-# do not install these files, but include them in the distribution
-dist_noinst_DATA += squid/README.md squid/Makefile.inc
-
diff --git a/collectors/python.d.plugin/squid/README.md b/collectors/python.d.plugin/squid/README.md
deleted file mode 120000
index c4e5a03d7..000000000
--- a/collectors/python.d.plugin/squid/README.md
+++ /dev/null
@@ -1 +0,0 @@
-integrations/squid.md \ No newline at end of file
diff --git a/collectors/python.d.plugin/squid/integrations/squid.md b/collectors/python.d.plugin/squid/integrations/squid.md
deleted file mode 100644
index 6599826da..000000000
--- a/collectors/python.d.plugin/squid/integrations/squid.md
+++ /dev/null
@@ -1,199 +0,0 @@
-<!--startmeta
-custom_edit_url: "https://github.com/netdata/netdata/edit/master/collectors/python.d.plugin/squid/README.md"
-meta_yaml: "https://github.com/netdata/netdata/edit/master/collectors/python.d.plugin/squid/metadata.yaml"
-sidebar_label: "Squid"
-learn_status: "Published"
-learn_rel_path: "Data Collection/Web Servers and Web Proxies"
-most_popular: False
-message: "DO NOT EDIT THIS FILE DIRECTLY, IT IS GENERATED BY THE COLLECTOR'S metadata.yaml FILE"
-endmeta-->
-
-# Squid
-
-
-<img src="https://netdata.cloud/img/squid.png" width="150"/>
-
-
-Plugin: python.d.plugin
-Module: squid
-
-<img src="https://img.shields.io/badge/maintained%20by-Netdata-%2300ab44" />
-
-## Overview
-
-This collector monitors statistics about the Squid Clients and Servers, like bandwidth and requests.
-
-
-It collects metrics from the endpoint where Squid exposes its `counters` data.
-
-This collector is supported on all platforms.
-
-This collector supports collecting metrics from multiple instances of this integration, including remote instances.
-
-
-### Default Behavior
-
-#### Auto-Detection
-
-By default, this collector will try to autodetect where Squid presents its `counters` data, by trying various configurations.
-
-#### Limits
-
-The default configuration for this integration does not impose any limits on data collection.
-
-#### Performance Impact
-
-The default configuration for this integration is not expected to impose a significant performance impact on the system.
-
-
-## Metrics
-
-Metrics grouped by *scope*.
-
-The scope defines the instance that the metric belongs to. An instance is uniquely identified by a set of labels.
-
-
-
-### Per Squid instance
-
-These metrics refer to each monitored Squid instance.
-
-This scope has no labels.
-
-Metrics:
-
-| Metric | Dimensions | Unit |
-|:------|:----------|:----|
-| squid.clients_net | in, out, hits | kilobits/s |
-| squid.clients_requests | requests, hits, errors | requests/s |
-| squid.servers_net | in, out | kilobits/s |
-| squid.servers_requests | requests, errors | requests/s |
-
-
-
-## Alerts
-
-There are no alerts configured by default for this integration.
-
-
-## Setup
-
-### Prerequisites
-
-#### Configure Squid's Cache Manager
-
-Take a look at [Squid's official documentation](https://wiki.squid-cache.org/Features/CacheManager/Index#controlling-access-to-the-cache-manager) on how to configure access to the Cache Manager.
-
-
-
-### Configuration
-
-#### File
-
-The configuration file name for this integration is `python.d/squid.conf`.
-
-
-You can edit the configuration file using the `edit-config` script from the
-Netdata [config directory](https://github.com/netdata/netdata/blob/master/docs/configure/nodes.md#the-netdata-config-directory).
-
-```bash
-cd /etc/netdata 2>/dev/null || cd /opt/netdata/etc/netdata
-sudo ./edit-config python.d/squid.conf
-```
-#### Options
-
-There are 2 sections:
-
-* Global variables
-* One or more JOBS that can define multiple different instances to monitor.
-
-The following options can be defined globally: priority, penalty, autodetection_retry, update_every, but can also be defined per JOB to override the global values.
-
-Additionally, the following collapsed table contains all the options that can be configured inside a JOB definition.
-
-Every configuration JOB starts with a `job_name` value which will appear in the dashboard, unless a `name` parameter is specified.
-
-
-<details><summary>Config options</summary>
-
-| Name | Description | Default | Required |
-|:----|:-----------|:-------|:--------:|
-| update_every | Sets the default data collection frequency. | 1 | no |
-| priority | Controls the order of charts at the netdata dashboard. | 60000 | no |
-| autodetection_retry | Sets the job re-check interval in seconds. | 0 | no |
-| penalty | Indicates whether to apply penalty to update_every in case of failures. | yes | no |
-| name | Job name. This value will overwrite the `job_name` value. JOBS with the same name are mutually exclusive. Only one of them will be allowed running at any time. This allows autodetection to try several alternatives and pick the one that works. | local | no |
-| host | The host to connect to. | | yes |
-| port | The port to connect to. | | yes |
-| request | The URL to request from Squid. | | yes |
-
-</details>
-
-#### Examples
-
-##### Basic
-
-A basic configuration example.
-
-```yaml
-example_job_name:
- name: 'local'
- host: 'localhost'
- port: 3128
- request: 'cache_object://localhost:3128/counters'
-
-```
-##### Multi-instance
-
-> **Note**: When you define multiple jobs, their names must be unique.
-
-Collecting metrics from local and remote instances.
-
-
-<details><summary>Config</summary>
-
-```yaml
-local_job:
- name: 'local'
- host: '127.0.0.1'
- port: 3128
- request: 'cache_object://127.0.0.1:3128/counters'
-
-remote_job:
- name: 'remote'
- host: '192.0.2.1'
- port: 3128
- request: 'cache_object://192.0.2.1:3128/counters'
-
-```
-</details>
-
-
-
-## Troubleshooting
-
-### Debug Mode
-
-To troubleshoot issues with the `squid` collector, run the `python.d.plugin` with the debug option enabled. The output
-should give you clues as to why the collector isn't working.
-
-- Navigate to the `plugins.d` directory, usually at `/usr/libexec/netdata/plugins.d/`. If that's not the case on
- your system, open `netdata.conf` and look for the `plugins` setting under `[directories]`.
-
- ```bash
- cd /usr/libexec/netdata/plugins.d/
- ```
-
-- Switch to the `netdata` user.
-
- ```bash
- sudo -u netdata -s
- ```
-
-- Run the `python.d.plugin` to debug the collector:
-
- ```bash
- ./python.d.plugin squid debug trace
- ```
-
-
diff --git a/collectors/python.d.plugin/squid/metadata.yaml b/collectors/python.d.plugin/squid/metadata.yaml
deleted file mode 100644
index d0c5b3ecc..000000000
--- a/collectors/python.d.plugin/squid/metadata.yaml
+++ /dev/null
@@ -1,174 +0,0 @@
-plugin_name: python.d.plugin
-modules:
- - meta:
- plugin_name: python.d.plugin
- module_name: squid
- monitored_instance:
- name: Squid
- link: "http://www.squid-cache.org/"
- categories:
- - data-collection.web-servers-and-web-proxies
- icon_filename: "squid.png"
- related_resources:
- integrations:
- list: []
- info_provided_to_referring_integrations:
- description: ""
- keywords:
- - squid
- - web delivery
- - squid caching proxy
- most_popular: false
- overview:
- data_collection:
- metrics_description: |
- This collector monitors statistics about the Squid Clients and Servers, like bandwidth and requests.
- method_description: "It collects metrics from the endpoint where Squid exposes its `counters` data."
- supported_platforms:
- include: []
- exclude: []
- multi_instance: true
- additional_permissions:
- description: ""
- default_behavior:
- auto_detection:
- description: "By default, this collector will try to autodetect where Squid presents its `counters` data, by trying various configurations."
- limits:
- description: ""
- performance_impact:
- description: ""
- setup:
- prerequisites:
- list:
- - title: Configure Squid's Cache Manager
- description: |
- Take a look at [Squid's official documentation](https://wiki.squid-cache.org/Features/CacheManager/Index#controlling-access-to-the-cache-manager) on how to configure access to the Cache Manager.
- configuration:
- file:
- name: "python.d/squid.conf"
- options:
- description: |
- There are 2 sections:
-
- * Global variables
- * One or more JOBS that can define multiple different instances to monitor.
-
- The following options can be defined globally: priority, penalty, autodetection_retry, update_every, but can also be defined per JOB to override the global values.
-
- Additionally, the following collapsed table contains all the options that can be configured inside a JOB definition.
-
- Every configuration JOB starts with a `job_name` value which will appear in the dashboard, unless a `name` parameter is specified.
- folding:
- title: "Config options"
- enabled: true
- list:
- - name: update_every
- description: Sets the default data collection frequency.
- default_value: 1
- required: false
- - name: priority
- description: Controls the order of charts at the netdata dashboard.
- default_value: 60000
- required: false
- - name: autodetection_retry
- description: Sets the job re-check interval in seconds.
- default_value: 0
- required: false
- - name: penalty
- description: Indicates whether to apply penalty to update_every in case of failures.
- default_value: yes
- required: false
- - name: name
- description: >
- Job name. This value will overwrite the `job_name` value. JOBS with the same name are mutually exclusive. Only one of them will be allowed running at any time. This allows autodetection to try several alternatives and pick the one that works.
- default_value: "local"
- required: false
- - name: host
- description: The host to connect to.
- default_value: ""
- required: true
- - name: port
- description: The port to connect to.
- default_value: ""
- required: true
- - name: request
- description: The URL to request from Squid.
- default_value: ""
- required: true
- examples:
- folding:
- enabled: true
- title: "Config"
- list:
- - name: Basic
- description: A basic configuration example.
- folding:
- enabled: false
- config: |
- example_job_name:
- name: 'local'
- host: 'localhost'
- port: 3128
- request: 'cache_object://localhost:3128/counters'
- - name: Multi-instance
- description: |
- > **Note**: When you define multiple jobs, their names must be unique.
-
- Collecting metrics from local and remote instances.
- config: |
- local_job:
- name: 'local'
- host: '127.0.0.1'
- port: 3128
- request: 'cache_object://127.0.0.1:3128/counters'
-
- remote_job:
- name: 'remote'
- host: '192.0.2.1'
- port: 3128
- request: 'cache_object://192.0.2.1:3128/counters'
- troubleshooting:
- problems:
- list: []
- alerts: []
- metrics:
- folding:
- title: Metrics
- enabled: false
- description: ""
- availability: []
- scopes:
- - name: Squid instance
- description: "These metrics refer to each monitored Squid instance."
- labels: []
- metrics:
- - name: squid.clients_net
- description: Squid Client Bandwidth
- unit: "kilobits/s"
- chart_type: area
- dimensions:
- - name: in
- - name: out
- - name: hits
- - name: squid.clients_requests
- description: Squid Client Requests
- unit: "requests/s"
- chart_type: line
- dimensions:
- - name: requests
- - name: hits
- - name: errors
- - name: squid.servers_net
- description: Squid Server Bandwidth
- unit: "kilobits/s"
- chart_type: area
- dimensions:
- - name: in
- - name: out
- - name: squid.servers_requests
- description: Squid Server Requests
- unit: "requests/s"
- chart_type: line
- dimensions:
- - name: requests
- - name: errors
diff --git a/collectors/python.d.plugin/squid/squid.chart.py b/collectors/python.d.plugin/squid/squid.chart.py
deleted file mode 100644
index bcae2d892..000000000
--- a/collectors/python.d.plugin/squid/squid.chart.py
+++ /dev/null
@@ -1,123 +0,0 @@
-# -*- coding: utf-8 -*-
-# Description: squid netdata python.d module
-# Author: Pawel Krupa (paulfantom)
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-from bases.FrameworkServices.SocketService import SocketService
-
-ORDER = [
- 'clients_net',
- 'clients_requests',
- 'servers_net',
- 'servers_requests',
-]
-
-CHARTS = {
- 'clients_net': {
- 'options': [None, 'Squid Client Bandwidth', 'kilobits/s', 'clients', 'squid.clients_net', 'area'],
- 'lines': [
- ['client_http_kbytes_in', 'in', 'incremental', 8, 1],
- ['client_http_kbytes_out', 'out', 'incremental', -8, 1],
- ['client_http_hit_kbytes_out', 'hits', 'incremental', -8, 1]
- ]
- },
- 'clients_requests': {
- 'options': [None, 'Squid Client Requests', 'requests/s', 'clients', 'squid.clients_requests', 'line'],
- 'lines': [
- ['client_http_requests', 'requests', 'incremental'],
- ['client_http_hits', 'hits', 'incremental'],
- ['client_http_errors', 'errors', 'incremental', -1, 1]
- ]
- },
- 'servers_net': {
- 'options': [None, 'Squid Server Bandwidth', 'kilobits/s', 'servers', 'squid.servers_net', 'area'],
- 'lines': [
- ['server_all_kbytes_in', 'in', 'incremental', 8, 1],
- ['server_all_kbytes_out', 'out', 'incremental', -8, 1]
- ]
- },
- 'servers_requests': {
- 'options': [None, 'Squid Server Requests', 'requests/s', 'servers', 'squid.servers_requests', 'line'],
- 'lines': [
- ['server_all_requests', 'requests', 'incremental'],
- ['server_all_errors', 'errors', 'incremental', -1, 1]
- ]
- }
-}
-
-
-class Service(SocketService):
- def __init__(self, configuration=None, name=None):
- SocketService.__init__(self, configuration=configuration, name=name)
- self._keep_alive = True
- self.request = ''
- self.host = 'localhost'
- self.port = 3128
- self.order = ORDER
- self.definitions = CHARTS
-
- def _get_data(self):
- """
- Get data via http request
- :return: dict
- """
- response = self._get_raw_data()
-
- data = dict()
- try:
- raw = ''
- for tmp in response.split('\r\n'):
- if tmp.startswith('sample_time'):
- raw = tmp
- break
-
- if raw.startswith('<'):
- self.error('invalid data received')
- return None
-
- for row in raw.split('\n'):
- if row.startswith(('client', 'server.all')):
- tmp = row.split('=')
- data[tmp[0].replace('.', '_').strip(' ')] = int(tmp[1])
-
- except (ValueError, AttributeError, TypeError):
- self.error('invalid data received')
- return None
-
- if not data:
- self.error('no data received')
- return None
- return data
-
- def _check_raw_data(self, data):
- header = data[:1024].lower()
-
- if 'connection: keep-alive' in header:
- self._keep_alive = True
- else:
- self._keep_alive = False
-
- if data[-7:] == '\r\n0\r\n\r\n' and 'transfer-encoding: chunked' in header: # HTTP/1.1 response
- self.debug('received full response from squid')
- return True
-
- self.debug('waiting more data from squid')
- return False
-
- def check(self):
- """
- Parse essential configuration, autodetect squid configuration (if needed), and check if data is available
- :return: boolean
- """
- self._parse_config()
- # format request
- req = self.request.decode()
- if not req.startswith('GET'):
- req = 'GET ' + req
- if not req.endswith(' HTTP/1.1\r\n\r\n'):
- req += ' HTTP/1.1\r\n\r\n'
- self.request = req.encode()
- if self._get_data() is not None:
- return True
- else:
- return False
diff --git a/collectors/python.d.plugin/squid/squid.conf b/collectors/python.d.plugin/squid/squid.conf
deleted file mode 100644
index b90a52c0c..000000000
--- a/collectors/python.d.plugin/squid/squid.conf
+++ /dev/null
@@ -1,167 +0,0 @@
-# netdata python.d.plugin configuration for squid
-#
-# This file is in YaML format. Generally the format is:
-#
-# name: value
-#
-# There are 2 sections:
-# - global variables
-# - one or more JOBS
-#
-# JOBS allow you to collect values from multiple sources.
-# Each source will have its own set of charts.
-#
-# JOB parameters have to be indented (using spaces only, example below).
-
-# ----------------------------------------------------------------------
-# Global Variables
-# These variables set the defaults for all JOBs, however each JOB
-# may define its own, overriding the defaults.
-
-# update_every sets the default data collection frequency.
-# If unset, the python.d.plugin default is used.
-# update_every: 1
-
-# priority controls the order of charts at the netdata dashboard.
-# Lower numbers move the charts towards the top of the page.
-# If unset, the default for python.d.plugin is used.
-# priority: 60000
-
-# penalty indicates whether to apply penalty to update_every in case of failures.
-# Penalty will increase every 5 failed updates in a row. Maximum penalty is 10 minutes.
-# penalty: yes
-
-# autodetection_retry sets the job re-check interval in seconds.
-# The job is not deleted if check fails.
-# Attempts to start the job are made once every autodetection_retry.
-# This feature is disabled by default.
-# autodetection_retry: 0
-
-# ----------------------------------------------------------------------
-# JOBS (data collection sources)
-#
-# The default JOBS share the same *name*. JOBS with the same name
-# are mutually exclusive. Only one of them will be allowed running at
-# any time. This allows autodetection to try several alternatives and
-# pick the one that works.
-#
-# Any number of jobs is supported.
-#
-# All python.d.plugin JOBS (for all its modules) support a set of
-# predefined parameters. These are:
-#
-# job_name:
-# name: myname # the JOB's name as it will appear at the
-# # dashboard (by default is the job_name)
-# # JOBs sharing a name are mutually exclusive
-# update_every: 1 # the JOB's data collection frequency
-# priority: 60000 # the JOB's order on the dashboard
-# penalty: yes # the JOB's penalty
-# autodetection_retry: 0 # the JOB's re-check interval in seconds
-#
-# Additionally to the above, squid also supports the following:
-#
-# host : 'IP or HOSTNAME' # the host to connect to
-# port : PORT # the port to connect to
-# request: 'URL' # the URL to request from squid
-#
-
-# ----------------------------------------------------------------------
-# SQUID CONFIGURATION
-#
-# See:
-# http://wiki.squid-cache.org/Features/CacheManager
-#
-# In short, add to your squid configuration these:
-#
-# http_access allow localhost manager
-# http_access deny manager
-#
-# To remotely monitor a squid:
-#
-# acl managerAdmin src 192.0.2.1
-# http_access allow localhost manager
-# http_access allow managerAdmin manager
-# http_access deny manager
-#
-
-# ----------------------------------------------------------------------
-# AUTO-DETECTION JOBS
-# only one of them will run (they have the same name)
-
-tcp3128old:
- name : 'local'
- host : 'localhost'
- port : 3128
- request : 'cache_object://localhost:3128/counters'
-
-tcp8080old:
- name : 'local'
- host : 'localhost'
- port : 8080
- request : 'cache_object://localhost:3128/counters'
-
-tcp3128new:
- name : 'local'
- host : 'localhost'
- port : 3128
- request : '/squid-internal-mgr/counters'
-
-tcp8080new:
- name : 'local'
- host : 'localhost'
- port : 8080
- request : '/squid-internal-mgr/counters'
-
-# IPv4
-
-tcp3128oldipv4:
- name : 'local'
- host : '127.0.0.1'
- port : 3128
- request : 'cache_object://127.0.0.1:3128/counters'
-
-tcp8080oldipv4:
- name : 'local'
- host : '127.0.0.1'
- port : 8080
- request : 'cache_object://127.0.0.1:3128/counters'
-
-tcp3128newipv4:
- name : 'local'
- host : '127.0.0.1'
- port : 3128
- request : '/squid-internal-mgr/counters'
-
-tcp8080newipv4:
- name : 'local'
- host : '127.0.0.1'
- port : 8080
- request : '/squid-internal-mgr/counters'
-
-# IPv6
-
-tcp3128oldipv6:
- name : 'local'
- host : '::1'
- port : 3128
- request : 'cache_object://[::1]:3128/counters'
-
-tcp8080oldipv6:
- name : 'local'
- host : '::1'
- port : 8080
- request : 'cache_object://[::1]:3128/counters'
-
-tcp3128newipv6:
- name : 'local'
- host : '::1'
- port : 3128
- request : '/squid-internal-mgr/counters'
-
-tcp8080newipv6:
- name : 'local'
- host : '::1'
- port : 8080
- request : '/squid-internal-mgr/counters'
-