summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac148
1 files changed, 54 insertions, 94 deletions
diff --git a/configure.ac b/configure.ac
index 7af950aa..40cd3869 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,6 +42,7 @@ AC_PROG_CXX
AC_PROG_INSTALL
PKG_PROG_PKG_CONFIG
AC_USE_SYSTEM_EXTENSIONS
+AC_PROG_RANLIB
# -----------------------------------------------------------------------------
# configurable options
@@ -218,14 +219,6 @@ AC_ARG_ENABLE(
[ enable_cloud="detect" ]
)
-AC_ARG_WITH(
- [new-cloud-protocol],
- [AS_HELP_STRING([--with-new-cloud-protocol],
- [Requires New Cloud Protocol support to be built])],
- [new_cloud_protocol="$withval"],
- [new_cloud_protocol="detect"]
-)
-
if test "${enable_cloud}" = "no"; then
AC_DEFINE([DISABLE_CLOUD], [1], [disable netdata cloud functionality])
fi
@@ -363,6 +356,8 @@ else
fi
AC_MSG_RESULT([${with_math}])
+AC_CHECK_FUNCS([isfinite])
+AC_CHECK_FUNCS([finite])
# -----------------------------------------------------------------------------
# libuv multi-platform support library with a focus on asynchronous I/O
@@ -474,45 +469,22 @@ OPTIONAL_JSONC_LIBS="${JSONC_LIBS}"
test "${enable_dbengine}" = "yes" -a -z "${LZ4_LIBS}" && \
AC_MSG_ERROR([liblz4 required but not found. Try installing 'liblz4-dev' or 'lz4-devel'.])
-
-AC_ARG_WITH([bundled-libJudy],
- [AS_HELP_STRING([--with-bundled-libJudy],[Use the bundled version of Judy library (default is system-library)])],
- [
- AC_MSG_CHECKING(for libJudy in $withval)
- if test -f "externaldeps/libJudy/libJudy.a" -a -f "externaldeps/libJudy/Judy.h"; then
- LIBS_BACKUP="${LIBS}"
- LIBS="externaldeps/libJudy/libJudy.a"
- AC_LINK_IFELSE([AC_LANG_SOURCE([[#include "externaldeps/libJudy/Judy.h"
- int main (int argc, char **argv) {
- Pvoid_t PJLArray = (Pvoid_t) NULL;
- Word_t * PValue;
- Word_t Index;
- JLI(PValue, PJLArray, Index);
- }]])],
- [HAVE_libJudy_a="yes"],
- [HAVE_libJudy_a="no"])
- LIBS="${LIBS_BACKUP}"
- JUDY_LIBS="\$(abs_top_srcdir)/externaldeps/libJudy/libJudy.a"
- JUDY_CFLAGS="-I \$(abs_top_srcdir)/externaldeps/libJudy"
- AC_MSG_RESULT([$HAVE_libJudy_a])
- else
- libjudy_dir=""
- HAVE_libJudy_a="no"
- AC_MSG_RESULT([$HAVE_libJudy_a])
- fi
- ],
- [HAVE_libJudy_a="no"])
-
-if test "${HAVE_libJudy_a}" = "no"; then
- AC_CHECK_LIB(
- [Judy],
- [JudyLIns],
- [JUDY_LIBS="-lJudy"]
- )
+AC_C_BIGENDIAN([],
+ [LIBJUDY_CFLAGS="-DJU_LITTLE_ENDIAN"],
+ [AC_MSG_ERROR([Could not find out system endiannnes])])
+
+AC_CHECK_SIZEOF(void *)
+if test "$ac_cv_sizeof_void_p" = 8; then
+ AC_MSG_RESULT(Detected 64-bit Build Environment)
+ LIBJUDY_CFLAGS="$LIBJUDY_CFLAGS -DJU_64BIT"
+else
+ AC_MSG_RESULT(Detected 32-bit Build Environment)
+ LIBJUDY_CFLAGS="$LIBJUDY_CFLAGS -UJU_64BIT"
fi
-test "${enable_dbengine}" = "yes" -a -z "${JUDY_LIBS}" && \
- AC_MSG_ERROR([libJudy required but not found. Try installing 'libjudy-dev' or 'Judy-devel'.])
+AC_SUBST([LIBJUDY_CFLAGS])
+
+JUDY_CFLAGS="-I \$(abs_top_srcdir)/libnetdata/libjudy/src"
test "${enable_https}" = "yes" -a -z "${SSL_LIBS}" && \
AC_MSG_ERROR([OpenSSL required for HTTPS but not found. Try installing 'libssl-dev' or 'openssl-devel'.])
@@ -521,13 +493,12 @@ test "${enable_dbengine}" = "yes" -a -z "${SSL_LIBS}" && \
AC_MSG_ERROR([OpenSSL required for DBENGINE but not found. Try installing 'libssl-dev' or 'openssl-devel'.])
AC_MSG_CHECKING([if netdata dbengine should be used])
-if test "${enable_dbengine}" != "no" -a "${UV_LIBS}" -a "${LZ4_LIBS}" -a "${JUDY_LIBS}" -a "${SSL_LIBS}"; then
+if test "${enable_dbengine}" != "no" -a "${UV_LIBS}" -a "${LZ4_LIBS}" -a "${SSL_LIBS}"; then
enable_dbengine="yes"
AC_DEFINE([ENABLE_DBENGINE], [1], [netdata dbengine usability])
OPTIONAL_LZ4_CFLAGS="${LZ4_CFLAGS}"
OPTIONAL_LZ4_LIBS="${LZ4_LIBS}"
OPTIONAL_JUDY_CFLAGS="${JUDY_CFLAGS}"
- OPTIONAL_JUDY_LIBS="${JUDY_LIBS}"
OPTIONAL_SSL_CFLAGS="${SSL_CFLAGS}"
OPTIONAL_SSL_LIBS="${SSL_LIBS}"
else
@@ -766,16 +737,16 @@ AC_MSG_CHECKING([if Cloud functionality should be enabled])
AC_MSG_RESULT([${enable_cloud}])
if test "$enable_cloud" != "no"; then
- AC_MSG_NOTICE([Checking if ACLK Next Generation can be built])
+ AC_MSG_NOTICE([Checking if ACLK can be built])
can_enable_ng="yes"
- AC_MSG_CHECKING([if git submodules present for ACLK Next Generation])
+ AC_MSG_CHECKING([if git submodules present for ACLK])
if test -f "mqtt_websockets/src/mqtt_wss_client.c"; then
AC_MSG_RESULT([yes])
else
AC_MSG_RESULT([no])
can_enable_ng="no"
fi
- AC_MSG_CHECKING([if SSL available for ACLK Next Generation])
+ AC_MSG_CHECKING([if SSL available for ACLK])
if test -n "${SSL_LIBS}"; then
AC_MSG_RESULT([yes])
OPTIONAL_SSL_CFLAGS="${SSL_CFLAGS}"
@@ -783,7 +754,7 @@ if test "$enable_cloud" != "no"; then
else
AC_MSG_RESULT([no])
fi
- AC_MSG_CHECKING([if JSON-C available for ACLK Next Generation])
+ AC_MSG_CHECKING([if JSON-C available for ACLK])
if test "$enable_jsonc" != "yes"; then
AC_MSG_RESULT([no])
can_enable_ng="no"
@@ -791,6 +762,28 @@ if test "$enable_cloud" != "no"; then
AC_MSG_RESULT([yes])
fi
+ AC_MSG_CHECKING([if protobuf available for ACLK New Cloud Protocol])
+ if test "${have_libprotobuf}" != "yes"; then
+ AC_MSG_RESULT([no])
+ can_enable_ng="no"
+ else
+ AC_MSG_RESULT([yes])
+ fi
+ AC_MSG_CHECKING([if protoc available for ACLK New Cloud Protocol])
+ if test "${have_protoc}" != "yes"; then
+ AC_MSG_RESULT([no])
+ can_enable_ng="no"
+ else
+ AC_MSG_RESULT([yes])
+ fi
+ AC_MSG_CHECKING([if C++ compiler available for ACLK New Cloud Protocol])
+ if test "${have_CXX_compiler}" != "yes"; then
+ AC_MSG_RESULT([no])
+ can_enable_ng="no"
+ else
+ AC_MSG_RESULT([yes])
+ fi
+
AC_MSG_CHECKING([ACLK Next Generation can be built])
AC_MSG_RESULT([${can_enable_ng}])
if test "$can_enable_ng" = "no" -a "$enable_cloud" = "yes"; then
@@ -799,46 +792,10 @@ if test "$enable_cloud" != "no"; then
if test "$can_enable_ng" = "yes"; then
enable_aclk="yes"
AC_DEFINE([ENABLE_ACLK], [1], [netdata ACLK])
- OPTIONAL_ACLK_CFLAGS="-I \$(abs_top_srcdir)/mqtt_websockets/src/include -I \$(abs_top_srcdir)/mqtt_websockets/c-rbuf/include -I \$(abs_top_srcdir)/mqtt_websockets/MQTT-C/include"
- fi
-
- if test "$new_cloud_protocol" != "no"; then
- can_build_new_cloud_protocol="yes"
- AC_MSG_CHECKING([if protobuf available for New Cloud Protocol])
- if test "${have_libprotobuf}" != "yes"; then
- AC_MSG_RESULT([no])
- can_build_new_cloud_protocol="no"
- else
- AC_MSG_RESULT([yes])
- fi
- AC_MSG_CHECKING([if protoc available for New Cloud Protocol])
- if test "${have_protoc}" != "yes"; then
- AC_MSG_RESULT([no])
- can_build_new_cloud_protocol="no"
- else
- AC_MSG_RESULT([yes])
- fi
- AC_MSG_CHECKING([if C++ compiler available for New Cloud Protocol])
- if test "${have_CXX_compiler}" != "yes"; then
- AC_MSG_RESULT([no])
- can_build_new_cloud_protocol="no"
- else
- AC_MSG_RESULT([yes])
- fi
-
- AC_MSG_CHECKING([ACLK Next Generation can support New Cloud protocol])
- AC_MSG_RESULT([${can_build_new_cloud_protocol}])
- if test "$new_cloud_protocol" = "yes" -a "$can_build_new_cloud_protocol" != "yes"; then
- AC_MSG_ERROR([Requested new cloud protocol support but it can't be build])
- fi
- if test "$can_build_new_cloud_protocol" = "yes"; then
- new_cloud_protocol="yes"
- AC_DEFINE([ENABLE_NEW_CLOUD_PROTOCOL], [1], [New protobuf based Netdata Cloud Protocol Support])
- OPTIONAL_ACLK_CFLAGS="${OPTIONAL_ACLK_CFLAGS} -I \$(abs_top_srcdir)/aclk/aclk-schemas"
- OPTIONAL_PROTOBUF_CFLAGS="${PROTOBUF_CFLAGS}"
- CXX11FLAG="-std=c++11"
- OPTIONAL_PROTOBUF_LIBS="${PROTOBUF_LIBS}"
- fi
+ OPTIONAL_ACLK_CFLAGS="-I \$(abs_top_srcdir)/mqtt_websockets/src/include -I \$(abs_top_srcdir)/mqtt_websockets/c-rbuf/include -I \$(abs_top_srcdir)/mqtt_websockets/MQTT-C/include -I \$(abs_top_srcdir)/aclk/aclk-schemas"
+ OPTIONAL_PROTOBUF_CFLAGS="${PROTOBUF_CFLAGS}"
+ CXX11FLAG="-std=c++11"
+ OPTIONAL_PROTOBUF_LIBS="${PROTOBUF_LIBS}"
fi
fi
@@ -849,7 +806,6 @@ fi
AC_SUBST([enable_cloud])
AC_SUBST([enable_aclk])
AM_CONDITIONAL([ENABLE_ACLK], [test "${enable_aclk}" = "yes"])
-AM_CONDITIONAL([ENABLE_NEW_CLOUD_PROTOCOL], [test "${can_build_new_cloud_protocol}" = "yes"])
# -----------------------------------------------------------------------------
# apps.plugin
@@ -1621,8 +1577,6 @@ AC_SUBST([OPTIONAL_MATH_CFLAGS])
AC_SUBST([OPTIONAL_MATH_LIBS])
AC_SUBST([OPTIONAL_UV_LIBS])
AC_SUBST([OPTIONAL_LZ4_LIBS])
-AC_SUBST([OPTIONAL_JUDY_CFLAGS])
-AC_SUBST([OPTIONAL_JUDY_LIBS])
AC_SUBST([OPTIONAL_SSL_LIBS])
AC_SUBST([OPTIONAL_JSONC_LIBS])
AC_SUBST([OPTIONAL_NFACCT_CFLAGS])
@@ -1727,6 +1681,8 @@ AC_CONFIG_FILES([
database/Makefile
database/engine/Makefile
database/engine/metadata_log/Makefile
+ database/ram/Makefile
+ database/sqlite/Makefile
diagrams/Makefile
exporting/Makefile
exporting/graphite/Makefile
@@ -1745,6 +1701,7 @@ AC_CONFIG_FILES([
libnetdata/Makefile
libnetdata/tests/Makefile
libnetdata/adaptive_resortable_list/Makefile
+ libnetdata/arrayalloc/Makefile
libnetdata/avl/Makefile
libnetdata/buffer/Makefile
libnetdata/clocks/Makefile
@@ -1785,14 +1742,17 @@ AC_CONFIG_FILES([
web/api/formatters/value/Makefile
web/api/queries/Makefile
web/api/queries/average/Makefile
+ web/api/queries/countif/Makefile
web/api/queries/des/Makefile
web/api/queries/incremental_sum/Makefile
web/api/queries/max/Makefile
web/api/queries/median/Makefile
web/api/queries/min/Makefile
+ web/api/queries/percentile/Makefile
web/api/queries/ses/Makefile
web/api/queries/stddev/Makefile
web/api/queries/sum/Makefile
+ web/api/queries/trimmed_mean/Makefile
web/api/health/Makefile
web/gui/Makefile
web/gui/dashboard/Makefile