summaryrefslogtreecommitdiffstats
path: root/contrib/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/debian/rules')
-rwxr-xr-xcontrib/debian/rules20
1 files changed, 11 insertions, 9 deletions
diff --git a/contrib/debian/rules b/contrib/debian/rules
index f36e995fc..cbf4a8375 100755
--- a/contrib/debian/rules
+++ b/contrib/debian/rules
@@ -23,26 +23,20 @@ HAVE_EBPF = 1
endif
%:
- # For jessie and beyond
- #
- dh $@ --with autoreconf,systemd
-
- # For wheezy or other non-systemd distributions use the following. You
- # should also see contrib/README.md which gives details of updates to
- # make to debian/control.
- #
- #dh $@ --with autoreconf
+ dh $@
override_dh_installinit:
echo "SystemD Version: $(SYSTEMD_VERSION)"
echo "Using SystemD Unit: $(SYSTEMD_UNIT)"
cp -v $(SYSTEMD_UNIT) debian/netdata.service
+ dh_systemd_enable
dh_installinit
override_dh_auto_configure:
if [ $(HAVE_EBPF) -eq 1 ]; then \
packaging/bundle-libbpf.sh . ${TOP}/usr/libexec/netdata/plugins.d; \
+ packaging/bundle-ebpf-co-re.sh . ${TOP}/usr/libexec/netdata/plugins.d; \
fi
autoreconf -ivf
dh_auto_configure -- --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libdir=/usr/lib \
@@ -75,6 +69,10 @@ override_dh_install:
mkdir -p "$(TOP)/var/cache/netdata"
mkdir -p "$(TOP)/var/run/netdata"
+ # Copy the updater script
+ #
+ cp -v packaging/installer/netdata-updater.sh $(TOP)/usr/libexec/netdata/netdata-updater.sh
+
# Move files that local user shouldn't be editing to /usr/share/netdata
#
mkdir -p "$(TOP)/usr/share/netdata/www"
@@ -108,6 +106,10 @@ override_dh_installdocs:
override_dh_fixperms:
dh_fixperms
+ # Updater script should be executable
+ #
+ chmod 0755 $(TOP)/usr/libexec/netdata/netdata-updater.sh
+
# apps.plugin should only be runnable by the netdata user. It will be
# given extra capabilities in the postinst script.
#