summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules82
1 files changed, 3 insertions, 79 deletions
diff --git a/debian/rules b/debian/rules
index cd01812b3..314b00c81 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,8 +2,6 @@
TOP = $(CURDIR)/debian/netdata
-PACKAGES := $(shell dh_listpackages -a)
-
VERSION := $(shell dpkg-parsechangelog -SVersion)
VERSION_MAJOR := $(word 1, $(subst ., ,$(VERSION)))
VERSION_MINOR := $(word 2, $(subst ., ,$(VERSION)))
@@ -26,8 +24,6 @@ export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
dh ${@} --with apache2
execute_before_dh_autoreconf:
- mkdir -p web/server/h2o/libh2o mqtt_websockets
-
rm -f debian/configure.ac.orig
cp configure.ac debian/configure.ac.orig
@@ -44,54 +40,18 @@ execute_before_dh_autoreconf_clean:
mv debian/configure.ac.orig configure.ac; \
fi
-execute_after_dh_auto_clean:
- rm -rf build-core
- rm -rf build-core-no-sse debian/tmp-core-no-sse
-
- for FILE in $$(find tests -type f -name "*.in"); \
- do \
- rm -f $$(dirname $${FILE})/$$(basename $${FILE} .in); \
- done
-
override_dh_auto_configure:
- mkdir -p build-core
- dh_auto_configure -B build-core -- --libdir=/usr/lib --libexecdir=/usr/lib \
+ dh_auto_configure -- --libdir=/usr/lib --libexecdir=/usr/lib \
--disable-cloud \
- --enable-x86-sse \
- --disable-exporting-prometheus-remote-write \
- --enable-dbengine \
- --enable-https \
- --enable-plugin-cups \
- --enable-plugin-nfacct \
- --with-math
- cp -a mqtt_websockets system tests build-core
- cp -a web/gui/src build-core/web/gui
-
-ifeq (netdata-core-no-sse,$(findstring netdata-core-no-sse,$(PACKAGES)))
- mkdir -p build-core-no-sse
- dh_auto_configure -B build-core-no-sse -- --libdir=/usr/lib --libexecdir=/usr/lib \
- --disable-cloud \
- --disable-x86-sse \
--disable-exporting-prometheus-remote-write \
--enable-dbengine \
--enable-https \
--enable-plugin-cups \
--enable-plugin-nfacct \
+ --enable-x86-sse \
--with-math
- cp -a mqtt_websockets system tests build-core-no-sse
- cp -a web/gui/src build-core-no-sse/web/gui
-endif
-
-override_dh_auto_build:
- dh_auto_build -B build-core
-
-ifeq (netdata-core-no-sse,$(findstring netdata-core-no-sse,$(PACKAGES)))
- dh_auto_build -B build-core-no-sse
-endif
-
-override_dh_auto_install:
- dh_auto_install -B build-core -- DESTDIR=$(CURDIR)/debian/tmp
+execute_after_dh_auto_install:
# Removing unused files
rm -f debian/tmp/etc/netdata/.install-type
rm -f debian/tmp/etc/netdata/netdata-updater.conf
@@ -101,10 +61,6 @@ override_dh_auto_install:
# Building without aws kinesis backend (needs aws sdk)
rm -f debian/tmp/usr/lib/netdata/conf.d/aws_kinesis.conf
-ifeq (netdata-core-no-sse,$(findstring netdata-core-no-sse,$(PACKAGES)))
- dh_auto_install -B build-core-no-sse -- DESTDIR=$(CURDIR)/debian/tmp-core-no-sse
-endif
-
override_dh_install-arch:
find debian/tmp -name .keep -delete
@@ -120,25 +76,7 @@ override_dh_install-arch:
$(TOP)-core/usr/lib/netdata/plugins.d; \
done
-ifeq (netdata-core-no-sse,$(findstring netdata-core-no-sse,$(PACKAGES)))
- find debian/tmp-core-no-sse -name .keep -delete
- dh_install -p netdata-core-no-sse --sourcedir=debian/tmp-core-no-sse
-
- mkdir -p $(TOP)-core-no-sse/etc/netdata
- cp debian/local/netdata/netdata.conf $(TOP)-core-no-sse/etc/netdata
- touch $(TOP)-core-no-sse/etc/netdata/.opt-out-from-anonymous-statistics
-
- mkdir -p $(TOP)-core-no-sse/usr/lib/netdata/plugins.d
- for plugin in cgroup-network apps.plugin nfacct.plugin perf.plugin slabinfo.plugin; \
- do \
- cp debian/tmp-core-no-sse/usr/lib/netdata/plugins.d/$${plugin} \
- $(TOP)-core-no-sse/usr/lib/netdata/plugins.d; \
- done
-
- dh_install -a --remaining-packages
-else
dh_install -a
-endif
override_dh_install-indep:
find debian/tmp -name .keep -delete
@@ -163,16 +101,6 @@ override_dh_install-indep:
# Setting package version (update check)
echo $(VERSION) > $(TOP)-web/usr/share/netdata/web/version.txt
-override_dh_installsystemd:
- dh_installsystemd -p netdata-core --name=netdata
- dh_installsystemd -p netdata-core-no-sse --name=netdata
- dh_installsystemd --remaining-packages
-
-override_dh_installlogrotate:
- dh_installlogrotate -p netdata-core --name=netdata
- dh_installlogrotate -p netdata-core-no-sse --name=netdata
- dh_installlogrotate --remaining-packages
-
override_dh_fixperms-arch:
dh_fixperms -a
@@ -180,10 +108,6 @@ override_dh_fixperms-arch:
# given extra capabilities in the postinst script.
chmod 0754 $(TOP)-core/usr/lib/netdata/plugins.d/apps.plugin
chmod 4754 $(TOP)-core/usr/lib/netdata/plugins.d/perf.plugin
-ifeq (netdata-core-no-sse,$(findstring netdata-core-no-sse,$(PACKAGES)))
- chmod 0754 $(TOP)-core-no-sse/usr/lib/netdata/plugins.d/apps.plugin
- chmod 4754 $(TOP)-core-no-sse/usr/lib/netdata/plugins.d/perf.plugin
-endif
override_dh_fixperms-indep:
dh_fixperms -i