summaryrefslogtreecommitdiffstats
path: root/health/notifications/email
diff options
context:
space:
mode:
Diffstat (limited to 'health/notifications/email')
-rw-r--r--health/notifications/email/Makefile.inc12
-rw-r--r--health/notifications/email/README.md114
-rw-r--r--health/notifications/email/metadata.yaml73
3 files changed, 0 insertions, 199 deletions
diff --git a/health/notifications/email/Makefile.inc b/health/notifications/email/Makefile.inc
deleted file mode 100644
index 95dc7cf22..000000000
--- a/health/notifications/email/Makefile.inc
+++ /dev/null
@@ -1,12 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# THIS IS NOT A COMPLETE Makefile
-# IT IS INCLUDED BY ITS PARENT'S Makefile.am
-# IT IS REQUIRED TO REFERENCE ALL FILES RELATIVE TO THE PARENT
-
-# install these files
-dist_noinst_DATA += \
- email/README.md \
- email/Makefile.inc \
- $(NULL)
-
diff --git a/health/notifications/email/README.md b/health/notifications/email/README.md
deleted file mode 100644
index 3470ba440..000000000
--- a/health/notifications/email/README.md
+++ /dev/null
@@ -1,114 +0,0 @@
-<!--startmeta
-custom_edit_url: "https://github.com/netdata/netdata/edit/master/health/notifications/email/README.md"
-meta_yaml: "https://github.com/netdata/netdata/edit/master/health/notifications/email/metadata.yaml"
-sidebar_label: "Email"
-learn_status: "Published"
-learn_rel_path: "Alerting/Notifications/Agent Dispatched Notifications"
-message: "DO NOT EDIT THIS FILE DIRECTLY, IT IS GENERATED BY THE NOTIFICATION'S metadata.yaml FILE"
-endmeta-->
-
-# Email
-
-
-<img src="https://netdata.cloud/img/email.png" width="150"/>
-
-
-Send notifications via Email using Netdata's Agent alert notification feature, which supports dozens of endpoints, user roles, and more.
-
-
-
-<img src="https://img.shields.io/badge/maintained%20by-Netdata-%2300ab44" />
-
-## Setup
-
-### Prerequisites
-
-####
-
-- A working sendmail command is required for email alerts to work. Almost all MTAs provide a sendmail interface. Netdata sends all emails as user netdata, so make sure your sendmail works for local users.
-- Access to the terminal where Netdata Agent is running
-
-
-
-### Configuration
-
-#### File
-
-The configuration file name for this integration is `health_alarm_notify.conf`.
-
-
-You can edit the configuration file using the `edit-config` script from the
-Netdata [config directory](https://github.com/netdata/netdata/blob/master/docs/configure/nodes.md#the-netdata-config-directory).
-
-```bash
-cd /etc/netdata 2>/dev/null || cd /opt/netdata/etc/netdata
-sudo ./edit-config health_alarm_notify.conf
-```
-#### Options
-
-The following options can be defined for this notification
-
-<details><summary>Config Options</summary>
-
-| Name | Description | Default | Required |
-|:----|:-----------|:-------|:--------:|
-| EMAIL_SENDER | You can change `EMAIL_SENDER` to the email address sending the notifications. | netdata | no |
-| SEND_EMAIL | Set `SEND_EMAIL` to YES | YES | yes |
-| DEFAULT_RECIPIENT_EMAIL | Set `DEFAULT_RECIPIENT_EMAIL` to the email address you want the email to be sent by default. You can define multiple email addresses like this: `alarms@example.com` `systems@example.com`. | root | yes |
-
-##### DEFAULT_RECIPIENT_EMAIL
-
-All roles will default to this variable if left unconfigured.
-The `DEFAULT_RECIPIENT_CUSTOM` can be edited in the following entries at the bottom of the same file:
-```conf
-role_recipients_email[sysadmin]="systems@example.com"
-role_recipients_email[domainadmin]="domains@example.com"
-role_recipients_email[dba]="databases@example.com systems@example.com"
-role_recipients_email[webmaster]="marketing@example.com development@example.com"
-role_recipients_email[proxyadmin]="proxy-admin@example.com"
-role_recipients_email[sitemgr]="sites@example.com"
-```
-
-
-</details>
-
-#### Examples
-
-##### Basic Configuration
-
-
-
-```yaml
-#------------------------------------------------------------------------------
-# email global notification options
-
-EMAIL_SENDER="example@domain.com"
-SEND_EMAIL="YES"
-DEFAULT_RECIPIENT_EMAIL="recipient@example.com"
-
-```
-
-
-## Troubleshooting
-
-### Test Notification
-
-You can run the following command by hand, to test alerts configuration:
-
-```bash
-# become user netdata
-sudo su -s /bin/bash netdata
-
-# enable debugging info on the console
-export NETDATA_ALARM_NOTIFY_DEBUG=1
-
-# send test alarms to sysadmin
-/usr/libexec/netdata/plugins.d/alarm-notify.sh test
-
-# send test alarms to any role
-/usr/libexec/netdata/plugins.d/alarm-notify.sh test "ROLE"
-```
-
-Note that this will test _all_ alert mechanisms for the selected role.
-
-
diff --git a/health/notifications/email/metadata.yaml b/health/notifications/email/metadata.yaml
deleted file mode 100644
index f0d4a62a9..000000000
--- a/health/notifications/email/metadata.yaml
+++ /dev/null
@@ -1,73 +0,0 @@
-# yamllint disable rule:line-length
----
-- id: 'notify-email'
- meta:
- name: 'Email'
- link: ''
- categories:
- - notify.agent
- icon_filename: 'email.png'
- keywords:
- - email
- overview:
- notification_description: |
- Send notifications via Email using Netdata's Agent alert notification feature, which supports dozens of endpoints, user roles, and more.
- notification_limitations: ''
- setup:
- prerequisites:
- list:
- - title: ''
- description: |
- - A working sendmail command is required for email alerts to work. Almost all MTAs provide a sendmail interface. Netdata sends all emails as user netdata, so make sure your sendmail works for local users.
- - Access to the terminal where Netdata Agent is running
- configuration:
- file:
- name: 'health_alarm_notify.conf'
- options:
- description: 'The following options can be defined for this notification'
- folding:
- title: 'Config Options'
- enabled: true
- list:
- - name: 'EMAIL_SENDER'
- default_value: 'netdata'
- description: "You can change `EMAIL_SENDER` to the email address sending the notifications."
- required: false
- - name: 'SEND_EMAIL'
- default_value: 'YES'
- description: "Set `SEND_EMAIL` to YES"
- required: true
- - name: 'DEFAULT_RECIPIENT_EMAIL'
- default_value: 'root'
- description: "Set `DEFAULT_RECIPIENT_EMAIL` to the email address you want the email to be sent by default. You can define multiple email addresses like this: `alarms@example.com` `systems@example.com`."
- required: true
- detailed_description: |
- All roles will default to this variable if left unconfigured.
- The `DEFAULT_RECIPIENT_CUSTOM` can be edited in the following entries at the bottom of the same file:
- ```conf
- role_recipients_email[sysadmin]="systems@example.com"
- role_recipients_email[domainadmin]="domains@example.com"
- role_recipients_email[dba]="databases@example.com systems@example.com"
- role_recipients_email[webmaster]="marketing@example.com development@example.com"
- role_recipients_email[proxyadmin]="proxy-admin@example.com"
- role_recipients_email[sitemgr]="sites@example.com"
- ```
- examples:
- folding:
- enabled: true
- title: ''
- list:
- - name: 'Basic Configuration'
- folding:
- enabled: false
- description: ''
- config: |
- #------------------------------------------------------------------------------
- # email global notification options
-
- EMAIL_SENDER="example@domain.com"
- SEND_EMAIL="YES"
- DEFAULT_RECIPIENT_EMAIL="recipient@example.com"
- troubleshooting:
- problems:
- list: []