summaryrefslogtreecommitdiffstats
path: root/health/notifications/flock
diff options
context:
space:
mode:
Diffstat (limited to 'health/notifications/flock')
-rw-r--r--health/notifications/flock/Makefile.inc12
-rw-r--r--health/notifications/flock/README.md113
-rw-r--r--health/notifications/flock/metadata.yaml72
3 files changed, 0 insertions, 197 deletions
diff --git a/health/notifications/flock/Makefile.inc b/health/notifications/flock/Makefile.inc
deleted file mode 100644
index 5bde1619e..000000000
--- a/health/notifications/flock/Makefile.inc
+++ /dev/null
@@ -1,12 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# THIS IS NOT A COMPLETE Makefile
-# IT IS INCLUDED BY ITS PARENT'S Makefile.am
-# IT IS REQUIRED TO REFERENCE ALL FILES RELATIVE TO THE PARENT
-
-# install these files
-dist_noinst_DATA += \
- flock/README.md \
- flock/Makefile.inc \
- $(NULL)
-
diff --git a/health/notifications/flock/README.md b/health/notifications/flock/README.md
deleted file mode 100644
index ab846203c..000000000
--- a/health/notifications/flock/README.md
+++ /dev/null
@@ -1,113 +0,0 @@
-<!--startmeta
-custom_edit_url: "https://github.com/netdata/netdata/edit/master/health/notifications/flock/README.md"
-meta_yaml: "https://github.com/netdata/netdata/edit/master/health/notifications/flock/metadata.yaml"
-sidebar_label: "Flock"
-learn_status: "Published"
-learn_rel_path: "Alerting/Notifications/Agent Dispatched Notifications"
-message: "DO NOT EDIT THIS FILE DIRECTLY, IT IS GENERATED BY THE NOTIFICATION'S metadata.yaml FILE"
-endmeta-->
-
-# Flock
-
-
-<img src="https://netdata.cloud/img/flock.png" width="150"/>
-
-
-Send notifications to Flock using Netdata's Agent alert notification feature, which supports dozens of endpoints, user roles, and more.
-
-
-
-<img src="https://img.shields.io/badge/maintained%20by-Netdata-%2300ab44" />
-
-## Setup
-
-### Prerequisites
-
-####
-
-- The incoming webhook URL as given by flock.com. You can use the same on all your Netdata servers (or you can have multiple if you like). Read more about flock webhooks and how to get one [here](https://admin.flock.com/webhooks).
-- Access to the terminal where Netdata Agent is running
-
-
-
-### Configuration
-
-#### File
-
-The configuration file name for this integration is `health_alarm_notify.conf`.
-
-
-You can edit the configuration file using the `edit-config` script from the
-Netdata [config directory](https://github.com/netdata/netdata/blob/master/docs/configure/nodes.md#the-netdata-config-directory).
-
-```bash
-cd /etc/netdata 2>/dev/null || cd /opt/netdata/etc/netdata
-sudo ./edit-config health_alarm_notify.conf
-```
-#### Options
-
-The following options can be defined for this notification
-
-<details><summary>Config Options</summary>
-
-| Name | Description | Default | Required |
-|:----|:-----------|:-------|:--------:|
-| SEND_FLOCK | Set `SEND_FLOCK` to YES | YES | yes |
-| FLOCK_WEBHOOK_URL | set `FLOCK_WEBHOOK_URL` to your webhook URL. | | yes |
-| DEFAULT_RECIPIENT_FLOCK | Set `DEFAULT_RECIPIENT_FLOCK` to the Flock channel you want the alert notifications to be sent to. All roles will default to this variable if left unconfigured. | | yes |
-
-##### DEFAULT_RECIPIENT_FLOCK
-
-You can have different channels per role, by editing DEFAULT_RECIPIENT_FLOCK with the channel you want, in the following entries at the bottom of the same file:
-```conf
-role_recipients_flock[sysadmin]="systems"
-role_recipients_flock[domainadmin]="domains"
-role_recipients_flock[dba]="databases systems"
-role_recipients_flock[webmaster]="marketing development"
-role_recipients_flock[proxyadmin]="proxy-admin"
-role_recipients_flock[sitemgr]="sites"
-```
-
-
-</details>
-
-#### Examples
-
-##### Basic Configuration
-
-
-
-```yaml
-#------------------------------------------------------------------------------
-# flock (flock.com) global notification options
-
-SEND_FLOCK="YES"
-FLOCK_WEBHOOK_URL="https://api.flock.com/hooks/sendMessage/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX"
-DEFAULT_RECIPIENT_FLOCK="alarms"
-
-```
-
-
-## Troubleshooting
-
-### Test Notification
-
-You can run the following command by hand, to test alerts configuration:
-
-```bash
-# become user netdata
-sudo su -s /bin/bash netdata
-
-# enable debugging info on the console
-export NETDATA_ALARM_NOTIFY_DEBUG=1
-
-# send test alarms to sysadmin
-/usr/libexec/netdata/plugins.d/alarm-notify.sh test
-
-# send test alarms to any role
-/usr/libexec/netdata/plugins.d/alarm-notify.sh test "ROLE"
-```
-
-Note that this will test _all_ alert mechanisms for the selected role.
-
-
diff --git a/health/notifications/flock/metadata.yaml b/health/notifications/flock/metadata.yaml
deleted file mode 100644
index 62e7f4995..000000000
--- a/health/notifications/flock/metadata.yaml
+++ /dev/null
@@ -1,72 +0,0 @@
-# yamllint disable rule:line-length
----
-- id: 'notify-flock'
- meta:
- name: 'Flock'
- link: 'https://support.flock.com/'
- categories:
- - notify.agent
- icon_filename: 'flock.png'
- keywords:
- - Flock
- overview:
- notification_description: |
- Send notifications to Flock using Netdata's Agent alert notification feature, which supports dozens of endpoints, user roles, and more.
- notification_limitations: ''
- setup:
- prerequisites:
- list:
- - title: ''
- description: |
- - The incoming webhook URL as given by flock.com. You can use the same on all your Netdata servers (or you can have multiple if you like). Read more about flock webhooks and how to get one [here](https://admin.flock.com/webhooks).
- - Access to the terminal where Netdata Agent is running
- configuration:
- file:
- name: 'health_alarm_notify.conf'
- options:
- description: 'The following options can be defined for this notification'
- folding:
- title: 'Config Options'
- enabled: true
- list:
- - name: 'SEND_FLOCK'
- default_value: 'YES'
- description: "Set `SEND_FLOCK` to YES"
- required: true
- - name: 'FLOCK_WEBHOOK_URL'
- default_value: ''
- description: "set `FLOCK_WEBHOOK_URL` to your webhook URL."
- required: true
- - name: 'DEFAULT_RECIPIENT_FLOCK'
- default_value: ''
- description: "Set `DEFAULT_RECIPIENT_FLOCK` to the Flock channel you want the alert notifications to be sent to. All roles will default to this variable if left unconfigured."
- required: true
- detailed_description: |
- You can have different channels per role, by editing DEFAULT_RECIPIENT_FLOCK with the channel you want, in the following entries at the bottom of the same file:
- ```conf
- role_recipients_flock[sysadmin]="systems"
- role_recipients_flock[domainadmin]="domains"
- role_recipients_flock[dba]="databases systems"
- role_recipients_flock[webmaster]="marketing development"
- role_recipients_flock[proxyadmin]="proxy-admin"
- role_recipients_flock[sitemgr]="sites"
- ```
- examples:
- folding:
- enabled: true
- title: ''
- list:
- - name: 'Basic Configuration'
- folding:
- enabled: false
- description: ''
- config: |
- #------------------------------------------------------------------------------
- # flock (flock.com) global notification options
-
- SEND_FLOCK="YES"
- FLOCK_WEBHOOK_URL="https://api.flock.com/hooks/sendMessage/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX"
- DEFAULT_RECIPIENT_FLOCK="alarms"
- troubleshooting:
- problems:
- list: []