summaryrefslogtreecommitdiffstats
path: root/health/notifications/irc
diff options
context:
space:
mode:
Diffstat (limited to 'health/notifications/irc')
-rw-r--r--health/notifications/irc/Makefile.inc12
-rw-r--r--health/notifications/irc/README.md132
-rw-r--r--health/notifications/irc/metadata.yaml100
3 files changed, 0 insertions, 244 deletions
diff --git a/health/notifications/irc/Makefile.inc b/health/notifications/irc/Makefile.inc
deleted file mode 100644
index 1a68f657f..000000000
--- a/health/notifications/irc/Makefile.inc
+++ /dev/null
@@ -1,12 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# THIS IS NOT A COMPLETE Makefile
-# IT IS INCLUDED BY ITS PARENT'S Makefile.am
-# IT IS REQUIRED TO REFERENCE ALL FILES RELATIVE TO THE PARENT
-
-# install these files
-dist_noinst_DATA += \
- irc/README.md \
- irc/Makefile.inc \
- $(NULL)
-
diff --git a/health/notifications/irc/README.md b/health/notifications/irc/README.md
deleted file mode 100644
index 60faa7b21..000000000
--- a/health/notifications/irc/README.md
+++ /dev/null
@@ -1,132 +0,0 @@
-<!--startmeta
-custom_edit_url: "https://github.com/netdata/netdata/edit/master/health/notifications/irc/README.md"
-meta_yaml: "https://github.com/netdata/netdata/edit/master/health/notifications/irc/metadata.yaml"
-sidebar_label: "IRC"
-learn_status: "Published"
-learn_rel_path: "Alerting/Notifications/Agent Dispatched Notifications"
-message: "DO NOT EDIT THIS FILE DIRECTLY, IT IS GENERATED BY THE NOTIFICATION'S metadata.yaml FILE"
-endmeta-->
-
-# IRC
-
-
-<img src="https://netdata.cloud/img/irc.png" width="150"/>
-
-
-Send notifications to IRC using Netdata's Agent alert notification feature, which supports dozens of endpoints, user roles, and more.
-
-
-
-<img src="https://img.shields.io/badge/maintained%20by-Netdata-%2300ab44" />
-
-## Setup
-
-### Prerequisites
-
-####
-
-- The `nc` utility. You can set the path to it, or Netdata will search for it in your system `$PATH`.
-- Access to the terminal where Netdata Agent is running
-
-
-
-### Configuration
-
-#### File
-
-The configuration file name for this integration is `health_alarm_notify.conf`.
-
-
-You can edit the configuration file using the `edit-config` script from the
-Netdata [config directory](https://github.com/netdata/netdata/blob/master/docs/configure/nodes.md#the-netdata-config-directory).
-
-```bash
-cd /etc/netdata 2>/dev/null || cd /opt/netdata/etc/netdata
-sudo ./edit-config health_alarm_notify.conf
-```
-#### Options
-
-The following options can be defined for this notification
-
-<details><summary>Config Options</summary>
-
-| Name | Description | Default | Required |
-|:----|:-----------|:-------|:--------:|
-| nc path | Set the path for nc, otherwise Netdata will search for it in your system $PATH | | yes |
-| SEND_IRC | Set `SEND_IRC` YES. | YES | yes |
-| IRC_NETWORK | Set `IRC_NETWORK` to the IRC network which your preferred channels belong to. | | yes |
-| IRC_PORT | Set `IRC_PORT` to the IRC port to which a connection will occur. | | no |
-| IRC_NICKNAME | Set `IRC_NICKNAME` to the IRC nickname which is required to send the notification. It must not be an already registered name as the connection's MODE is defined as a guest. | | yes |
-| IRC_REALNAME | Set `IRC_REALNAME` to the IRC realname which is required in order to make the connection. | | yes |
-| DEFAULT_RECIPIENT_IRC | You can have different channels per role, by editing `DEFAULT_RECIPIENT_IRC` with the channel you want | | yes |
-
-##### nc path
-
-```sh
-#------------------------------------------------------------------------------
-# external commands
-#
-# The full path of the nc command.
-# If empty, the system $PATH will be searched for it.
-# If not found, irc notifications will be silently disabled.
-nc="/usr/bin/nc"
-```
-
-
-##### DEFAULT_RECIPIENT_IRC
-
-The `DEFAULT_RECIPIENT_IRC` can be edited in the following entries at the bottom of the same file:
-```conf
-role_recipients_irc[sysadmin]="#systems"
-role_recipients_irc[domainadmin]="#domains"
-role_recipients_irc[dba]="#databases #systems"
-role_recipients_irc[webmaster]="#marketing #development"
-role_recipients_irc[proxyadmin]="#proxy-admin"
-role_recipients_irc[sitemgr]="#sites"
-```
-
-
-</details>
-
-#### Examples
-
-##### Basic Configuration
-
-
-
-```yaml
-#------------------------------------------------------------------------------
-# irc notification options
-#
-SEND_IRC="YES"
-DEFAULT_RECIPIENT_IRC="#system-alarms"
-IRC_NETWORK="irc.freenode.net"
-IRC_NICKNAME="netdata-alarm-user"
-IRC_REALNAME="netdata-user"
-
-```
-
-
-## Troubleshooting
-
-### Test Notification
-
-You can run the following command by hand, to test alerts configuration:
-
-```bash
-# become user netdata
-sudo su -s /bin/bash netdata
-
-# enable debugging info on the console
-export NETDATA_ALARM_NOTIFY_DEBUG=1
-
-# send test alarms to sysadmin
-/usr/libexec/netdata/plugins.d/alarm-notify.sh test
-
-# send test alarms to any role
-/usr/libexec/netdata/plugins.d/alarm-notify.sh test "ROLE"
-```
-
-Note that this will test _all_ alert mechanisms for the selected role.
-
-
diff --git a/health/notifications/irc/metadata.yaml b/health/notifications/irc/metadata.yaml
deleted file mode 100644
index aa2593f91..000000000
--- a/health/notifications/irc/metadata.yaml
+++ /dev/null
@@ -1,100 +0,0 @@
-# yamllint disable rule:line-length
----
-- id: 'notify-irc'
- meta:
- name: 'IRC'
- link: ''
- categories:
- - notify.agent
- icon_filename: 'irc.png'
- keywords:
- - IRC
- overview:
- notification_description: |
- Send notifications to IRC using Netdata's Agent alert notification feature, which supports dozens of endpoints, user roles, and more.
- notification_limitations: ''
- setup:
- prerequisites:
- list:
- - title: ''
- description: |
- - The `nc` utility. You can set the path to it, or Netdata will search for it in your system `$PATH`.
- - Access to the terminal where Netdata Agent is running
- configuration:
- file:
- name: 'health_alarm_notify.conf'
- options:
- description: 'The following options can be defined for this notification'
- folding:
- title: 'Config Options'
- enabled: true
- list:
- - name: 'nc path'
- default_value: ''
- description: "Set the path for nc, otherwise Netdata will search for it in your system $PATH"
- required: true
- detailed_description: |
- ```sh
- #------------------------------------------------------------------------------
- # external commands
- #
- # The full path of the nc command.
- # If empty, the system $PATH will be searched for it.
- # If not found, irc notifications will be silently disabled.
- nc="/usr/bin/nc"
- ```
- - name: 'SEND_IRC'
- default_value: 'YES'
- description: "Set `SEND_IRC` YES."
- required: true
- - name: 'IRC_NETWORK'
- default_value: ''
- description: "Set `IRC_NETWORK` to the IRC network which your preferred channels belong to."
- required: true
- - name: 'IRC_PORT '
- default_value: ''
- description: "Set `IRC_PORT` to the IRC port to which a connection will occur."
- required: false
- - name: 'IRC_NICKNAME'
- default_value: ''
- description: "Set `IRC_NICKNAME` to the IRC nickname which is required to send the notification. It must not be an already registered name as the connection's MODE is defined as a guest."
- required: true
- - name: 'IRC_REALNAME'
- default_value: ''
- description: "Set `IRC_REALNAME` to the IRC realname which is required in order to make the connection."
- required: true
- - name: 'DEFAULT_RECIPIENT_IRC'
- default_value: ''
- description: "You can have different channels per role, by editing `DEFAULT_RECIPIENT_IRC` with the channel you want"
- required: true
- detailed_description: |
- The `DEFAULT_RECIPIENT_IRC` can be edited in the following entries at the bottom of the same file:
- ```conf
- role_recipients_irc[sysadmin]="#systems"
- role_recipients_irc[domainadmin]="#domains"
- role_recipients_irc[dba]="#databases #systems"
- role_recipients_irc[webmaster]="#marketing #development"
- role_recipients_irc[proxyadmin]="#proxy-admin"
- role_recipients_irc[sitemgr]="#sites"
- ```
- examples:
- folding:
- enabled: true
- title: ''
- list:
- - name: 'Basic Configuration'
- folding:
- enabled: false
- description: ''
- config: |
- #------------------------------------------------------------------------------
- # irc notification options
- #
- SEND_IRC="YES"
- DEFAULT_RECIPIENT_IRC="#system-alarms"
- IRC_NETWORK="irc.freenode.net"
- IRC_NICKNAME="netdata-alarm-user"
- IRC_REALNAME="netdata-user"
- troubleshooting:
- problems:
- list: []