summaryrefslogtreecommitdiffstats
path: root/health/notifications/pushbullet
diff options
context:
space:
mode:
Diffstat (limited to 'health/notifications/pushbullet')
-rw-r--r--health/notifications/pushbullet/Makefile.inc12
-rw-r--r--health/notifications/pushbullet/README.md117
-rw-r--r--health/notifications/pushbullet/metadata.yaml76
3 files changed, 0 insertions, 205 deletions
diff --git a/health/notifications/pushbullet/Makefile.inc b/health/notifications/pushbullet/Makefile.inc
deleted file mode 100644
index d3a9459e5..000000000
--- a/health/notifications/pushbullet/Makefile.inc
+++ /dev/null
@@ -1,12 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# THIS IS NOT A COMPLETE Makefile
-# IT IS INCLUDED BY ITS PARENT'S Makefile.am
-# IT IS REQUIRED TO REFERENCE ALL FILES RELATIVE TO THE PARENT
-
-# install these files
-dist_noinst_DATA += \
- pushbullet/README.md \
- pushbullet/Makefile.inc \
- $(NULL)
-
diff --git a/health/notifications/pushbullet/README.md b/health/notifications/pushbullet/README.md
deleted file mode 100644
index 748325712..000000000
--- a/health/notifications/pushbullet/README.md
+++ /dev/null
@@ -1,117 +0,0 @@
-<!--startmeta
-custom_edit_url: "https://github.com/netdata/netdata/edit/master/health/notifications/pushbullet/README.md"
-meta_yaml: "https://github.com/netdata/netdata/edit/master/health/notifications/pushbullet/metadata.yaml"
-sidebar_label: "Pushbullet"
-learn_status: "Published"
-learn_rel_path: "Alerting/Notifications/Agent Dispatched Notifications"
-message: "DO NOT EDIT THIS FILE DIRECTLY, IT IS GENERATED BY THE NOTIFICATION'S metadata.yaml FILE"
-endmeta-->
-
-# Pushbullet
-
-
-<img src="https://netdata.cloud/img/pushbullet.png" width="150"/>
-
-
-Send notifications to Pushbullet using Netdata's Agent alert notification feature, which supports dozens of endpoints, user roles, and more.
-
-
-
-<img src="https://img.shields.io/badge/maintained%20by-Netdata-%2300ab44" />
-
-## Setup
-
-### Prerequisites
-
-####
-
-- A Pushbullet access token that can be created in your [account settings](https://www.pushbullet.com/#settings/account).
-- Access to the terminal where Netdata Agent is running
-
-
-
-### Configuration
-
-#### File
-
-The configuration file name for this integration is `health_alarm_notify.conf`.
-
-
-You can edit the configuration file using the `edit-config` script from the
-Netdata [config directory](https://github.com/netdata/netdata/blob/master/docs/configure/nodes.md#the-netdata-config-directory).
-
-```bash
-cd /etc/netdata 2>/dev/null || cd /opt/netdata/etc/netdata
-sudo ./edit-config health_alarm_notify.conf
-```
-#### Options
-
-The following options can be defined for this notification
-
-<details><summary>Config Options</summary>
-
-| Name | Description | Default | Required |
-|:----|:-----------|:-------|:--------:|
-| Send_PUSHBULLET | Set `Send_PUSHBULLET` to YES | YES | yes |
-| PUSHBULLET_ACCESS_TOKEN | set `PUSHBULLET_ACCESS_TOKEN` to the access token you generated. | | yes |
-| DEFAULT_RECIPIENT_PUSHBULLET | Set `DEFAULT_RECIPIENT_PUSHBULLET` to the email (e.g. `example@domain.com`) or the channel tag (e.g. `#channel`) you want the alert notifications to be sent to. | | yes |
-
-##### DEFAULT_RECIPIENT_PUSHBULLET
-
-You can define multiple entries like this: user1@email.com user2@email.com.
-
-All roles will default to this variable if left unconfigured.
-
-The `DEFAULT_RECIPIENT_PUSHBULLET` can be edited in the following entries at the bottom of the same file:
-```conf
-role_recipients_pushbullet[sysadmin]="user1@email.com"
-role_recipients_pushbullet[domainadmin]="user2@mail.com"
-role_recipients_pushbullet[dba]="#channel1"
-role_recipients_pushbullet[webmaster]="#channel2"
-role_recipients_pushbullet[proxyadmin]="user3@mail.com"
-role_recipients_pushbullet[sitemgr]="user4@mail.com"
-```
-
-
-</details>
-
-#### Examples
-
-##### Basic Configuration
-
-
-
-```yaml
-#------------------------------------------------------------------------------
-# pushbullet (pushbullet.com) push notification options
-
-SEND_PUSHBULLET="YES"
-PUSHBULLET_ACCESS_TOKEN="XXXXXXXXX"
-DEFAULT_RECIPIENT_PUSHBULLET="admin1@example.com admin3@somemail.com #examplechanneltag #anotherchanneltag"
-
-```
-
-
-## Troubleshooting
-
-### Test Notification
-
-You can run the following command by hand, to test alerts configuration:
-
-```bash
-# become user netdata
-sudo su -s /bin/bash netdata
-
-# enable debugging info on the console
-export NETDATA_ALARM_NOTIFY_DEBUG=1
-
-# send test alarms to sysadmin
-/usr/libexec/netdata/plugins.d/alarm-notify.sh test
-
-# send test alarms to any role
-/usr/libexec/netdata/plugins.d/alarm-notify.sh test "ROLE"
-```
-
-Note that this will test _all_ alert mechanisms for the selected role.
-
-
diff --git a/health/notifications/pushbullet/metadata.yaml b/health/notifications/pushbullet/metadata.yaml
deleted file mode 100644
index 430033cca..000000000
--- a/health/notifications/pushbullet/metadata.yaml
+++ /dev/null
@@ -1,76 +0,0 @@
-# yamllint disable rule:line-length
----
-- id: 'notify-pushbullet'
- meta:
- name: 'Pushbullet'
- link: 'https://www.pushbullet.com/'
- categories:
- - notify.agent
- icon_filename: 'pushbullet.png'
- keywords:
- - Pushbullet
- overview:
- notification_description: |
- Send notifications to Pushbullet using Netdata's Agent alert notification feature, which supports dozens of endpoints, user roles, and more.
- notification_limitations: ''
- setup:
- prerequisites:
- list:
- - title: ''
- description: |
- - A Pushbullet access token that can be created in your [account settings](https://www.pushbullet.com/#settings/account).
- - Access to the terminal where Netdata Agent is running
- configuration:
- file:
- name: 'health_alarm_notify.conf'
- options:
- description: 'The following options can be defined for this notification'
- folding:
- title: 'Config Options'
- enabled: true
- list:
- - name: 'Send_PUSHBULLET'
- default_value: 'YES'
- description: "Set `Send_PUSHBULLET` to YES"
- required: true
- - name: 'PUSHBULLET_ACCESS_TOKEN'
- default_value: ''
- description: "set `PUSHBULLET_ACCESS_TOKEN` to the access token you generated."
- required: true
- - name: 'DEFAULT_RECIPIENT_PUSHBULLET'
- default_value: ''
- description: "Set `DEFAULT_RECIPIENT_PUSHBULLET` to the email (e.g. `example@domain.com`) or the channel tag (e.g. `#channel`) you want the alert notifications to be sent to."
- required: true
- detailed_description: |
- You can define multiple entries like this: user1@email.com user2@email.com.
-
- All roles will default to this variable if left unconfigured.
-
- The `DEFAULT_RECIPIENT_PUSHBULLET` can be edited in the following entries at the bottom of the same file:
- ```conf
- role_recipients_pushbullet[sysadmin]="user1@email.com"
- role_recipients_pushbullet[domainadmin]="user2@mail.com"
- role_recipients_pushbullet[dba]="#channel1"
- role_recipients_pushbullet[webmaster]="#channel2"
- role_recipients_pushbullet[proxyadmin]="user3@mail.com"
- role_recipients_pushbullet[sitemgr]="user4@mail.com"
- ```
- examples:
- folding:
- enabled: true
- title: ''
- list:
- - name: 'Basic Configuration'
- folding:
- enabled: false
- description: ''
- config: |
- #------------------------------------------------------------------------------
- # pushbullet (pushbullet.com) push notification options
-
- SEND_PUSHBULLET="YES"
- PUSHBULLET_ACCESS_TOKEN="XXXXXXXXX"
- DEFAULT_RECIPIENT_PUSHBULLET="admin1@example.com admin3@somemail.com #examplechanneltag #anotherchanneltag"
- troubleshooting:
- problems:
- list: []