summaryrefslogtreecommitdiffstats
path: root/health/notifications/rocketchat
diff options
context:
space:
mode:
Diffstat (limited to 'health/notifications/rocketchat')
-rw-r--r--health/notifications/rocketchat/Makefile.inc12
-rw-r--r--health/notifications/rocketchat/README.md116
-rw-r--r--health/notifications/rocketchat/metadata.yaml75
3 files changed, 0 insertions, 203 deletions
diff --git a/health/notifications/rocketchat/Makefile.inc b/health/notifications/rocketchat/Makefile.inc
deleted file mode 100644
index 58f210b6b..000000000
--- a/health/notifications/rocketchat/Makefile.inc
+++ /dev/null
@@ -1,12 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# THIS IS NOT A COMPLETE Makefile
-# IT IS INCLUDED BY ITS PARENT'S Makefile.am
-# IT IS REQUIRED TO REFERENCE ALL FILES RELATIVE TO THE PARENT
-
-# install these files
-dist_noinst_DATA += \
- rocketchat/README.md \
- rocketchat/Makefile.inc \
- $(NULL)
-
diff --git a/health/notifications/rocketchat/README.md b/health/notifications/rocketchat/README.md
deleted file mode 100644
index 59c35124a..000000000
--- a/health/notifications/rocketchat/README.md
+++ /dev/null
@@ -1,116 +0,0 @@
-<!--startmeta
-custom_edit_url: "https://github.com/netdata/netdata/edit/master/health/notifications/rocketchat/README.md"
-meta_yaml: "https://github.com/netdata/netdata/edit/master/health/notifications/rocketchat/metadata.yaml"
-sidebar_label: "RocketChat"
-learn_status: "Published"
-learn_rel_path: "Alerting/Notifications/Agent Dispatched Notifications"
-message: "DO NOT EDIT THIS FILE DIRECTLY, IT IS GENERATED BY THE NOTIFICATION'S metadata.yaml FILE"
-endmeta-->
-
-# RocketChat
-
-
-<img src="https://netdata.cloud/img/rocketchat.png" width="150"/>
-
-
-Send notifications to Rocket.Chat using Netdata's Agent alert notification feature, which supports dozens of endpoints, user roles, and more.
-
-
-
-<img src="https://img.shields.io/badge/maintained%20by-Netdata-%2300ab44" />
-
-## Setup
-
-### Prerequisites
-
-####
-
-- The incoming webhook URL as given by RocketChat. You can use the same on all your Netdata servers (or you can have multiple if you like - your decision).
-- One or more channels to post the messages to
-- Access to the terminal where Netdata Agent is running
-
-
-
-### Configuration
-
-#### File
-
-The configuration file name for this integration is `health_alarm_notify.conf`.
-
-
-You can edit the configuration file using the `edit-config` script from the
-Netdata [config directory](https://github.com/netdata/netdata/blob/master/docs/configure/nodes.md#the-netdata-config-directory).
-
-```bash
-cd /etc/netdata 2>/dev/null || cd /opt/netdata/etc/netdata
-sudo ./edit-config health_alarm_notify.conf
-```
-#### Options
-
-The following options can be defined for this notification
-
-<details><summary>Config Options</summary>
-
-| Name | Description | Default | Required |
-|:----|:-----------|:-------|:--------:|
-| SEND_ROCKETCHAT | Set `SEND_ROCKETCHAT` to `YES` | YES | yes |
-| ROCKETCHAT_WEBHOOK_URL | set `ROCKETCHAT_WEBHOOK_URL` to your webhook URL. | | yes |
-| DEFAULT_RECIPIENT_ROCKETCHAT | Set `DEFAULT_RECIPIENT_ROCKETCHAT` to the channel you want the alert notifications to be sent to. You can define multiple channels like this: `alerts` `systems`. | | yes |
-
-##### DEFAULT_RECIPIENT_ROCKETCHAT
-
-All roles will default to this variable if left unconfigured.
-
-The `DEFAULT_RECIPIENT_ROCKETCHAT` can be edited in the following entries at the bottom of the same file:
-```conf
-role_recipients_rocketchat[sysadmin]="systems"
-role_recipients_rocketchat[domainadmin]="domains"
-role_recipients_rocketchat[dba]="databases systems"
-role_recipients_rocketchat[webmaster]="marketing development"
-role_recipients_rocketchat[proxyadmin]="proxy_admin"
-role_recipients_rocketchat[sitemgr]="sites"
-```
-
-
-</details>
-
-#### Examples
-
-##### Basic Configuration
-
-
-
-```yaml
-#------------------------------------------------------------------------------
-# rocketchat (rocket.chat) global notification options
-
-SEND_ROCKETCHAT="YES"
-ROCKETCHAT_WEBHOOK_URL="<your_incoming_webhook_url>"
-DEFAULT_RECIPIENT_ROCKETCHAT="monitoring_alarms"
-
-```
-
-
-## Troubleshooting
-
-### Test Notification
-
-You can run the following command by hand, to test alerts configuration:
-
-```bash
-# become user netdata
-sudo su -s /bin/bash netdata
-
-# enable debugging info on the console
-export NETDATA_ALARM_NOTIFY_DEBUG=1
-
-# send test alarms to sysadmin
-/usr/libexec/netdata/plugins.d/alarm-notify.sh test
-
-# send test alarms to any role
-/usr/libexec/netdata/plugins.d/alarm-notify.sh test "ROLE"
-```
-
-Note that this will test _all_ alert mechanisms for the selected role.
-
-
diff --git a/health/notifications/rocketchat/metadata.yaml b/health/notifications/rocketchat/metadata.yaml
deleted file mode 100644
index f644b93e1..000000000
--- a/health/notifications/rocketchat/metadata.yaml
+++ /dev/null
@@ -1,75 +0,0 @@
-# yamllint disable rule:line-length
----
-- id: 'notify-rocketchat'
- meta:
- name: 'RocketChat'
- link: 'https://rocket.chat/'
- categories:
- - notify.agent
- icon_filename: 'rocketchat.png'
- keywords:
- - RocketChat
- overview:
- notification_description: |
- Send notifications to Rocket.Chat using Netdata's Agent alert notification feature, which supports dozens of endpoints, user roles, and more.
- notification_limitations: ''
- setup:
- prerequisites:
- list:
- - title: ''
- description: |
- - The incoming webhook URL as given by RocketChat. You can use the same on all your Netdata servers (or you can have multiple if you like - your decision).
- - One or more channels to post the messages to
- - Access to the terminal where Netdata Agent is running
- configuration:
- file:
- name: 'health_alarm_notify.conf'
- options:
- description: 'The following options can be defined for this notification'
- folding:
- title: 'Config Options'
- enabled: true
- list:
- - name: 'SEND_ROCKETCHAT'
- default_value: 'YES'
- description: "Set `SEND_ROCKETCHAT` to `YES`"
- required: true
- - name: 'ROCKETCHAT_WEBHOOK_URL'
- default_value: ''
- description: "set `ROCKETCHAT_WEBHOOK_URL` to your webhook URL."
- required: true
- - name: 'DEFAULT_RECIPIENT_ROCKETCHAT'
- default_value: ''
- description: "Set `DEFAULT_RECIPIENT_ROCKETCHAT` to the channel you want the alert notifications to be sent to. You can define multiple channels like this: `alerts` `systems`."
- required: true
- detailed_description: |
- All roles will default to this variable if left unconfigured.
-
- The `DEFAULT_RECIPIENT_ROCKETCHAT` can be edited in the following entries at the bottom of the same file:
- ```conf
- role_recipients_rocketchat[sysadmin]="systems"
- role_recipients_rocketchat[domainadmin]="domains"
- role_recipients_rocketchat[dba]="databases systems"
- role_recipients_rocketchat[webmaster]="marketing development"
- role_recipients_rocketchat[proxyadmin]="proxy_admin"
- role_recipients_rocketchat[sitemgr]="sites"
- ```
- examples:
- folding:
- enabled: true
- title: ''
- list:
- - name: 'Basic Configuration'
- folding:
- enabled: false
- description: ''
- config: |
- #------------------------------------------------------------------------------
- # rocketchat (rocket.chat) global notification options
-
- SEND_ROCKETCHAT="YES"
- ROCKETCHAT_WEBHOOK_URL="<your_incoming_webhook_url>"
- DEFAULT_RECIPIENT_ROCKETCHAT="monitoring_alarms"
- troubleshooting:
- problems:
- list: []