summaryrefslogtreecommitdiffstats
path: root/health/notifications/slack
diff options
context:
space:
mode:
Diffstat (limited to 'health/notifications/slack')
-rw-r--r--health/notifications/slack/Makefile.inc12
-rw-r--r--health/notifications/slack/README.md101
-rw-r--r--health/notifications/slack/metadata.yaml63
3 files changed, 0 insertions, 176 deletions
diff --git a/health/notifications/slack/Makefile.inc b/health/notifications/slack/Makefile.inc
deleted file mode 100644
index 043bfaf08..000000000
--- a/health/notifications/slack/Makefile.inc
+++ /dev/null
@@ -1,12 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# THIS IS NOT A COMPLETE Makefile
-# IT IS INCLUDED BY ITS PARENT'S Makefile.am
-# IT IS REQUIRED TO REFERENCE ALL FILES RELATIVE TO THE PARENT
-
-# install these files
-dist_noinst_DATA += \
- slack/README.md \
- slack/Makefile.inc \
- $(NULL)
-
diff --git a/health/notifications/slack/README.md b/health/notifications/slack/README.md
deleted file mode 100644
index dfe87f99d..000000000
--- a/health/notifications/slack/README.md
+++ /dev/null
@@ -1,101 +0,0 @@
-<!--startmeta
-custom_edit_url: "https://github.com/netdata/netdata/edit/master/health/notifications/slack/README.md"
-meta_yaml: "https://github.com/netdata/netdata/edit/master/health/notifications/slack/metadata.yaml"
-sidebar_label: "Slack"
-learn_status: "Published"
-learn_rel_path: "Alerting/Notifications/Agent Dispatched Notifications"
-message: "DO NOT EDIT THIS FILE DIRECTLY, IT IS GENERATED BY THE NOTIFICATION'S metadata.yaml FILE"
-endmeta-->
-
-# Slack
-
-
-<img src="https://netdata.cloud/img/slack.png" width="150"/>
-
-
-Send notifications to a Slack workspace using Netdata's Agent alert notification feature, which supports dozens of endpoints, user roles, and more.
-
-
-
-<img src="https://img.shields.io/badge/maintained%20by-Netdata-%2300ab44" />
-
-## Setup
-
-### Prerequisites
-
-####
-
-- Slack app along with an incoming webhook, read Slack's guide on the topic [here](https://api.slack.com/messaging/webhooks).
-- One or more channels to post the messages to
-- Access to the terminal where Netdata Agent is running
-
-
-
-### Configuration
-
-#### File
-
-The configuration file name for this integration is `health_alarm_notify.conf`.
-
-
-You can edit the configuration file using the `edit-config` script from the
-Netdata [config directory](https://github.com/netdata/netdata/blob/master/docs/configure/nodes.md#the-netdata-config-directory).
-
-```bash
-cd /etc/netdata 2>/dev/null || cd /opt/netdata/etc/netdata
-sudo ./edit-config health_alarm_notify.conf
-```
-#### Options
-
-The following options can be defined for this notification
-
-<details><summary>Config Options</summary>
-
-| Name | Description | Default | Required |
-|:----|:-----------|:-------|:--------:|
-| SEND_SLACK | Set `SEND_SLACK` to YES | YES | yes |
-| SLACK_WEBHOOK_URL | set `SLACK_WEBHOOK_URL` to your Slack app's webhook URL. | | yes |
-| DEFAULT_RECIPIENT_SLACK | Set `DEFAULT_RECIPIENT_SLACK` to the Slack channel your Slack app is set to send messages to. The syntax for channels is `#channel` or `channel`. | | yes |
-
-</details>
-
-#### Examples
-
-##### Basic Configuration
-
-
-
-```yaml
-#------------------------------------------------------------------------------
-# slack (slack.com) global notification options
-
-SEND_SLACK="YES"
-SLACK_WEBHOOK_URL="https://hooks.slack.com/services/XXXXXXXX/XXXXXXXX/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX"
-DEFAULT_RECIPIENT_SLACK="#alarms"
-
-```
-
-
-## Troubleshooting
-
-### Test Notification
-
-You can run the following command by hand, to test alerts configuration:
-
-```bash
-# become user netdata
-sudo su -s /bin/bash netdata
-
-# enable debugging info on the console
-export NETDATA_ALARM_NOTIFY_DEBUG=1
-
-# send test alarms to sysadmin
-/usr/libexec/netdata/plugins.d/alarm-notify.sh test
-
-# send test alarms to any role
-/usr/libexec/netdata/plugins.d/alarm-notify.sh test "ROLE"
-```
-
-Note that this will test _all_ alert mechanisms for the selected role.
-
-
diff --git a/health/notifications/slack/metadata.yaml b/health/notifications/slack/metadata.yaml
deleted file mode 100644
index 226c7ca37..000000000
--- a/health/notifications/slack/metadata.yaml
+++ /dev/null
@@ -1,63 +0,0 @@
-# yamllint disable rule:line-length
----
-- id: 'notify-slack'
- meta:
- name: 'Slack'
- link: 'https://slack.com/'
- categories:
- - notify.agent
- icon_filename: 'slack.png'
- keywords:
- - Slack
- overview:
- notification_description: |
- Send notifications to a Slack workspace using Netdata's Agent alert notification feature, which supports dozens of endpoints, user roles, and more.
- notification_limitations: ''
- setup:
- prerequisites:
- list:
- - title: ''
- description: |
- - Slack app along with an incoming webhook, read Slack's guide on the topic [here](https://api.slack.com/messaging/webhooks).
- - One or more channels to post the messages to
- - Access to the terminal where Netdata Agent is running
- configuration:
- file:
- name: 'health_alarm_notify.conf'
- options:
- description: 'The following options can be defined for this notification'
- folding:
- title: 'Config Options'
- enabled: true
- list:
- - name: 'SEND_SLACK'
- default_value: 'YES'
- description: "Set `SEND_SLACK` to YES"
- required: true
- - name: 'SLACK_WEBHOOK_URL'
- default_value: ''
- description: "set `SLACK_WEBHOOK_URL` to your Slack app's webhook URL."
- required: true
- - name: 'DEFAULT_RECIPIENT_SLACK'
- default_value: ''
- description: "Set `DEFAULT_RECIPIENT_SLACK` to the Slack channel your Slack app is set to send messages to. The syntax for channels is `#channel` or `channel`."
- required: true
- examples:
- folding:
- enabled: true
- title: ''
- list:
- - name: 'Basic Configuration'
- folding:
- enabled: false
- description: ''
- config: |
- #------------------------------------------------------------------------------
- # slack (slack.com) global notification options
-
- SEND_SLACK="YES"
- SLACK_WEBHOOK_URL="https://hooks.slack.com/services/XXXXXXXX/XXXXXXXX/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX"
- DEFAULT_RECIPIENT_SLACK="#alarms"
- troubleshooting:
- problems:
- list: []