summaryrefslogtreecommitdiffstats
path: root/netdata.spec.in
diff options
context:
space:
mode:
Diffstat (limited to 'netdata.spec.in')
-rw-r--r--netdata.spec.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/netdata.spec.in b/netdata.spec.in
index cbbe6ab73..1c6aa61d2 100644
--- a/netdata.spec.in
+++ b/netdata.spec.in
@@ -40,7 +40,7 @@ AutoReqProv: yes
#
# Conditional build:
%bcond_without systemd # systemd
-%bcond_with netns # build with netns support (cgroup-network)
+%bcond_without netns # build with netns support (cgroup-network)
%if 0%{?fedora} || 0%{?rhel} >= 7 || 0%{?suse_version} >= 1140
%else
@@ -504,6 +504,11 @@ rm -rf "${RPM_BUILD_ROOT}"
%attr(0750,root,netdata) %{_libexecdir}/%{name}/plugins.d/cgroup-network-helper.sh
%endif
+# ebpf plugin
+%if 0%{?_have_ebpf}
+%attr(4750,root,netdata) %{_libexecdir}/%{name}/plugins.d/ebpf.plugin
+%endif
+
# perf plugin
# This should be CAP_PERFMON once RPM finally learns about it, but needs to be CAP_SYS_ADMIN for now.
# %caps(cap_perfmon=ep) %attr(0750,root,netdata) %{_libexecdir}/%{name}/plugins.d/perf.plugin