summaryrefslogtreecommitdiffstats
path: root/packaging/makeself
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/makeself')
-rwxr-xr-xpackaging/makeself/build-static.sh10
-rwxr-xr-xpackaging/makeself/build-x86_64-static.sh2
-rwxr-xr-xpackaging/makeself/jobs/50-curl-7.78.0.install.sh2
3 files changed, 7 insertions, 7 deletions
diff --git a/packaging/makeself/build-static.sh b/packaging/makeself/build-static.sh
index e9cf620b4..e4c92a7ba 100755
--- a/packaging/makeself/build-static.sh
+++ b/packaging/makeself/build-static.sh
@@ -20,7 +20,7 @@ case ${BUILDARCH} in
;;
esac
-DOCKER_CONTAINER_NAME="netdata-package-${BUILDARCH}-static-alpine314"
+DOCKER_CONTAINER_NAME="netdata-package-${BUILDARCH}-static-alpine315"
if [ "${BUILDARCH}" != "$(uname -m)" ] && [ "$(uname -m)" = 'x86_64' ] && [ -z "${SKIP_EMULATION}" ]; then
docker run --rm --privileged multiarch/qemu-user-static --reset -p yes || exit 1
@@ -40,12 +40,12 @@ if ! docker inspect "${DOCKER_CONTAINER_NAME}" > /dev/null 2>&1; then
# inside the container and runs the script install-alpine-packages.sh
# (also inside the container)
#
- if docker inspect alpine:3.14 > /dev/null 2>&1; then
- run docker image remove alpine:3.14
- run docker pull --platform=${platform} alpine:3.14
+ if docker inspect alpine:3.15 > /dev/null 2>&1; then
+ run docker image remove alpine:3.15
+ run docker pull --platform=${platform} alpine:3.15
fi
- run docker run --platform=${platform} -v "$(pwd)":/usr/src/netdata.git:rw alpine:3.14 \
+ run docker run --platform=${platform} -v "$(pwd)":/usr/src/netdata.git:rw alpine:3.15 \
/bin/sh /usr/src/netdata.git/packaging/makeself/install-alpine-packages.sh
# save the changes made permanently
diff --git a/packaging/makeself/build-x86_64-static.sh b/packaging/makeself/build-x86_64-static.sh
index 0f5f1df14..59d2078f4 100755
--- a/packaging/makeself/build-x86_64-static.sh
+++ b/packaging/makeself/build-x86_64-static.sh
@@ -4,4 +4,4 @@
SCRIPT_DIR="$( cd "$( dirname "${BASH_SOURCE[0]}" )" &> /dev/null && pwd )"
-"${SCRIPT_DIR}/build-static.sh" x86_64
+"${SCRIPT_DIR}/build-static.sh" x86_64 "${@}"
diff --git a/packaging/makeself/jobs/50-curl-7.78.0.install.sh b/packaging/makeself/jobs/50-curl-7.78.0.install.sh
index a2bb24e2c..aeab1af68 100755
--- a/packaging/makeself/jobs/50-curl-7.78.0.install.sh
+++ b/packaging/makeself/jobs/50-curl-7.78.0.install.sh
@@ -40,7 +40,7 @@ run ./configure \
--with-openssl
# Curl autoconf does not honour the curl_LDFLAGS environment variable
-run sed -i -e "s/curl_LDFLAGS =/curl_LDFLAGS = -all-static/" src/Makefile
+run sed -i -e "s/LDFLAGS =/LDFLAGS = -all-static/" src/Makefile
run make clean
run make -j "$(nproc)"