summaryrefslogtreecommitdiffstats
path: root/packaging/repoconfig/debian
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/repoconfig/debian')
-rw-r--r--packaging/repoconfig/debian/changelog6
-rw-r--r--packaging/repoconfig/debian/compat1
-rw-r--r--packaging/repoconfig/debian/control19
-rw-r--r--packaging/repoconfig/debian/copyright10
-rwxr-xr-xpackaging/repoconfig/debian/rules21
-rw-r--r--packaging/repoconfig/debian/source/format1
6 files changed, 58 insertions, 0 deletions
diff --git a/packaging/repoconfig/debian/changelog b/packaging/repoconfig/debian/changelog
new file mode 100644
index 000000000..61d2e746b
--- /dev/null
+++ b/packaging/repoconfig/debian/changelog
@@ -0,0 +1,6 @@
+netdata-repo (1-1) unstable; urgency=medium
+
+ * Initial Release
+
+ -- Netdata Builder <bot@netdata.cloud> Mon, 14 Jun 2021 08:00:00 -0500
+
diff --git a/packaging/repoconfig/debian/compat b/packaging/repoconfig/debian/compat
new file mode 100644
index 000000000..ec635144f
--- /dev/null
+++ b/packaging/repoconfig/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/packaging/repoconfig/debian/control b/packaging/repoconfig/debian/control
new file mode 100644
index 000000000..5fdcf140b
--- /dev/null
+++ b/packaging/repoconfig/debian/control
@@ -0,0 +1,19 @@
+Source: netdata-repo
+Section: net
+Priority: optional
+Maintainer: Netdata Builder <bot@netdata.cloud>
+Standards-Version: 3.9.6
+Build-Depends: debhelper (>= 9), curl, gnupg
+Homepage: https://netdata.cloud
+
+Package: netdata-repo
+Architecture: all
+Depends: apt-transport-https, debian-archive-keyring, gnupg
+Conflicts: netdata-repo-edge
+Description: Configuration for the official Netdata Stable package repository.
+
+Package: netdata-repo-edge
+Architecture:all
+Depends: apt-transport-https, debian-archive-keyring, gnupg
+Conflicts: netdata-repo
+Description: Configuration for the official Netdata Edge package repository.
diff --git a/packaging/repoconfig/debian/copyright b/packaging/repoconfig/debian/copyright
new file mode 100644
index 000000000..193b45e6a
--- /dev/null
+++ b/packaging/repoconfig/debian/copyright
@@ -0,0 +1,10 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: Netdata
+Upstream-Contact: Costa Tsaousis <costa@netdata.cloud>
+Source: https://github.com/netdata/netdata
+
+Files: *
+Copyright: 2021 Netdata Inc.
+License: GPL-3+
+ On Debian systems, the complete text of the GNU General Public
+ License version 3 can be found in /usr/share/common-licenses/GPL-3.
diff --git a/packaging/repoconfig/debian/rules b/packaging/repoconfig/debian/rules
new file mode 100755
index 000000000..0151b96ea
--- /dev/null
+++ b/packaging/repoconfig/debian/rules
@@ -0,0 +1,21 @@
+#!/usr/bin/make -f
+
+TOP = $(CURDIR)/debian/netdata-repo
+TOP_EDGE = $(CURDIR)/debian/netdata-repo-edge
+TEMPTOP = $(CURDIR)/debian/tmp
+
+%:
+ dh $@
+
+override_dh_configure:
+ true
+
+override_dh_install:
+ mkdir -p $(TOP)/etc/apt/sources.list.d $(TOP)/etc/apt/trusted.gpg.d/
+ mv -f $(TEMPTOP)/netdata.list $(TOP)/etc/apt/sources.list.d
+ mv -f $(TEMPTOP)/netdata-archive-keyring.gpg $(TOP)/etc/apt/trusted.gpg.d
+ cp $(TEMPTOP)/netdata-repoconfig-archive-keyring.gpg $(TOP)/etc/apt/trusted.gpg.d
+ mkdir -p $(TOP_EDGE)/etc/apt/sources.list.d $(TOP_EDGE)/etc/apt/trusted.gpg.d/
+ mv -f $(TEMPTOP)/netdata-edge.list $(TOP_EDGE)/etc/apt/sources.list.d
+ mv -f $(TEMPTOP)/netdata-edge-archive-keyring.gpg $(TOP_EDGE)/etc/apt/trusted.gpg.d
+ cp $(TEMPTOP)/netdata-repoconfig-archive-keyring.gpg $(TOP_EDGE)/etc/apt/trusted.gpg.d
diff --git a/packaging/repoconfig/debian/source/format b/packaging/repoconfig/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/packaging/repoconfig/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)