summaryrefslogtreecommitdiffstats
path: root/packaging/repoconfig
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/repoconfig')
-rw-r--r--packaging/repoconfig/CMakeLists.txt4
-rw-r--r--packaging/repoconfig/deb.changelog12
-rw-r--r--packaging/repoconfig/netdata.repo.dnf8
-rw-r--r--packaging/repoconfig/netdata.repo.zypp8
-rw-r--r--packaging/repoconfig/netdata.sources.in8
-rw-r--r--packaging/repoconfig/rpm.changelog6
6 files changed, 31 insertions, 15 deletions
diff --git a/packaging/repoconfig/CMakeLists.txt b/packaging/repoconfig/CMakeLists.txt
index 415ad8807..54ac3c494 100644
--- a/packaging/repoconfig/CMakeLists.txt
+++ b/packaging/repoconfig/CMakeLists.txt
@@ -9,8 +9,8 @@ list(APPEND DEB_DISTROS debian ubuntu)
set(DEB_GPG_KEY_SOURCE "https://repo.netdata.cloud/netdatabot.gpg.key")
-set(PACKAGE_VERSION 3)
-set(PACKAGE_RELEASE 4)
+set(PACKAGE_VERSION 4)
+set(PACKAGE_RELEASE 1)
set(CPACK_THREADS 0)
set(CPACK_STRIP_FILES NO)
diff --git a/packaging/repoconfig/deb.changelog b/packaging/repoconfig/deb.changelog
index 6d1dca883..28f44705f 100644
--- a/packaging/repoconfig/deb.changelog
+++ b/packaging/repoconfig/deb.changelog
@@ -1,3 +1,15 @@
+@PKG_NAME@ (4-1) unstable; urgency=medium
+
+ * Update repositories to new subdomain
+
+ -- Austin Hemmelgarn <austin@netdata.cloud> Thu, 31 Oct 2024 11:00:00 -0400
+
+@PKG_NAME@ (3-5) unstable; urgency=medium
+
+ * Switch DEB packages to fetch repo metadata by hash.
+
+ -- Austin Hemmelgarn <austin@netdata.cloud> Thu, 12 Sep 2024 07:27:00 -0400
+
@PKG_NAME@ (3-4) unstable; urgency=medium
* Convert sources to DEB822 format
diff --git a/packaging/repoconfig/netdata.repo.dnf b/packaging/repoconfig/netdata.repo.dnf
index 3a64a2a58..42fed9b48 100644
--- a/packaging/repoconfig/netdata.repo.dnf
+++ b/packaging/repoconfig/netdata.repo.dnf
@@ -1,19 +1,19 @@
[netdata]
name=Netdata
-baseurl=https://repo.netdata.cloud/repos/@VARIANT@/@DIST_NAME@/@DIST_VERSION@/$basearch
+baseurl=https://repository.netdata.cloud/repos/@VARIANT@/@DIST_NAME@/@DIST_VERSION@/$basearch
repo_gpgcheck=1
gpgcheck=1
-gpgkey=https://repo.netdata.cloud/netdatabot.gpg.key
+gpgkey=https://repository.netdata.cloud/netdatabot.gpg.key
enabled=1
sslverify=1
priority=50
[netdata-repoconfig]
name=Netdata Repository Config
-baseurl=https://repo.netdata.cloud/repos/repoconfig/@DIST_NAME@/@DIST_VERSION@/$basearch
+baseurl=https://repository.netdata.cloud/repos/repoconfig/@DIST_NAME@/@DIST_VERSION@/$basearch
repo_gpgcheck=1
gpgcheck=1
-gpgkey=https://repo.netdata.cloud/netdatabot.gpg.key
+gpgkey=https://repository.netdata.cloud/netdatabot.gpg.key
enabled=1
sslverify=1
priority=50
diff --git a/packaging/repoconfig/netdata.repo.zypp b/packaging/repoconfig/netdata.repo.zypp
index 9ab847343..c352f9c4e 100644
--- a/packaging/repoconfig/netdata.repo.zypp
+++ b/packaging/repoconfig/netdata.repo.zypp
@@ -1,19 +1,19 @@
[netdata]
name=Netdata
-baseurl=https://repo.netdata.cloud/repos/@VARIANT@/@DIST_NAME@/@DIST_VERSION@/$basearch
+baseurl=https://repository.netdata.cloud/repos/@VARIANT@/@DIST_NAME@/@DIST_VERSION@/$basearch
repo_gpgcheck=1
pkg_gpgcheck=1
-gpgkey=https://repo.netdata.cloud/netdatabot.gpg.key
+gpgkey=https://repository.netdata.cloud/netdatabot.gpg.key
enabled=1
type=rpm-md
autorefresh=1
[netdata-repoconfig]
name=Netdata Repoconfig
-baseurl=https://repo.netdata.cloud/repos/repoconfig/@DIST_NAME@/@DIST_VERSION@/$basearch
+baseurl=https://repository.netdata.cloud/repos/repoconfig/@DIST_NAME@/@DIST_VERSION@/$basearch
repo_gpgcheck=1
pkg_gpgcheck=1
-gpgkey=https://repo.netdata.cloud/netdatabot.gpg.key
+gpgkey=https://repository.netdata.cloud/netdatabot.gpg.key
enabled=1
type=rpm-md
autorefresh=1
diff --git a/packaging/repoconfig/netdata.sources.in b/packaging/repoconfig/netdata.sources.in
index 926b2c453..6579a4f0e 100644
--- a/packaging/repoconfig/netdata.sources.in
+++ b/packaging/repoconfig/netdata.sources.in
@@ -1,15 +1,15 @@
X-Repolib-Name: Netdata @VARIANT@ repository
Types: deb
-URIs: http://repo.netdata.cloud/repos/@VARIANT@/@DIST_NAME@/
+URIs: http://repository.netdata.cloud/repos/@VARIANT@/@DIST_NAME@/
Suites: @SUITE@/
Signed-By: /usr/share/keyrings/netdata-archive-keyring.gpg
-By-Hash: No
+By-Hash: Yes
Enabled: Yes
X-Repolib-Name: Netdata repository configuration repository
Types: deb
-URIs: http://repo.netdata.cloud/repos/repoconfig/@DIST_NAME@/
+URIs: http://repository.netdata.cloud/repos/repoconfig/@DIST_NAME@/
Suites: @SUITE@/
Signed-By: /usr/share/keyrings/netdata-archive-keyring.gpg
-By-Hash: No
+By-Hash: Yes
Enabled: Yes
diff --git a/packaging/repoconfig/rpm.changelog b/packaging/repoconfig/rpm.changelog
index dab81a2cf..7469eb26f 100644
--- a/packaging/repoconfig/rpm.changelog
+++ b/packaging/repoconfig/rpm.changelog
@@ -1,4 +1,8 @@
-* Mon Aug 19 2024 Austin Hemmelgarn <austin@netdata.cloud
+* Thu Oct 31 2024 Austin Hemmelgarn <austin@netdata.cloud> 4-1
+- Switch repos to new subdomain.
+* Thu Sep 17 2024 Austin Hemmelgarn <austin@netdata.cloud> 3-5
+- Fix changelog formatting.
+* Mon Aug 19 2024 Austin Hemmelgarn <austin@netdata.cloud> 3-4
- Version bump to stay in sync with DEB packages.
* Fri Aug 9 2024 Austin Hemmelgarn <austin@netdata.cloud> 3-3
- Use system certificate config for Yum/DNF repos.