summaryrefslogtreecommitdiffstats
path: root/src/fluent-bit/examples/hello_world/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/fluent-bit/examples/hello_world/CMakeLists.txt')
-rw-r--r--src/fluent-bit/examples/hello_world/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/fluent-bit/examples/hello_world/CMakeLists.txt b/src/fluent-bit/examples/hello_world/CMakeLists.txt
new file mode 100644
index 000000000..2e55b75f0
--- /dev/null
+++ b/src/fluent-bit/examples/hello_world/CMakeLists.txt
@@ -0,0 +1,9 @@
+set(src
+ ${src}
+ hello_world.c
+ )
+
+find_package (Threads)
+add_executable(hello_world ${src})
+target_link_libraries(hello_world fluent-bit-shared)
+target_link_libraries(hello_world ${CMAKE_THREAD_LIBS_INIT})