summaryrefslogtreecommitdiffstats
path: root/src/fluent-bit/examples/out_lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/fluent-bit/examples/out_lib/CMakeLists.txt')
-rw-r--r--src/fluent-bit/examples/out_lib/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/fluent-bit/examples/out_lib/CMakeLists.txt b/src/fluent-bit/examples/out_lib/CMakeLists.txt
new file mode 100644
index 000000000..db04ff1c1
--- /dev/null
+++ b/src/fluent-bit/examples/out_lib/CMakeLists.txt
@@ -0,0 +1,9 @@
+set(src
+ ${src}
+ out_lib.c
+ )
+
+find_package (Threads)
+add_executable(out_lib ${src})
+target_link_libraries(out_lib fluent-bit-shared)
+target_link_libraries(out_lib ${CMAKE_THREAD_LIBS_INIT})