summaryrefslogtreecommitdiffstats
path: root/src/fluent-bit/plugins/filter_geoip2/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/fluent-bit/plugins/filter_geoip2/CMakeLists.txt')
-rw-r--r--src/fluent-bit/plugins/filter_geoip2/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/fluent-bit/plugins/filter_geoip2/CMakeLists.txt b/src/fluent-bit/plugins/filter_geoip2/CMakeLists.txt
new file mode 100644
index 000000000..b33799e79
--- /dev/null
+++ b/src/fluent-bit/plugins/filter_geoip2/CMakeLists.txt
@@ -0,0 +1,19 @@
+# libmaxminddb
+
+# The subdirectory 'libmaxminddb' was imported from the following repo.
+# (The minimum set of files required to compile geoip2.c were imported)
+#
+# https://github.com/maxmind/libmaxminddb
+#
+# We keep the exact version in the file 'libmaxminddb/VERSION',
+# Please update the content when you upgrade libmaxminddb.
+#
+option(BUILD_TESTING "" OFF)
+set(CMAKE_C_FLAGS "-std=gnu99 ${CMAKE_C_FLAGS}")
+add_subdirectory(libmaxminddb EXCLUDE_FROM_ALL)
+include_directories(libmaxminddb/include/)
+
+set(src
+ geoip2.c)
+
+FLB_PLUGIN(filter_geoip2 "${src}" "maxminddb")