summaryrefslogtreecommitdiffstats
path: root/src/fluent-bit/plugins/filter_geoip2/libmaxminddb/bin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/fluent-bit/plugins/filter_geoip2/libmaxminddb/bin/CMakeLists.txt')
-rw-r--r--src/fluent-bit/plugins/filter_geoip2/libmaxminddb/bin/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/fluent-bit/plugins/filter_geoip2/libmaxminddb/bin/CMakeLists.txt b/src/fluent-bit/plugins/filter_geoip2/libmaxminddb/bin/CMakeLists.txt
new file mode 100644
index 000000000..9026be83b
--- /dev/null
+++ b/src/fluent-bit/plugins/filter_geoip2/libmaxminddb/bin/CMakeLists.txt
@@ -0,0 +1,13 @@
+# getopt is required by mmdblookup which is not available by default on Windows
+if(NOT WIN32)
+ add_executable(mmdblookup
+ mmdblookup.c
+ )
+
+ target_link_libraries(mmdblookup maxminddb pthread)
+
+ install(
+ TARGETS mmdblookup
+ RUNTIME DESTINATION bin
+ )
+endif()