summaryrefslogtreecommitdiffstats
path: root/src/fluent-bit/plugins/in_stdin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/fluent-bit/plugins/in_stdin/CMakeLists.txt')
-rw-r--r--src/fluent-bit/plugins/in_stdin/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/fluent-bit/plugins/in_stdin/CMakeLists.txt b/src/fluent-bit/plugins/in_stdin/CMakeLists.txt
new file mode 100644
index 000000000..3c2e2bdfe
--- /dev/null
+++ b/src/fluent-bit/plugins/in_stdin/CMakeLists.txt
@@ -0,0 +1,10 @@
+# FIXME: there is something wrong when linking objects and this
+# static plugin, I should not require to link to a specific symbol
+# if the object was already linked from fluent-bit core on src/, also
+# jsmn should not be required.
+
+set(src
+ in_stdin.c
+ )
+
+FLB_PLUGIN(in_stdin "${src}" "")