summaryrefslogtreecommitdiffstats
path: root/src/fluent-bit/plugins/in_systemd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/fluent-bit/plugins/in_systemd/CMakeLists.txt')
-rw-r--r--src/fluent-bit/plugins/in_systemd/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/fluent-bit/plugins/in_systemd/CMakeLists.txt b/src/fluent-bit/plugins/in_systemd/CMakeLists.txt
new file mode 100644
index 000000000..3e52d52b7
--- /dev/null
+++ b/src/fluent-bit/plugins/in_systemd/CMakeLists.txt
@@ -0,0 +1,11 @@
+set(src
+ systemd_config.c
+ systemd.c)
+
+if(FLB_SQLDB)
+set(src
+ ${src}
+ systemd_db.c)
+endif()
+
+FLB_PLUGIN(in_systemd "${src}" ${JOURNALD_LIBRARIES})