summaryrefslogtreecommitdiffstats
path: root/src/ml/dlib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/ml/dlib/CMakeLists.txt')
-rw-r--r--src/ml/dlib/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/ml/dlib/CMakeLists.txt b/src/ml/dlib/CMakeLists.txt
new file mode 100644
index 000000000..d3cf123f6
--- /dev/null
+++ b/src/ml/dlib/CMakeLists.txt
@@ -0,0 +1,36 @@
+cmake_minimum_required(VERSION 2.8.12)
+
+
+
+
+#############################################################################
+# #
+# READ examples/CMakeLists.txt TO SEE HOW TO USE DLIB FROM C++ WITH CMAKE #
+# #
+#############################################################################
+
+
+
+
+
+get_directory_property(has_parent PARENT_DIRECTORY)
+if(NOT has_parent)
+ # When you call add_subdirectory(dlib) from a parent CMake project dlib's
+ # CMake scripts will assume you want to statically compile dlib into
+ # whatever you are building rather than create a standalone copy of dlib.
+ # This means CMake will build dlib as a static library, disable dlib's
+ # install targets so they don't clutter your project, and adjust a few other
+ # minor things that are convenient when statically building dlib as part of
+ # your own projects.
+ #
+ # On the other hand, if there is no parent CMake project or if
+ # DLIB_IN_PROJECT_BUILD is set to false, CMake will compile dlib as a normal
+ # standalone library (either shared or static, based on the state of CMake's
+ # BUILD_SHARED_LIBS flag), and include the usual install targets so you can
+ # install dlib on your computer via `make install`. Since the only reason
+ # to build this CMakeLists.txt (the one you are reading right now) by itself
+ # is if you want to install dlib, we indicate as such by setting
+ # DLIB_IN_PROJECT_BUILD to false.
+ set(DLIB_IN_PROJECT_BUILD false)
+endif()
+add_subdirectory(dlib)