summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
Diffstat (limited to 'system')
-rw-r--r--system/.install-type1
-rw-r--r--system/Makefile.am4
-rw-r--r--system/netdata.service.in1
3 files changed, 5 insertions, 1 deletions
diff --git a/system/.install-type b/system/.install-type
new file mode 100644
index 000000000..ebac7be59
--- /dev/null
+++ b/system/.install-type
@@ -0,0 +1 @@
+INSTALL_TYPE='custom'
diff --git a/system/Makefile.am b/system/Makefile.am
index 5323738c9..a88ccab65 100644
--- a/system/Makefile.am
+++ b/system/Makefile.am
@@ -23,6 +23,10 @@ dist_config_SCRIPTS = \
edit-config \
$(NULL)
+dist_config_DATA = \
+ .install-type \
+ $(NULL)
+
# Explicitly install directories to avoid permission issues due to umask
install-exec-local:
$(INSTALL) -d $(DESTDIR)$(configdir)
diff --git a/system/netdata.service.in b/system/netdata.service.in
index 1947b15d4..813b2421f 100644
--- a/system/netdata.service.in
+++ b/system/netdata.service.in
@@ -17,7 +17,6 @@ ExecStartPre=/bin/mkdir -p @localstatedir_POST@/cache/netdata
ExecStartPre=/bin/chown -R netdata:netdata @localstatedir_POST@/cache/netdata
ExecStartPre=/bin/mkdir -p @localstatedir_POST@/run/netdata
ExecStartPre=/bin/chown -R netdata:netdata @localstatedir_POST@/run/netdata
-ExecStopPost=@pluginsdir_POST@/reset_netdata_trace.sh
PermissionsStartOnly=true
# saving a big db on slow disks may need some time