summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-12-01 06:15:11 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-12-01 06:15:11 +0000
commit483926a283e118590da3f9ecfa75a8a4d62143ce (patch)
treecb77052778df9a128a8cd3ff5bf7645322a13bc5 /system
parentReleasing debian version 1.31.0-4. (diff)
downloadnetdata-483926a283e118590da3f9ecfa75a8a4d62143ce.tar.xz
netdata-483926a283e118590da3f9ecfa75a8a4d62143ce.zip
Merging upstream version 1.32.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'system')
-rw-r--r--system/.install-type1
-rw-r--r--system/Makefile.am4
-rw-r--r--system/netdata.service.in1
3 files changed, 5 insertions, 1 deletions
diff --git a/system/.install-type b/system/.install-type
new file mode 100644
index 00000000..ebac7be5
--- /dev/null
+++ b/system/.install-type
@@ -0,0 +1 @@
+INSTALL_TYPE='custom'
diff --git a/system/Makefile.am b/system/Makefile.am
index 5323738c..a88ccab6 100644
--- a/system/Makefile.am
+++ b/system/Makefile.am
@@ -23,6 +23,10 @@ dist_config_SCRIPTS = \
edit-config \
$(NULL)
+dist_config_DATA = \
+ .install-type \
+ $(NULL)
+
# Explicitly install directories to avoid permission issues due to umask
install-exec-local:
$(INSTALL) -d $(DESTDIR)$(configdir)
diff --git a/system/netdata.service.in b/system/netdata.service.in
index 1947b15d..813b2421 100644
--- a/system/netdata.service.in
+++ b/system/netdata.service.in
@@ -17,7 +17,6 @@ ExecStartPre=/bin/mkdir -p @localstatedir_POST@/cache/netdata
ExecStartPre=/bin/chown -R netdata:netdata @localstatedir_POST@/cache/netdata
ExecStartPre=/bin/mkdir -p @localstatedir_POST@/run/netdata
ExecStartPre=/bin/chown -R netdata:netdata @localstatedir_POST@/run/netdata
-ExecStopPost=@pluginsdir_POST@/reset_netdata_trace.sh
PermissionsStartOnly=true
# saving a big db on slow disks may need some time