summaryrefslogtreecommitdiffstats
path: root/web/api/formatters/ssv
diff options
context:
space:
mode:
Diffstat (limited to 'web/api/formatters/ssv')
-rw-r--r--web/api/formatters/ssv/Makefile.am8
-rw-r--r--web/api/formatters/ssv/README.md63
-rw-r--r--web/api/formatters/ssv/ssv.c45
-rw-r--r--web/api/formatters/ssv/ssv.h10
4 files changed, 0 insertions, 126 deletions
diff --git a/web/api/formatters/ssv/Makefile.am b/web/api/formatters/ssv/Makefile.am
deleted file mode 100644
index 161784b8f..000000000
--- a/web/api/formatters/ssv/Makefile.am
+++ /dev/null
@@ -1,8 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-AUTOMAKE_OPTIONS = subdir-objects
-MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
-
-dist_noinst_DATA = \
- README.md \
- $(NULL)
diff --git a/web/api/formatters/ssv/README.md b/web/api/formatters/ssv/README.md
deleted file mode 100644
index 434d56721..000000000
--- a/web/api/formatters/ssv/README.md
+++ /dev/null
@@ -1,63 +0,0 @@
-<!--
-title: "SSV formatter"
-custom_edit_url: https://github.com/netdata/netdata/edit/master/web/api/formatters/ssv/README.md
-sidebar_label: "SSV formatter"
-learn_status: "Published"
-learn_topic_type: "References"
-learn_rel_path: "Developers/Web/Api/Formatters"
--->
-
-# SSV formatter
-
-The SSV formatter sums all dimensions in [results of database queries](https://github.com/netdata/netdata/blob/master/web/api/queries/README.md)
-to a single value and returns a list of such values showing how it changes through time.
-
-It supports the following formats:
-
-| format | content type | description |
-|:----:|:----------:|:----------|
-| `ssv` | text/plain | a space separated list of values |
-| `ssvcomma` | text/plain | a comma separated list of values |
-| `array` | application/json | a JSON array |
-
-The SSV formatter respects the following API `&options=`:
-
-| option | supported | description |
-| :----:|:-------:|:----------|
-| `nonzero` | yes | to return only the dimensions that have at least a non-zero value |
-| `flip` | yes | to return the numbers older to newer (the default is newer to older) |
-| `percent` | yes | to replace all values with their percentage over the row total |
-| `abs` | yes | to turn all values positive, before using them |
-| `min2max` | yes | to return the delta from the minimum value to the maximum value (across dimensions) |
-
-## Examples
-
-Get the average system CPU utilization of the last hour, in 6 values (one every 10 minutes):
-
-```bash
-# curl -Ss 'https://registry.my-netdata.io/api/v1/data?chart=system.cpu&format=ssv&after=-3600&points=6&group=average'
-1.741352 1.6800467 1.769411 1.6761112 1.629862 1.6807968
-```
-
----
-
-Get the total mysql bandwidth (in + out) for the last hour, in 6 values (one every 10 minutes):
-
-Netdata returns bandwidth in `kilobits`.
-
-```bash
-# curl -Ss 'https://registry.my-netdata.io/api/v1/data?chart=mysql_local.net&format=ssvcomma&after=-3600&points=6&group=sum&options=abs'
-72618.7936215,72618.778889,72618.788084,72618.9195918,72618.7760612,72618.6712421
-```
-
----
-
-Get the web server max connections for the last hour, in 12 values (one every 5 minutes)
-in a JSON array:
-
-```bash
-# curl -Ss 'https://registry.my-netdata.io/api/v1/data?chart=nginx_local.connections&format=array&after=-3600&points=12&group=max'
-[278,258,268,239,259,260,243,266,278,318,264,258]
-```
-
-
diff --git a/web/api/formatters/ssv/ssv.c b/web/api/formatters/ssv/ssv.c
deleted file mode 100644
index 2eb26b459..000000000
--- a/web/api/formatters/ssv/ssv.c
+++ /dev/null
@@ -1,45 +0,0 @@
-// SPDX-License-Identifier: GPL-3.0-or-later
-
-#include "ssv.h"
-
-void rrdr2ssv(RRDR *r, BUFFER *wb, RRDR_OPTIONS options, const char *prefix, const char *separator, const char *suffix) {
- //netdata_log_info("RRD2SSV(): %s: BEGIN", r->st->id);
- long i;
-
- buffer_strcat(wb, prefix);
- long start = 0, end = rrdr_rows(r), step = 1;
- if(!(options & RRDR_OPTION_REVERSED)) {
- start = rrdr_rows(r) - 1;
- end = -1;
- step = -1;
- }
-
- // for each line in the array
- for(i = start; i != end ;i += step) {
- int all_values_are_null = 0;
- NETDATA_DOUBLE v = rrdr2value(r, i, options, &all_values_are_null, NULL);
-
- if(likely(i != start)) {
- if(r->view.min > v) r->view.min = v;
- if(r->view.max < v) r->view.max = v;
- }
- else {
- r->view.min = v;
- r->view.max = v;
- }
-
- if(likely(i != start))
- buffer_strcat(wb, separator);
-
- if(all_values_are_null) {
- if(options & RRDR_OPTION_NULL2ZERO)
- buffer_strcat(wb, "0");
- else
- buffer_strcat(wb, "null");
- }
- else
- buffer_print_netdata_double(wb, v);
- }
- buffer_strcat(wb, suffix);
- //netdata_log_info("RRD2SSV(): %s: END", r->st->id);
-}
diff --git a/web/api/formatters/ssv/ssv.h b/web/api/formatters/ssv/ssv.h
deleted file mode 100644
index f7d4a9548..000000000
--- a/web/api/formatters/ssv/ssv.h
+++ /dev/null
@@ -1,10 +0,0 @@
-// SPDX-License-Identifier: GPL-3.0-or-later
-
-#ifndef NETDATA_API_FORMATTER_SSV_H
-#define NETDATA_API_FORMATTER_SSV_H
-
-#include "../rrd2json.h"
-
-void rrdr2ssv(RRDR *r, BUFFER *wb, RRDR_OPTIONS options, const char *prefix, const char *separator, const char *suffix);
-
-#endif //NETDATA_API_FORMATTER_SSV_H