summaryrefslogtreecommitdiffstats
path: root/web/api/queries/min
diff options
context:
space:
mode:
Diffstat (limited to 'web/api/queries/min')
-rw-r--r--web/api/queries/min/Makefile.am8
-rw-r--r--web/api/queries/min/README.md42
-rw-r--r--web/api/queries/min/min.c7
-rw-r--r--web/api/queries/min/min.h59
4 files changed, 0 insertions, 116 deletions
diff --git a/web/api/queries/min/Makefile.am b/web/api/queries/min/Makefile.am
deleted file mode 100644
index 161784b8f..000000000
--- a/web/api/queries/min/Makefile.am
+++ /dev/null
@@ -1,8 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-AUTOMAKE_OPTIONS = subdir-objects
-MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
-
-dist_noinst_DATA = \
- README.md \
- $(NULL)
diff --git a/web/api/queries/min/README.md b/web/api/queries/min/README.md
deleted file mode 100644
index 67f3326ed..000000000
--- a/web/api/queries/min/README.md
+++ /dev/null
@@ -1,42 +0,0 @@
-<!--
-title: "Min"
-sidebar_label: "Min"
-custom_edit_url: https://github.com/netdata/netdata/edit/master/web/api/queries/min/README.md
-learn_status: "Published"
-learn_topic_type: "References"
-learn_rel_path: "Developers/Web/Api/Queries"
--->
-
-# Min
-
-This module finds the min value in the time-frame given.
-
-## how to use
-
-Use it in alerts like this:
-
-```
- alarm: my_alert
- on: my_chart
-lookup: min -1m unaligned of my_dimension
- warn: $this > 1000
-```
-
-`min` does not change the units. For example, if the chart units is `requests/sec`, the result
-will be again expressed in the same units.
-
-It can also be used in APIs and badges as `&group=min` in the URL.
-
-## Examples
-
-Examining last 1 minute `successful` web server responses:
-
-- ![](https://registry.my-netdata.io/api/v1/badge.svg?chart=web_log_nginx.response_statuses&options=unaligned&dimensions=success&group=min&after=-60&label=min&value_color=orange)
-- ![](https://registry.my-netdata.io/api/v1/badge.svg?chart=web_log_nginx.response_statuses&options=unaligned&dimensions=success&group=average&after=-60&label=average)
-- ![](https://registry.my-netdata.io/api/v1/badge.svg?chart=web_log_nginx.response_statuses&options=unaligned&dimensions=success&group=max&after=-60&label=max)
-
-## References
-
-- <https://en.wikipedia.org/wiki/Sample_maximum_and_minimum>.
-
-
diff --git a/web/api/queries/min/min.c b/web/api/queries/min/min.c
deleted file mode 100644
index cefa7cf31..000000000
--- a/web/api/queries/min/min.c
+++ /dev/null
@@ -1,7 +0,0 @@
-// SPDX-License-Identifier: GPL-3.0-or-later
-
-#include "min.h"
-
-// ----------------------------------------------------------------------------
-// min
-
diff --git a/web/api/queries/min/min.h b/web/api/queries/min/min.h
deleted file mode 100644
index 3c53dfd1d..000000000
--- a/web/api/queries/min/min.h
+++ /dev/null
@@ -1,59 +0,0 @@
-// SPDX-License-Identifier: GPL-3.0-or-later
-
-#ifndef NETDATA_API_QUERY_MIN_H
-#define NETDATA_API_QUERY_MIN_H
-
-#include "../query.h"
-#include "../rrdr.h"
-
-struct tg_min {
- NETDATA_DOUBLE min;
- size_t count;
-};
-
-static inline void tg_min_create(RRDR *r, const char *options __maybe_unused) {
- r->time_grouping.data = onewayalloc_callocz(r->internal.owa, 1, sizeof(struct tg_min));
-}
-
-// resets when switches dimensions
-// so, clear everything to restart
-static inline void tg_min_reset(RRDR *r) {
- struct tg_min *g = (struct tg_min *)r->time_grouping.data;
- g->min = 0;
- g->count = 0;
-}
-
-static inline void tg_min_free(RRDR *r) {
- onewayalloc_freez(r->internal.owa, r->time_grouping.data);
- r->time_grouping.data = NULL;
-}
-
-static inline void tg_min_add(RRDR *r, NETDATA_DOUBLE value) {
- struct tg_min *g = (struct tg_min *)r->time_grouping.data;
-
- if(!g->count || fabsndd(value) < fabsndd(g->min)) {
- g->min = value;
- g->count++;
- }
-}
-
-static inline NETDATA_DOUBLE tg_min_flush(RRDR *r, RRDR_VALUE_FLAGS *rrdr_value_options_ptr) {
- struct tg_min *g = (struct tg_min *)r->time_grouping.data;
-
- NETDATA_DOUBLE value;
-
- if(unlikely(!g->count)) {
- value = 0.0;
- *rrdr_value_options_ptr |= RRDR_VALUE_EMPTY;
- }
- else {
- value = g->min;
- }
-
- g->min = 0.0;
- g->count = 0;
-
- return value;
-}
-
-#endif //NETDATA_API_QUERY_MIN_H