summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 085adf8..10d16f0 100644
--- a/Makefile
+++ b/Makefile
@@ -34,6 +34,10 @@ endif
install dist: ${BUILD-DIR}
cd ${BUILD-DIR} && meson $@
+.PHONY: uninstall
+uninstall:
+ cd ${BUILD-DIR} && meson --internal uninstall
+
.PHONY: test
test: ${BUILD-DIR}
ninja -C ${BUILD-DIR} $@
@@ -45,3 +49,8 @@ rpm:
-Dsystemddir=$(shell rpm --eval '%{_unitdir}') \
-Ddocs=man -Ddocs-build=true
rpmbuild -ba ${BUILD-DIR}/nvme.spec --define "_builddir ${BUILD-DIR}" -v
+
+.PHONY: debug
+debug:
+ meson ${BUILD-DIR} --buildtype=debug
+ ninja -C ${BUILD-DIR}