summaryrefslogtreecommitdiffstats
path: root/ccan/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'ccan/meson.build')
-rw-r--r--ccan/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/ccan/meson.build b/ccan/meson.build
new file mode 100644
index 0000000..7573265
--- /dev/null
+++ b/ccan/meson.build
@@ -0,0 +1,10 @@
+sources += files([
+ 'ccan/list/list.c',
+ 'ccan/str/debug.c',
+ 'ccan/str/str.c',
+])
+
+if get_option('buildtype') == 'debug'
+ add_project_arguments('-DCCAN_LIST_DEBUG=1', language : ['c', 'cpp'])
+ add_project_arguments('-DCCAN_STR_DEBUG=1', language : ['c', 'cpp'])
+endif