summaryrefslogtreecommitdiffstats
path: root/debian/patches/debian/0002-meson-nose2.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/debian/0002-meson-nose2.patch')
-rw-r--r--debian/patches/debian/0002-meson-nose2.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/patches/debian/0002-meson-nose2.patch b/debian/patches/debian/0002-meson-nose2.patch
index 19bcc0e..914f5a3 100644
--- a/debian/patches/debian/0002-meson-nose2.patch
+++ b/debian/patches/debian/0002-meson-nose2.patch
@@ -4,12 +4,12 @@ Description: Updating meson to find /usr/bin/nose2-3 (python3).
diff -Naurp nvme-cli.orig/tests/meson.build nvme-cli/tests/meson.build
--- nvme-cli.orig/tests/meson.build
+++ nvme-cli/tests/meson.build
-@@ -24,7 +24,7 @@ tests = [
- 'nvme_get_lba_status_test',
+@@ -30,7 +30,7 @@ tests = [
+ 'nvme_get_lba_status_test.py',
]
-runtests = find_program('nose2', required : false)
+runtests = find_program('nose2-3', required : false)
if runtests.found()
- foreach t : tests
+ foreach file : infra + tests