summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..fd56a06
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ dh_auto_install -- PREFIX=/usr UDEVDIR=/lib/udev
+ # Remove build-time unique id files, instead these will be
+ # generated by the postinst script
+ rm -f debian/nvme-cli/etc/nvme/hostid
+ rm -f debian/nvme-cli/etc/nvme/hostnqn
+ rm -f debian/nvme-cli/usr/lib/dracut/dracut.conf.d/70-nvmf-autoconnect.conf
+
+override_dh_auto_test:
+ # Overriding auto test, since the tests require that the build machine
+ # has a NVME device.