summaryrefslogtreecommitdiffstats
path: root/nvme.spec.in
diff options
context:
space:
mode:
Diffstat (limited to 'nvme.spec.in')
-rw-r--r--nvme.spec.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/nvme.spec.in b/nvme.spec.in
index 74e681e..7154a87 100644
--- a/nvme.spec.in
+++ b/nvme.spec.in
@@ -7,7 +7,7 @@ Group: Development/Tools
URL: https://github.com/linux-nvme/nvme-cli/
Source: nvme-@@VERSION@@.tar.gz
Provides: nvme
-Requires(post): util-linux
+Requires(post): util-linux systemd systemd-udev
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
@@ -49,7 +49,7 @@ rm -rf $RPM_BUILD_ROOT
%post
if [ $1 -eq 1 ]; then # 1 : This package is being installed for the first time
if [ ! -s %{_sysconfdir}/nvme/hostnqn ]; then
- echo $(nvme gen-hostnqn) > %{_sysconfdir}/nvme/hostnqn
+ echo $(%{_sbindir}/nvme gen-hostnqn) > %{_sysconfdir}/nvme/hostnqn
fi
if [ ! -s %{_sysconfdir}/nvme/hostid ]; then
uuidgen > %{_sysconfdir}/nvme/hostid