summaryrefslogtreecommitdiffstats
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build19
1 files changed, 17 insertions, 2 deletions
diff --git a/tests/meson.build b/tests/meson.build
index bc49d05..6f17137 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -32,6 +32,12 @@ tests = [
runtests = find_program('nose2', required : false)
+if meson.version().version_compare('>= 0.56')
+ nvmecli_path = meson.project_build_root()
+else
+ nvmecli_path = meson.build_root()
+endif
+
if runtests.found()
foreach file : infra + tests
configure_file(
@@ -43,12 +49,21 @@ if runtests.found()
foreach t : tests
t_name = t.split('.')[0]
test(t_name, runtests,
- args: ['--verbose', '--start-dir', meson.build_root() + '/tests', t_name],
- env: ['PATH=' + meson.build_root() + ':/usr/bin:/usr/sbin'],
+ args: ['--verbose', '--start-dir', meson.current_build_dir(), t_name],
+ env: ['PATH=' + nvmecli_path + ':/usr/bin:/usr/sbin'],
timeout: 500)
endforeach
endif
+test_uint128 = executable(
+ 'test-uint128',
+ ['test-uint128.c', '../util/types.c'],
+ include_directories: [incdir, '..'],
+ dependencies: [libnvme_dep],
+)
+
+test('uint128', test_uint128)
+
python_module = import('python')
python = python_module.find_installation('python3')