summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-06-16 11:03:24 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-06-16 11:03:24 +0000
commitcd7009797f422a1df7e9fc1edf633a1ec6720b13 (patch)
tree623d2a0079912a23a15b28179f8fbdb7d6fc9a66 /Makefile
parentReleasing debian version 2.2.2-1. (diff)
downloadnvme-stas-cd7009797f422a1df7e9fc1edf633a1ec6720b13.tar.xz
nvme-stas-cd7009797f422a1df7e9fc1edf633a1ec6720b13.zip
Merging upstream version 2.3~rc1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 1d67940..c02ac77 100644
--- a/Makefile
+++ b/Makefile
@@ -26,12 +26,12 @@ ${BUILD-DIR}:
.PHONY: stas
stas: ${BUILD-DIR}
- ninja -C ${BUILD-DIR}
+ meson compile -C ${BUILD-DIR}
.PHONY: clean
clean:
ifneq ("$(wildcard ${BUILD-DIR})","")
- ninja -C ${BUILD-DIR} -t clean
+ meson compile --clean -C ${BUILD-DIR}
endif
.PHONY: purge
@@ -46,7 +46,7 @@ install: stas
.PHONY: uninstall
uninstall: ${BUILD-DIR}
- sudo ninja -C ${BUILD-DIR} uninstall
+ sudo ninja $@ -C ${BUILD-DIR}
.PHONY: dist
dist: stas
@@ -56,6 +56,7 @@ dist: stas
test: stas
meson $@ -C ${BUILD-DIR} --suite nvme-stas
+################################################################################
.PHONY: loc
loc:
@cloc --by-file --exclude-dir=${BUILD-DIR},doc,subprojects,test,utils,debian,obj-x86_64-linux-gnu,.github --exclude-lang=Markdown,"NAnt script",XML,"Bourne Again Shell",make,"Bourne Shell",Meson,YAML,XSLT .