summaryrefslogtreecommitdiffstats
path: root/doc/readthedocs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'doc/readthedocs/Makefile')
-rw-r--r--doc/readthedocs/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/doc/readthedocs/Makefile b/doc/readthedocs/Makefile
new file mode 100644
index 0000000..76911e9
--- /dev/null
+++ b/doc/readthedocs/Makefile
@@ -0,0 +1,22 @@
+# Minimal makefile for Sphinx documentation
+#
+.DEFAULT_GOAL := help
+
+# You can set these variables from the command line, and also
+# from the environment for the first two.
+SPHINXOPTS ?=
+SPHINXBUILD ?= sphinx-build
+SOURCEDIR = .
+BUILDDIR = _build
+
+# Put it first so that "make" without argument is like "make help".
+.PHONY: help
+help:
+ @$(SPHINXBUILD) -M help "$(SOURCEDIR)" "$(BUILDDIR)" $(SPHINXOPTS) $(O)
+
+
+# Catch-all target: route all unknown targets to Sphinx using the new
+# "make mode" option. $(O) is meant as a shortcut for $(SPHINXOPTS).
+.PHONY: Makefile
+%: Makefile
+ @$(SPHINXBUILD) -M $@ "$(SOURCEDIR)" "$(BUILDDIR)" $(SPHINXOPTS) $(O)