summaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/test/meson.build b/test/meson.build
index 086a3e8..ef31c63 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -46,6 +46,12 @@ if libnvme_location == '?'
else
#---------------------------------------------------------------------------
# pylint and pyflakes
+
+ # There's a bug with pylint 3.X. Tests should be run with pylint
+ # 2.17.7 (or less), which can be installed with:
+ # python3 -m pip install --upgrade pylint==2.17.7
+
+
if modules_to_lint.length() != 0
pylint = find_program('pylint', required: false)
pyflakes = find_program('pyflakes3', required: false)
@@ -59,7 +65,7 @@ else
rcfile = srce_dir / 'pylint.rc'
if pylint.found()
- test('pylint', pylint, args: ['--rcfile=' + rcfile] + modules_to_lint, env: test_env)
+ test('pylint', pylint, args: ['--rcfile=' + rcfile] + modules_to_lint + packages_to_lint, env: test_env)
else
warning('Skiping some of the tests because "pylint" is missing.')
endif