summaryrefslogtreecommitdiffstats
path: root/usr/lib/systemd/system/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'usr/lib/systemd/system/meson.build')
-rw-r--r--usr/lib/systemd/system/meson.build37
1 files changed, 37 insertions, 0 deletions
diff --git a/usr/lib/systemd/system/meson.build b/usr/lib/systemd/system/meson.build
new file mode 100644
index 0000000..0076b01
--- /dev/null
+++ b/usr/lib/systemd/system/meson.build
@@ -0,0 +1,37 @@
+# Copyright (c) 2021, Dell Inc. or its subsidiaries. All rights reserved.
+# SPDX-License-Identifier: Apache-2.0
+# See the LICENSE file for details.
+#
+# This file is part of NVMe STorage Appliance Services (nvme-stas).
+#
+# Authors: Martin Belanger <Martin.Belanger@dell.com>
+#
+sd_unit_dir = prefix / 'lib' / 'systemd' / 'system'
+
+configure_file(
+ input: 'stafd.in.service',
+ output: 'stafd.service',
+ install_dir: sd_unit_dir,
+ configuration: conf,
+)
+
+configure_file(
+ input: 'stacd.in.service',
+ output: 'stacd.service',
+ install_dir: sd_unit_dir,
+ configuration: conf,
+)
+
+configure_file(
+ input: 'stas-config@.service',
+ output: 'stas-config@.service',
+ install_dir: sd_unit_dir,
+ copy: true,
+)
+
+configure_file(
+ input: 'stas-config.target',
+ output: 'stas-config.target',
+ install_dir: sd_unit_dir,
+ copy: true,
+)