summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 15:57:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 15:57:28 +0000
commita5283f584122bbcfb9085d46f6efe18d45440719 (patch)
tree6f516f7d908a9852650b2f48f50818e0c1a3b3e0 /setup.py
parentInitial commit. (diff)
downloadnvmetcli-a5283f584122bbcfb9085d46f6efe18d45440719.tar.xz
nvmetcli-a5283f584122bbcfb9085d46f6efe18d45440719.zip
Adding upstream version 0.8.upstream/0.8upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py31
1 files changed, 31 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..2b202e8
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,31 @@
+#! /usr/bin/env python
+'''
+This file is part of ConfigShell.
+Copyright (c) 2011-2013 by Datera, Inc
+
+Licensed under the Apache License, Version 2.0 (the "License"); you may
+not use this file except in compliance with the License. You may obtain
+a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
+WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
+License for the specific language governing permissions and limitations
+under the License.
+'''
+
+from setuptools import setup
+
+setup(
+ name = 'nvmetcli',
+ version = 0.8,
+ description = 'NVMe target configuration tool',
+ license = 'Apache 2.0',
+ maintainer = 'Christoph Hellwig',
+ maintainer_email = 'hch@lst.de',
+ test_suite='nose2.collector.collector',
+ packages = ['nvmet'],
+ scripts=['nvmetcli']
+ )