summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-07-04 13:39:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-10-02 12:20:18 +0000
commitbff7ee2c0cc8d4f2e087fb3786984f042963240b (patch)
treef0c5b9df6edd092e64d67c5100b7dcf19d874f16
parentReleasing debian version 20220605-1. (diff)
downloadopen-infrastructure-compute-tools-bff7ee2c0cc8d4f2e087fb3786984f042963240b.tar.xz
open-infrastructure-compute-tools-bff7ee2c0cc8d4f2e087fb3786984f042963240b.zip
Merging upstream version 20220704.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--CHANGELOG.txt9
-rw-r--r--Makefile26
-rw-r--r--VERSION.txt2
-rwxr-xr-xshare/build-scripts/debconf2
-rw-r--r--share/man/compute-tools.7.rst6
5 files changed, 41 insertions, 4 deletions
diff --git a/CHANGELOG.txt b/CHANGELOG.txt
index 0887fe9..42ed6f1 100644
--- a/CHANGELOG.txt
+++ b/CHANGELOG.txt
@@ -1,3 +1,12 @@
+2022-07-04 Daniel Baumann <daniel.baumann@open-infrastructure.net>
+
+ * Releasing version 20220704.
+
+ [ Daniel Baumann ]
+ * Adding release related targets in Makefile.
+ * Updating links about related articles in compute-tools manpage.
+ * Reverting adding LinkLocalAddressing=no to ipv6 interfaces as its only desirable on container bridges but breaks a few other things in normal containers.
+
2022-06-05 Daniel Baumann <daniel.baumann@open-infrastructure.net>
* Releasing version 20220605.
diff --git a/Makefile b/Makefile
index 95524db..bdb8f26 100644
--- a/Makefile
+++ b/Makefile
@@ -25,6 +25,8 @@ PROGRAM = container
SCRIPTS = bin/* libexec/*/*
+VERSION := $(shell cat VERSION.txt)
+
all: build
test:
@@ -226,6 +228,28 @@ clean:
rm -f README.txt
-distclean:
+distclean: clean
+ rm -rf service-tools-$(VERSION)
reinstall: uninstall install
+
+release: distclean
+ git commit -a -s -S -m 'Releasing version $(VERSION).' || true
+ git tag -s -m 'Tagging version $(VERSION).' v$(VERSION) || true
+
+ mkdir -p $(SOFTWARE)-$(VERSION)
+ find . -mindepth 1 -maxdepth 1 -and -not -name ".git*" -and -not -name debian -and -not -name $(SOFTWARE)-$(VERSION) -exec cp \-a {} $(SOFTWARE)-$(VERSION) \;
+
+ for FORMAT in xz lzip; \
+ do \
+ EXTENSION=$$(echo $${FORMAT} | cut -b-2); \
+ tar --$${FORMAT} -cf ../$(SOFTWARE)-$(VERSION).tar.$${EXTENSION} $(SOFTWARE)-$(VERSION); \
+ sha512sum ../$(SOFTWARE)-$(VERSION).tar.$${EXTENSION} > ../$(SOFTWARE)-$(VERSION).tar.$${EXTENSION}.sha512; \
+ gpg --default-key 0xB62C61A10B93195F --armor -b ../$(SOFTWARE)-$(VERSION).tar.$${EXTENSION}; \
+ mv ../$(SOFTWARE)-$(VERSION).tar.$${EXTENSION}.asc ../$(SOFTWARE)-$(VERSION).tar.$${EXTENSION}.sig; \
+ done
+
+ rm -rf $(SOFTWARE)-$(VERSION)
+
+upload:
+ scp ../$(SOFTWARE)-$(VERSION).* get.open-infrastructure.net:/srv/get.open-infrastructure.net/software/$(SOFTWARE)/upstream
diff --git a/VERSION.txt b/VERSION.txt
index fcf7587..d929766 100644
--- a/VERSION.txt
+++ b/VERSION.txt
@@ -1 +1 @@
-20220605
+20220704
diff --git a/share/build-scripts/debconf b/share/build-scripts/debconf
index 168f985..ac5f9cd 100755
--- a/share/build-scripts/debconf
+++ b/share/build-scripts/debconf
@@ -958,7 +958,6 @@ EOF
cat >> "${DIRECTORY}/etc/systemd/network/eno${NUMBER}.network" << EOF
DHCP=no
IPv6AcceptRA=no
-LinkLocalAddressing=no
Address=${IPV6_ADDRESS}/${IPV6_NETMASK}
EOF
@@ -977,7 +976,6 @@ EOF
cat >> "${DIRECTORY}/etc/systemd/network/eno${NUMBER}.network" << EOF
DHCP=no
IPv6AcceptRA=no
-LinkLocalAddressing=no
EOF
;;
diff --git a/share/man/compute-tools.7.rst b/share/man/compute-tools.7.rst
index 95e765b..33e6aea 100644
--- a/share/man/compute-tools.7.rst
+++ b/share/man/compute-tools.7.rst
@@ -119,6 +119,12 @@ See container(1) for a list of all container commands.
Links
=====
+| * Linux Weekly News: Kernel / Containers
+| (https://lwn.net/Kernel/Index/#Containers)
+
+| * Linux Weekly News: Security / Containers
+| (https://lwn.net/Security/Index/#Containers)
+
| * 2016-02-24: Systemd vs. Docker
| (https://lwn.net/Articles/676831/)